c07cef03c8
Fri Dec 08 2000 Tim Powers <timp@redhat.com> - built for dist-7.1 Mon Jul 24 2000 Prospector <prospector@redhat.com> - rebuilt Mon Jul 10 2000 Tim Powers <timp@redhat.com> - rebuilt Mon Jul 03 2000 Prospector <bugzilla@redhat.com> - automatic rebuild Fri May 26 2000 Tim Powers <timp@redhat.com> - man pages in /usr/share/man (FHS compliant location) - grabbed spec from contrib - initial build for Powertools Wed May 12 1999 Peter Soos <sp@osb.hu> - Corrected the file and directory attributes to rebuild the package under RedHat Linux 6.0 Fri Dec 25 1998 Peter Soos <sp@osb.hu> - Corrected the file and directory attributes Tue Jun 23 1998 Peter Soos <sp@osb.hu> - Using %attr for ability to rebuild the package as an ordinary user. Wed Jun 04 1997 Timo Karjalainen <timok@iki.fi> - Reverted back to un-gzipped man-pages (Redhat style) - Added patch to compile everything cleanly - Some minor changes to specfile Thu Mar 27 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl> - new version: Patchlevel 17 had some minor bugfixes and improvements - Trailer information now put before %EOF comments if no %Trailer - psselect can now add blank pages. - Piped input works in Linux - spec file rewrited for using Buildroot, - man pages gziped.
64 lines
1.6 KiB
Diff
64 lines
1.6 KiB
Diff
--- psutils/Makefile.unix.orig Wed Mar 12 00:52:59 1997
|
|
+++ psutils/Makefile.unix Wed Jun 4 10:54:59 1997
|
|
@@ -25,10 +25,10 @@
|
|
|
|
OS = UNIX
|
|
|
|
-BINDIR = /usr/local/bin
|
|
+BINDIR = $(DESTDIR)/usr/bin
|
|
SCRIPTDIR = $(BINDIR)
|
|
-INCLUDEDIR = /usr/local/share/psutils
|
|
-PERL = /usr/local/bin/perl
|
|
+INCLUDEDIR = $(DESTDIR)/usr/lib/psutils
|
|
+PERL = /usr/bin/perl
|
|
|
|
BINMODE = 0755
|
|
MANMODE = 0644
|
|
@@ -36,10 +36,10 @@
|
|
INSTALL = install -c -m $(BINMODE)
|
|
INSTALLMAN = install -c -m $(MANMODE)
|
|
MANEXT = 1
|
|
-MANDIR = /usr/local/share/man/man$(MANEXT)
|
|
+MANDIR = $(DESTDIR)/usr/man/man$(MANEXT)
|
|
|
|
CC = gcc
|
|
-CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX -O -Wall
|
|
+CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX $(RPM_OPT_FLAGS) -Wall
|
|
|
|
BIN = psbook psselect pstops epsffit psnup \
|
|
psresize
|
|
@@ -219,28 +219,28 @@
|
|
install: install.bin install.script install.man install.include
|
|
|
|
install.bin: $(BIN)
|
|
- -mkdir $(BINDIR)
|
|
+ -mkdir -p $(BINDIR)
|
|
@for i in $(BIN); do \
|
|
echo Installing $$i; \
|
|
- $(INSTALL) $$i $(BINDIR); \
|
|
+ $(INSTALL) $$i -s $(BINDIR); \
|
|
done
|
|
|
|
install.script: $(PERLSCRIPTS) $(SHELLSCRIPTS)
|
|
- -mkdir $(SCRIPTDIR)
|
|
+ -mkdir -p $(SCRIPTDIR)
|
|
@for i in $(PERLSCRIPTS) $(SHELLSCRIPTS); do \
|
|
echo Installing $$i; \
|
|
$(INSTALL) $$i $(SCRIPTDIR); \
|
|
done
|
|
|
|
install.include: $(INCLUDES)
|
|
- -mkdir $(INCLUDEDIR)
|
|
+ -mkdir -p $(INCLUDEDIR)
|
|
@for i in $(INCLUDES); do \
|
|
echo Installing $$i; \
|
|
$(INSTALLMAN) $$i $(INCLUDEDIR); \
|
|
done
|
|
|
|
install.man: $(MANPAGES)
|
|
- -mkdir $(MANDIR)
|
|
+ -mkdir -p $(MANDIR)
|
|
@for i in $(MANPAGES); do \
|
|
echo Installing manual page for $$i; \
|
|
$(INSTALLMAN) $$i $(MANDIR)/$$i; \
|