new upstream (version 1.21)
This commit is contained in:
parent
0136e920e7
commit
d3e42a7fc0
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
psutils-p17-clean.tar.gz
|
psutils-p17-clean.tar.gz
|
||||||
|
/psutils-1.21.tar.xz
|
||||||
|
@ -1,51 +0,0 @@
|
|||||||
diff -up psutils/Makefile.unix.copyright psutils/Makefile.unix
|
|
||||||
--- psutils/Makefile.unix.copyright 2010-01-26 15:06:01.000000000 +0100
|
|
||||||
+++ psutils/Makefile.unix 2010-01-26 15:07:06.000000000 +0100
|
|
||||||
@@ -44,12 +44,12 @@ CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX -O
|
|
||||||
BIN = psbook psselect pstops epsffit psnup \
|
|
||||||
psresize
|
|
||||||
SHELLSCRIPTS = getafm showchar
|
|
||||||
-PERLSCRIPTS = fixfmps fixmacps fixpsditps fixpspps \
|
|
||||||
+PERLSCRIPTS = fixfmps fixpsditps fixpspps \
|
|
||||||
fixtpps fixwfwps fixwpps fixscribeps fixwwps \
|
|
||||||
fixdlsrps extractres includeres psmerge
|
|
||||||
MANPAGES = psbook.$(MANEXT) psselect.$(MANEXT) pstops.$(MANEXT) epsffit.$(MANEXT) psnup.$(MANEXT) \
|
|
||||||
psresize.$(MANEXT) psmerge.$(MANEXT) fixscribeps.$(MANEXT) getafm.$(MANEXT) \
|
|
||||||
- fixdlsrps.$(MANEXT) fixfmps.$(MANEXT) fixmacps.$(MANEXT) fixpsditps.$(MANEXT) \
|
|
||||||
+ fixdlsrps.$(MANEXT) fixfmps.$(MANEXT) fixpsditps.$(MANEXT) \
|
|
||||||
fixpspps.$(MANEXT) fixtpps.$(MANEXT) fixwfwps.$(MANEXT) fixwpps.$(MANEXT) \
|
|
||||||
fixwwps.$(MANEXT) extractres.$(MANEXT) includeres.$(MANEXT)
|
|
||||||
INCLUDES = md68_0.ps md71_0.ps
|
|
||||||
@@ -106,9 +106,9 @@ fixfmps: fixfmps.pl
|
|
||||||
$(PERL) maketext OS=$(OS) PERL=$(PERL) $? > $@
|
|
||||||
$(CHMOD) $(BINMODE) $@
|
|
||||||
|
|
||||||
-fixmacps: fixmacps.pl
|
|
||||||
- $(PERL) maketext OS=$(OS) PERL=$(PERL) INCLUDE=$(INCLUDEDIR) $? > $@
|
|
||||||
- $(CHMOD) $(BINMODE) $@
|
|
||||||
+#fixmacps: fixmacps.pl
|
|
||||||
+# $(PERL) maketext OS=$(OS) PERL=$(PERL) INCLUDE=$(INCLUDEDIR) $? > $@
|
|
||||||
+# $(CHMOD) $(BINMODE) $@
|
|
||||||
|
|
||||||
fixpsditps: fixpsditps.pl
|
|
||||||
$(PERL) maketext OS=$(OS) PERL=$(PERL) $? > $@
|
|
||||||
@@ -174,8 +174,8 @@ psmerge.$(MANEXT): psmerge.man
|
|
||||||
fixfmps.$(MANEXT): fixfmps.man
|
|
||||||
$(PERL) maketext "MAN=$(MANPAGES)" $? > $@
|
|
||||||
|
|
||||||
-fixmacps.$(MANEXT): fixmacps.man
|
|
||||||
- $(PERL) maketext "MAN=$(MANPAGES)" INCLUDE=$(INCLUDEDIR) $? > $@
|
|
||||||
+#fixmacps.$(MANEXT): fixmacps.man
|
|
||||||
+# $(PERL) maketext "MAN=$(MANPAGES)" INCLUDE=$(INCLUDEDIR) $? > $@
|
|
||||||
|
|
||||||
fixpsditps.$(MANEXT): fixpsditps.man
|
|
||||||
$(PERL) maketext "MAN=$(MANPAGES)" $? > $@
|
|
||||||
@@ -216,7 +216,7 @@ clean:
|
|
||||||
veryclean realclean: clean
|
|
||||||
rm -f $(BIN) $(PERLSCRIPTS) $(MANPAGES)
|
|
||||||
|
|
||||||
-install: install.bin install.script install.man install.include
|
|
||||||
+install: install.bin install.script install.man
|
|
||||||
|
|
||||||
install.bin: $(BIN)
|
|
||||||
-mkdir $(BINDIR)
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up psutils/Makefile.unix.jx psutils/Makefile.unix
|
|
||||||
--- psutils/Makefile.unix.jx 2009-07-22 15:03:58.000000000 -0400
|
|
||||||
+++ psutils/Makefile.unix 2009-07-22 15:08:21.000000000 -0400
|
|
||||||
@@ -31,7 +31,7 @@ OS = UNIX
|
|
||||||
|
|
||||||
BINDIR = $(DESTDIR)/usr/bin
|
|
||||||
SCRIPTDIR = $(BINDIR)
|
|
||||||
-INCLUDEDIR = $(DESTDIR)/usr/lib/psutils
|
|
||||||
+INCLUDEDIR = $(DESTDIR)/usr/share/psutils
|
|
||||||
PERL = /usr/bin/perl
|
|
||||||
|
|
||||||
BINMODE = 0755
|
|
@ -1,35 +0,0 @@
|
|||||||
diff -up psutils/epsffit.c.manpage psutils/epsffit.c
|
|
||||||
--- psutils/epsffit.c.manpage 2013-03-26 14:29:40.000000000 +0100
|
|
||||||
+++ psutils/epsffit.c 2013-03-26 14:31:09.828141988 +0100
|
|
||||||
@@ -34,7 +34,7 @@ static void usage(void)
|
|
||||||
{
|
|
||||||
fprintf(stderr, "%s release %d patchlevel %d\n", program, RELEASE, PATCHLEVEL);
|
|
||||||
fprintf(stderr, "Copyright (C) Angus J. C. Duggan, 1991-1995. See file LICENSE for details.\n");
|
|
||||||
- fprintf(stderr, "Usage: %s [-c] [-r] [-a] [-s] llx lly urx ury [infile [outfile]]\n",
|
|
||||||
+ fprintf(stderr, "Usage: %s [-c] [-r] [-a] [-m] [-s] llx lly urx ury [infile [outfile]]\n",
|
|
||||||
program);
|
|
||||||
exit(1);
|
|
||||||
}
|
|
||||||
diff -up psutils/psnup.man.manpage psutils/psnup.man
|
|
||||||
--- psutils/psnup.man.manpage 2013-03-26 14:29:40.000000000 +0100
|
|
||||||
+++ psutils/psnup.man 2013-03-26 14:37:24.109882610 +0100
|
|
||||||
@@ -32,7 +32,7 @@ psnup \- multiple pages per sheet
|
|
||||||
] [
|
|
||||||
.B \-s\fIscale\fR
|
|
||||||
] [
|
|
||||||
-.B \-\fInup\fR
|
|
||||||
+.B \-n\fIup\fR
|
|
||||||
] [
|
|
||||||
.B \-q
|
|
||||||
] [
|
|
||||||
diff -up psutils/psresize.man.manpage psutils/psresize.man
|
|
||||||
--- psutils/psresize.man.manpage 2013-03-26 14:29:40.193375608 +0100
|
|
||||||
+++ psutils/psresize.man 2013-03-26 14:29:40.199375526 +0100
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
.TH PSRESIZE 1 "PSUtils Release @RELEASE@ Patchlevel @PATCHLEVEL@"
|
|
||||||
.SH NAME
|
|
||||||
-psresize \- multiple pages per sheet
|
|
||||||
+psresize \- rescale and centre the pages of a PostScript file
|
|
||||||
.SH SYNOPSIS
|
|
||||||
.B psresize
|
|
||||||
[
|
|
@ -1,63 +0,0 @@
|
|||||||
--- psutils/Makefile.unix.orig Wed Mar 12 00:52:59 1997
|
|
||||||
+++ psutils/Makefile.unix Wed Jun 4 10:54:59 1997
|
|
||||||
@@ -25,10 +25,10 @@
|
|
||||||
|
|
||||||
OS = UNIX
|
|
||||||
|
|
||||||
-BINDIR = /usr/local/bin
|
|
||||||
+BINDIR = $(DESTDIR)/usr/bin
|
|
||||||
SCRIPTDIR = $(BINDIR)
|
|
||||||
-INCLUDEDIR = /usr/local/share/psutils
|
|
||||||
-PERL = /usr/local/bin/perl
|
|
||||||
+INCLUDEDIR = $(DESTDIR)/usr/lib/psutils
|
|
||||||
+PERL = /usr/bin/perl
|
|
||||||
|
|
||||||
BINMODE = 0755
|
|
||||||
MANMODE = 0644
|
|
||||||
@@ -36,10 +36,10 @@
|
|
||||||
INSTALL = install -c -m $(BINMODE)
|
|
||||||
INSTALLMAN = install -c -m $(MANMODE)
|
|
||||||
MANEXT = 1
|
|
||||||
-MANDIR = /usr/local/share/man/man$(MANEXT)
|
|
||||||
+MANDIR = $(DESTDIR)/usr/man/man$(MANEXT)
|
|
||||||
|
|
||||||
CC = gcc
|
|
||||||
-CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX -O -Wall
|
|
||||||
+CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX $(RPM_OPT_FLAGS) -Wall
|
|
||||||
|
|
||||||
BIN = psbook psselect pstops epsffit psnup \
|
|
||||||
psresize
|
|
||||||
@@ -219,28 +219,28 @@
|
|
||||||
install: install.bin install.script install.man
|
|
||||||
|
|
||||||
install.bin: $(BIN)
|
|
||||||
- -mkdir $(BINDIR)
|
|
||||||
+ -mkdir -p $(BINDIR)
|
|
||||||
@for i in $(BIN); do \
|
|
||||||
echo Installing $$i; \
|
|
||||||
- $(INSTALL) $$i $(BINDIR); \
|
|
||||||
+ $(INSTALL) $$i -s $(BINDIR); \
|
|
||||||
done
|
|
||||||
|
|
||||||
install.script: $(PERLSCRIPTS) $(SHELLSCRIPTS)
|
|
||||||
- -mkdir $(SCRIPTDIR)
|
|
||||||
+ -mkdir -p $(SCRIPTDIR)
|
|
||||||
@for i in $(PERLSCRIPTS) $(SHELLSCRIPTS); do \
|
|
||||||
echo Installing $$i; \
|
|
||||||
$(INSTALL) $$i $(SCRIPTDIR); \
|
|
||||||
done
|
|
||||||
|
|
||||||
install.include: $(INCLUDES)
|
|
||||||
- -mkdir $(INCLUDEDIR)
|
|
||||||
+ -mkdir -p $(INCLUDEDIR)
|
|
||||||
@for i in $(INCLUDES); do \
|
|
||||||
echo Installing $$i; \
|
|
||||||
$(INSTALLMAN) $$i $(INCLUDEDIR); \
|
|
||||||
done
|
|
||||||
|
|
||||||
install.man: $(MANPAGES)
|
|
||||||
- -mkdir $(MANDIR)
|
|
||||||
+ -mkdir -p $(MANDIR)
|
|
||||||
@for i in $(MANPAGES); do \
|
|
||||||
echo Installing manual page for $$i; \
|
|
||||||
$(INSTALLMAN) $$i $(MANDIR)/$$i; \
|
|
@ -1,60 +0,0 @@
|
|||||||
--- psutils/epsffit.c.orig Wed Mar 12 00:52:52 1997
|
|
||||||
+++ psutils/epsffit.c Wed Jun 4 11:02:36 1997
|
|
||||||
@@ -42,12 +42,12 @@
|
|
||||||
void main(int argc, char **argv)
|
|
||||||
{
|
|
||||||
int bbfound = 0; /* %%BoundingBox: found */
|
|
||||||
- int urx, ury, llx, lly;
|
|
||||||
+ int urx = 0, ury = 0, llx = 0, lly = 0;
|
|
||||||
int furx, fury, fllx, flly;
|
|
||||||
int showpage = 0, centre = 0, rotate = 0, aspect = 0, maximise = 0;
|
|
||||||
char buf[BUFSIZ];
|
|
||||||
- FILE *input;
|
|
||||||
- FILE *output;
|
|
||||||
+ FILE *input = stdin;
|
|
||||||
+ FILE *output = stdout;
|
|
||||||
|
|
||||||
program = *argv++; argc--;
|
|
||||||
|
|
||||||
@@ -163,9 +163,14 @@
|
|
||||||
yoffset -= lly * yscale;
|
|
||||||
}
|
|
||||||
fputs("%%EndComments\n", output);
|
|
||||||
- if (showpage)
|
|
||||||
- fputs("save /showpage{}def /copypage{}def /erasepage{}def\n", output);
|
|
||||||
- else
|
|
||||||
+ if (showpage) {
|
|
||||||
+ fputs("/startEpsffit {\n", output);
|
|
||||||
+ fputs(" /EpsffitSave {save} def\n", output);
|
|
||||||
+ fputs(" userdict 200 dict begin\n", output);
|
|
||||||
+ fputs(" /showpage{}def /copypage{}def /erasepage{}def\n", output);
|
|
||||||
+ fputs("}def\n", output);
|
|
||||||
+ fputs("startEpsffit\n", output);
|
|
||||||
+ } else
|
|
||||||
fputs("%%BeginProcSet: epsffit 1 0\n", output);
|
|
||||||
fputs("gsave\n", output);
|
|
||||||
fprintf(output, "%.3f %.3f translate\n", xoffset, yoffset);
|
|
||||||
@@ -181,7 +186,7 @@
|
|
||||||
if (bbfound) {
|
|
||||||
fputs("grestore\n", output);
|
|
||||||
if (showpage)
|
|
||||||
- fputs("restore showpage\n", output); /* just in case */
|
|
||||||
+ fputs("end EpsffitSave restore showpage\n", output); /* just in case */
|
|
||||||
} else
|
|
||||||
message(FATAL, "no %%%%BoundingBox:\n");
|
|
||||||
|
|
||||||
--- psutils/psnup.c.orig Wed Mar 12 00:53:02 1997
|
|
||||||
+++ psutils/psnup.c Wed Jun 4 11:02:36 1997
|
|
||||||
@@ -68,10 +68,10 @@
|
|
||||||
|
|
||||||
void main(int argc, char *argv[])
|
|
||||||
{
|
|
||||||
- int horiz, vert, rotate, column, flip, leftright, topbottom;
|
|
||||||
+ int horiz = 0, vert = 0, rotate = 0, column, flip, leftright, topbottom;
|
|
||||||
int nup = 1;
|
|
||||||
double draw = 0; /* draw page borders */
|
|
||||||
- double scale; /* page scale */
|
|
||||||
+ double scale = 0; /* page scale */
|
|
||||||
double uscale = 0; /* user supplied scale */
|
|
||||||
double ppwid, pphgt; /* paper dimensions */
|
|
||||||
double margin, border; /* paper & page margins */
|
|
@ -1,5 +1,5 @@
|
|||||||
--- psutils/pstops.man.paper Tue Mar 11 23:53:04 1997
|
--- psutils/pstops.1.paper Tue Mar 11 23:53:04 1997
|
||||||
+++ psutils/pstops.man Thu Jul 19 15:21:51 2001
|
+++ psutils/pstops.1 Thu Jul 19 15:21:51 2001
|
||||||
@@ -108,10 +108,11 @@
|
@@ -108,10 +108,11 @@
|
||||||
The
|
The
|
||||||
.I \-p
|
.I \-p
|
||||||
@ -117,8 +117,8 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* Make a file seekable, using temporary files if necessary */
|
/* Make a file seekable, using temporary files if necessary */
|
||||||
--- psutils/psresize.man.paper Tue Mar 11 23:53:03 1997
|
--- psutils/psresize.1.paper Tue Mar 11 23:53:03 1997
|
||||||
+++ psutils/psresize.man Thu Jul 19 15:21:51 2001
|
+++ psutils/psresize.1 Thu Jul 19 15:21:51 2001
|
||||||
@@ -42,10 +42,11 @@
|
@@ -42,10 +42,11 @@
|
||||||
The
|
The
|
||||||
.I \-p
|
.I \-p
|
||||||
@ -147,8 +147,8 @@
|
|||||||
.SH AUTHOR
|
.SH AUTHOR
|
||||||
Copyright (C) Angus J. C. Duggan 1991-1995
|
Copyright (C) Angus J. C. Duggan 1991-1995
|
||||||
.SH "SEE ALSO"
|
.SH "SEE ALSO"
|
||||||
--- psutils/psnup.man.paper Tue Mar 11 23:53:02 1997
|
--- psutils/psnup.1.paper Tue Mar 11 23:53:02 1997
|
||||||
+++ psutils/psnup.man Thu Jul 19 15:21:51 2001
|
+++ psutils/psnup.1 Thu Jul 19 15:21:51 2001
|
||||||
@@ -61,9 +61,11 @@
|
@@ -61,9 +61,11 @@
|
||||||
The
|
The
|
||||||
.I \-p
|
.I \-p
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- psutils/Makefile.unix.orig 2002-06-20 12:41:54.000000000 +0200
|
|
||||||
+++ psutils/Makefile.unix 2002-06-20 12:41:41.000000000 +0200
|
|
||||||
@@ -226,7 +226,7 @@
|
|
||||||
-mkdir -p $(BINDIR)
|
|
||||||
@for i in $(BIN); do \
|
|
||||||
echo Installing $$i; \
|
|
||||||
- $(INSTALL) $$i -s $(BINDIR); \
|
|
||||||
+ $(INSTALL) $$i $(BINDIR); \
|
|
||||||
done
|
|
||||||
|
|
||||||
install.script: $(PERLSCRIPTS) $(SHELLSCRIPTS)
|
|
@ -1,153 +0,0 @@
|
|||||||
--- psutils/psmerge.pl.new 2006-06-12 09:53:37.000000000 +0200
|
|
||||||
+++ psutils/psmerge.pl 2006-06-12 09:53:47.000000000 +0200
|
|
||||||
@@ -1,11 +1,19 @@
|
|
||||||
-@PERL@
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
+eval 'exec perl -S $0 "$@"'
|
|
||||||
+ if (1 == 0);
|
|
||||||
+
|
|
||||||
# psmerge: merge PostScript files produced by same application and setup
|
|
||||||
-# usage: psmerge [-oout.ps] [-thorough] file1.ps file2.ps ...
|
|
||||||
+# usage: psmerge [-oout.ps] file1.ps file2.ps ...
|
|
||||||
#
|
|
||||||
# Copyright (C) Angus J. C. Duggan 1991-1995
|
|
||||||
# See file LICENSE for details.
|
|
||||||
+#
|
|
||||||
+# Unbroken (or, broken in a different way that at least sometimes
|
|
||||||
+# works) by Peter Williams 2003 <peter@newton.cx>
|
|
||||||
+
|
|
||||||
|
|
||||||
-$prog = ($0 =~ s=.*/==);
|
|
||||||
+$prog = $0;
|
|
||||||
+$prog =~ s=.*/==;
|
|
||||||
|
|
||||||
while ($ARGV[0] =~ /^-/) {
|
|
||||||
$_ = shift;
|
|
||||||
@@ -14,72 +22,75 @@
|
|
||||||
print STDERR "$prog: can't open $1 for output\n";
|
|
||||||
exit 1;
|
|
||||||
}
|
|
||||||
- } elsif (/^-t(horough)?$/) {
|
|
||||||
- $thorough = 1;
|
|
||||||
} else {
|
|
||||||
- print STDERR "Usage: $prog [-oout] [-thorough] file...\n";
|
|
||||||
+ print STDERR "Usage: $prog [-oout] file1 file2...\n";
|
|
||||||
exit 1;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
$page = 0;
|
|
||||||
$first = 1;
|
|
||||||
+$seenpages = 0;
|
|
||||||
$nesting = 0;
|
|
||||||
|
|
||||||
-@header = ();
|
|
||||||
-$header = 1;
|
|
||||||
-
|
|
||||||
@trailer = ();
|
|
||||||
-$trailer = 0;
|
|
||||||
-
|
|
||||||
-@pages = ();
|
|
||||||
-@body = ();
|
|
||||||
-
|
|
||||||
-@resources = ();
|
|
||||||
-$inresource = 0;
|
|
||||||
+$trailermode = 0;
|
|
||||||
|
|
||||||
while (<>) {
|
|
||||||
- if (/^%%BeginFont:/ || /^%%BeginResource:/ || /^%%BeginProcSet:/) {
|
|
||||||
- $inresource = 1;
|
|
||||||
- push(@resources, $_);
|
|
||||||
- } elsif ($inresource) {
|
|
||||||
- push(@resources, $_);
|
|
||||||
- $inresource = 0 if /^%%EndFont/ || /^%%EndResource/ || /^%%EndProcSet/;
|
|
||||||
- } elsif (/^%%Page:/ && $nesting == 0) {
|
|
||||||
- $header = $trailer = 0;
|
|
||||||
- push(@pages, join("", @body)) if @body;
|
|
||||||
- $page++;
|
|
||||||
- @body = ("%%Page: ($page) $page\n");
|
|
||||||
- } elsif (/^%%Trailer/ && $nesting == 0) {
|
|
||||||
- push(@trailer, $_);
|
|
||||||
- push(@pages, join("", @body)) if @body;
|
|
||||||
- @body = ();
|
|
||||||
- $trailer = 1;
|
|
||||||
- $header = 0;
|
|
||||||
- } elsif ($header) {
|
|
||||||
- push(@trailer, $_);
|
|
||||||
- push(@pages, join("", @body)) if @body;
|
|
||||||
- @body = ();
|
|
||||||
- $trailer = 1;
|
|
||||||
- $header = 0;
|
|
||||||
- } elsif ($trailer) {
|
|
||||||
- if (/^%!/ || /%%EOF/) {
|
|
||||||
- $trailer = $first = 0;
|
|
||||||
- } elsif ($first) {
|
|
||||||
- push(@trailer, $_);
|
|
||||||
- }
|
|
||||||
- } elsif (/^%%BeginDocument/ || /^%%BeginBinary/ || /^%%BeginFile/) {
|
|
||||||
- push(@body, $_);
|
|
||||||
- $nesting++;
|
|
||||||
- } elsif (/^%%EndDocument/ || /^%%EndBinary/ || /^%%EndFile/) {
|
|
||||||
- push(@body, $_);
|
|
||||||
- $nesting--;
|
|
||||||
- } else {
|
|
||||||
- print $_ if $print;
|
|
||||||
- }
|
|
||||||
+ if ($seenpages == 0) {
|
|
||||||
+ if (/^%%Page:/) {
|
|
||||||
+ if ($nesting == 0) {
|
|
||||||
+ $seenpages = 1;
|
|
||||||
+ $page++;
|
|
||||||
+ print "%%Page: ($page) $page\n";
|
|
||||||
+ } else {
|
|
||||||
+ print $_;
|
|
||||||
+ }
|
|
||||||
+ } elsif ($first) {
|
|
||||||
+ if (/^%%Pages: /) {
|
|
||||||
+ print "%%Pages: (atend)\n";
|
|
||||||
+ } else {
|
|
||||||
+ print $_;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+ } elsif ($trailermode) {
|
|
||||||
+ if (/^%!/ || /%%EOF/) {
|
|
||||||
+ $seenpages = 0;
|
|
||||||
+ $first = 0;
|
|
||||||
+ $trailermode = 0;
|
|
||||||
+ } elsif ($first) {
|
|
||||||
+ push (@trailer, $_)
|
|
||||||
+ unless (/^%%Pages/);
|
|
||||||
+ }
|
|
||||||
+ } else {
|
|
||||||
+ if (/^%%Page:/) {
|
|
||||||
+ if ($nesting == 0) {
|
|
||||||
+ $seenpages = 1;
|
|
||||||
+ $page++;
|
|
||||||
+ print "%%Page: ($page) $page\n";
|
|
||||||
+ } else {
|
|
||||||
+ print $_;
|
|
||||||
+ }
|
|
||||||
+ } elsif (/^%%Trailer/ && $nesting == 0) {
|
|
||||||
+ $trailermode = 1;
|
|
||||||
+ } elsif (/^%%BeginDocument/ || /^%%BeginBinary/ || /^%%BeginFile/) {
|
|
||||||
+ push(@body, $_);
|
|
||||||
+ $nesting++;
|
|
||||||
+ print $_;
|
|
||||||
+ } elsif (/^%%EndDocument/ || /^%%EndBinary/ || /^%%EndFile/) {
|
|
||||||
+ push(@body, $_);
|
|
||||||
+ $nesting--;
|
|
||||||
+ print $_;
|
|
||||||
+ } else {
|
|
||||||
+ print $_;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
+print "%%Trailer\n";
|
|
||||||
print @trailer;
|
|
||||||
+print "%%Pages: $page\n";
|
|
||||||
+print "%%EOF\n";
|
|
||||||
|
|
||||||
exit 0;
|
|
||||||
-@END@
|
|
||||||
+
|
|
@ -1,9 +0,0 @@
|
|||||||
#!/bin/bash
|
|
||||||
archive_name=psutils-p17.tar.gz
|
|
||||||
tar xzf psutils-p17.tar.gz
|
|
||||||
rm psutils/fixmacps*
|
|
||||||
rm psutils/md68_0.ps
|
|
||||||
rm psutils/md71_0.ps
|
|
||||||
patch -p0 < psutils-copyright.patch
|
|
||||||
tar czf psutils-p17-clean.tar.gz psutils/
|
|
||||||
rm -r psutils/
|
|
100
psutils.spec
100
psutils.spec
@ -1,23 +1,21 @@
|
|||||||
Summary: PostScript Utilities
|
Summary: PostScript Utilities
|
||||||
Name: psutils
|
Name: psutils
|
||||||
Version: 1.17
|
Version: 1.21
|
||||||
Release: 43%{?dist}
|
Release: 1%{?dist}
|
||||||
License: psutils
|
License: psutils
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
# We cannot use the upstream tarball because it contains non-free files.
|
|
||||||
# To generate a clean tarball, run the psutils-remove-copyrighted-files script.
|
# wget https://github.com/rrthomas/psutils/archive/master.zip && unzip master.zip && cd psutils-master/
|
||||||
#Source: ftp://ftp.knackered.org/pub/psutils/psutils-p17.tar.gz
|
# ./bootstrap && autoreconf -vfi && ./configure && make dist-xz
|
||||||
Source0: psutils-p17-clean.tar.gz
|
Source: psutils-%{version}.tar.xz
|
||||||
Source1: psutils-remove-copyrighted-files
|
URL: https://github.com/rrthomas/psutils
|
||||||
Source2: psutils-copyright.patch
|
|
||||||
URL: http://knackered.org/angus/psutils/
|
#Patch0: psutils-p17-paper.patch
|
||||||
Patch0: psutils-p17-Makefile.patch
|
|
||||||
Patch1: psutils-p17-misc.patch
|
BuildRequires: libpaper-devel
|
||||||
Patch2: psutils-p17-paper.patch
|
|
||||||
Patch3: psutils-p17-strip.patch
|
# copylib - https://fedorahosted.org/fpc/ticket/174
|
||||||
Patch4: psutils-manpage.patch
|
Provides: bundled(gnulib)
|
||||||
Patch5: psutils-psmerge.patch
|
|
||||||
Patch6: psutils-datadir.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This archive contains some utilities for manipulating PostScript documents.
|
This archive contains some utilities for manipulating PostScript documents.
|
||||||
@ -28,79 +26,55 @@ signatures for booklet printing, and page merging for n-up printing.
|
|||||||
Summary: psutils scripts requiring perl
|
Summary: psutils scripts requiring perl
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
Requires: perl
|
||||||
|
|
||||||
%description perl
|
%description perl
|
||||||
Various scripts from the psutils distribution that require perl.
|
Various scripts from the psutils distribution that require perl.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n psutils
|
%setup -q
|
||||||
%patch0 -p1 -b .makefile
|
|
||||||
%patch1 -p1 -b .misc
|
# Do we still need this one ?
|
||||||
%patch2 -p1 -b .paper
|
#%%patch0 -p1 -b .paper
|
||||||
%patch3 -p1 -b .strip
|
|
||||||
%patch4 -p1 -b .manpage
|
|
||||||
%patch5 -p1 -b .new
|
|
||||||
%patch6 -p1 -b .datadir
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make -f Makefile.unix RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
|
%configure --disable-silent-rules
|
||||||
|
%{__make} %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make -f Makefile.unix \
|
%{__make} install DESTDIR=%{buildroot}
|
||||||
MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
|
|
||||||
DESTDIR=$RPM_BUILD_ROOT install
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README LICENSE
|
%doc README LICENSE
|
||||||
%{_bindir}/epsffit
|
%{_bindir}/epsffit
|
||||||
%{_bindir}/getafm
|
|
||||||
%{_bindir}/psbook
|
%{_bindir}/psbook
|
||||||
|
%{_bindir}/psjoin
|
||||||
%{_bindir}/psnup
|
%{_bindir}/psnup
|
||||||
%{_bindir}/psresize
|
%{_bindir}/psresize
|
||||||
%{_bindir}/psselect
|
%{_bindir}/psselect
|
||||||
%{_bindir}/pstops
|
%{_bindir}/pstops
|
||||||
%{_bindir}/showchar
|
%{_mandir}/man1/epsffit.1.gz
|
||||||
%{_mandir}/man1/epsffit.1*
|
%{_mandir}/man1/psbook.1.gz
|
||||||
%{_mandir}/man1/getafm.1*
|
%{_mandir}/man1/psjoin.1.gz
|
||||||
%{_mandir}/man1/psbook.1*
|
%{_mandir}/man1/psnup.1.gz
|
||||||
%{_mandir}/man1/psnup.1*
|
%{_mandir}/man1/psresize.1.gz
|
||||||
%{_mandir}/man1/psresize.1*
|
%{_mandir}/man1/psselect.1.gz
|
||||||
%{_mandir}/man1/psselect.1*
|
%{_mandir}/man1/pstops.1.gz
|
||||||
%{_mandir}/man1/pstops.1*
|
%{_mandir}/man1/psutils.1.gz
|
||||||
#{_mandir}/man1/showchar.1*
|
|
||||||
|
|
||||||
%files perl
|
%files perl
|
||||||
%doc LICENSE
|
%doc LICENSE
|
||||||
%{_bindir}/extractres
|
%{_bindir}/extractres
|
||||||
%{_bindir}/fixdlsrps
|
|
||||||
%{_bindir}/fixfmps
|
|
||||||
#%%{_bindir}/fixmacps
|
|
||||||
%{_bindir}/fixpsditps
|
|
||||||
%{_bindir}/fixpspps
|
|
||||||
%{_bindir}/fixscribeps
|
|
||||||
%{_bindir}/fixtpps
|
|
||||||
%{_bindir}/fixwfwps
|
|
||||||
%{_bindir}/fixwpps
|
|
||||||
%{_bindir}/fixwwps
|
|
||||||
%{_bindir}/includeres
|
%{_bindir}/includeres
|
||||||
%{_bindir}/psmerge
|
%{_mandir}/man1/extractres.1.gz
|
||||||
#%%{_datadir}/psutils
|
%{_mandir}/man1/includeres.1.gz
|
||||||
%{_mandir}/man1/extractres.1*
|
|
||||||
%{_mandir}/man1/fixdlsrps.1*
|
|
||||||
%{_mandir}/man1/fixfmps.1*
|
|
||||||
#%%{_mandir}/man1/fixmacps.1*
|
|
||||||
%{_mandir}/man1/fixpsditps.1*
|
|
||||||
%{_mandir}/man1/fixpspps.1*
|
|
||||||
%{_mandir}/man1/fixscribeps.1*
|
|
||||||
%{_mandir}/man1/fixtpps.1*
|
|
||||||
%{_mandir}/man1/fixwfwps.1*
|
|
||||||
%{_mandir}/man1/fixwpps.1*
|
|
||||||
%{_mandir}/man1/fixwwps.1*
|
|
||||||
%{_mandir}/man1/includeres.1*
|
|
||||||
%{_mandir}/man1/psmerge.1*
|
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 22 2013 Jiri Popelka <jpopelka@redhat.com> - 1.21-1
|
||||||
|
- new upstream
|
||||||
|
- version 1.21
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-43
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-43
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user