auto-import changelog data from psutils-1.17-10.src.rpm
Fri Dec 08 2000 Tim Powers <timp@redhat.com> - built for dist-7.1 Mon Jul 24 2000 Prospector <prospector@redhat.com> - rebuilt Mon Jul 10 2000 Tim Powers <timp@redhat.com> - rebuilt Mon Jul 03 2000 Prospector <bugzilla@redhat.com> - automatic rebuild Fri May 26 2000 Tim Powers <timp@redhat.com> - man pages in /usr/share/man (FHS compliant location) - grabbed spec from contrib - initial build for Powertools Wed May 12 1999 Peter Soos <sp@osb.hu> - Corrected the file and directory attributes to rebuild the package under RedHat Linux 6.0 Fri Dec 25 1998 Peter Soos <sp@osb.hu> - Corrected the file and directory attributes Tue Jun 23 1998 Peter Soos <sp@osb.hu> - Using %attr for ability to rebuild the package as an ordinary user. Wed Jun 04 1997 Timo Karjalainen <timok@iki.fi> - Reverted back to un-gzipped man-pages (Redhat style) - Added patch to compile everything cleanly - Some minor changes to specfile Thu Mar 27 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl> - new version: Patchlevel 17 had some minor bugfixes and improvements - Trailer information now put before %EOF comments if no %Trailer - psselect can now add blank pages. - Piped input works in Linux - spec file rewrited for using Buildroot, - man pages gziped.
This commit is contained in:
parent
7ed70da6e4
commit
c07cef03c8
@ -0,0 +1 @@
|
|||||||
|
psutils-p17.tar.gz
|
63
psutils-p17-Makefile.patch
Normal file
63
psutils-p17-Makefile.patch
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
--- psutils/Makefile.unix.orig Wed Mar 12 00:52:59 1997
|
||||||
|
+++ psutils/Makefile.unix Wed Jun 4 10:54:59 1997
|
||||||
|
@@ -25,10 +25,10 @@
|
||||||
|
|
||||||
|
OS = UNIX
|
||||||
|
|
||||||
|
-BINDIR = /usr/local/bin
|
||||||
|
+BINDIR = $(DESTDIR)/usr/bin
|
||||||
|
SCRIPTDIR = $(BINDIR)
|
||||||
|
-INCLUDEDIR = /usr/local/share/psutils
|
||||||
|
-PERL = /usr/local/bin/perl
|
||||||
|
+INCLUDEDIR = $(DESTDIR)/usr/lib/psutils
|
||||||
|
+PERL = /usr/bin/perl
|
||||||
|
|
||||||
|
BINMODE = 0755
|
||||||
|
MANMODE = 0644
|
||||||
|
@@ -36,10 +36,10 @@
|
||||||
|
INSTALL = install -c -m $(BINMODE)
|
||||||
|
INSTALLMAN = install -c -m $(MANMODE)
|
||||||
|
MANEXT = 1
|
||||||
|
-MANDIR = /usr/local/share/man/man$(MANEXT)
|
||||||
|
+MANDIR = $(DESTDIR)/usr/man/man$(MANEXT)
|
||||||
|
|
||||||
|
CC = gcc
|
||||||
|
-CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX -O -Wall
|
||||||
|
+CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX $(RPM_OPT_FLAGS) -Wall
|
||||||
|
|
||||||
|
BIN = psbook psselect pstops epsffit psnup \
|
||||||
|
psresize
|
||||||
|
@@ -219,28 +219,28 @@
|
||||||
|
install: install.bin install.script install.man install.include
|
||||||
|
|
||||||
|
install.bin: $(BIN)
|
||||||
|
- -mkdir $(BINDIR)
|
||||||
|
+ -mkdir -p $(BINDIR)
|
||||||
|
@for i in $(BIN); do \
|
||||||
|
echo Installing $$i; \
|
||||||
|
- $(INSTALL) $$i $(BINDIR); \
|
||||||
|
+ $(INSTALL) $$i -s $(BINDIR); \
|
||||||
|
done
|
||||||
|
|
||||||
|
install.script: $(PERLSCRIPTS) $(SHELLSCRIPTS)
|
||||||
|
- -mkdir $(SCRIPTDIR)
|
||||||
|
+ -mkdir -p $(SCRIPTDIR)
|
||||||
|
@for i in $(PERLSCRIPTS) $(SHELLSCRIPTS); do \
|
||||||
|
echo Installing $$i; \
|
||||||
|
$(INSTALL) $$i $(SCRIPTDIR); \
|
||||||
|
done
|
||||||
|
|
||||||
|
install.include: $(INCLUDES)
|
||||||
|
- -mkdir $(INCLUDEDIR)
|
||||||
|
+ -mkdir -p $(INCLUDEDIR)
|
||||||
|
@for i in $(INCLUDES); do \
|
||||||
|
echo Installing $$i; \
|
||||||
|
$(INSTALLMAN) $$i $(INCLUDEDIR); \
|
||||||
|
done
|
||||||
|
|
||||||
|
install.man: $(MANPAGES)
|
||||||
|
- -mkdir $(MANDIR)
|
||||||
|
+ -mkdir -p $(MANDIR)
|
||||||
|
@for i in $(MANPAGES); do \
|
||||||
|
echo Installing manual page for $$i; \
|
||||||
|
$(INSTALLMAN) $$i $(MANDIR)/$$i; \
|
60
psutils-p17-misc.patch
Normal file
60
psutils-p17-misc.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
--- psutils/epsffit.c.orig Wed Mar 12 00:52:52 1997
|
||||||
|
+++ psutils/epsffit.c Wed Jun 4 11:02:36 1997
|
||||||
|
@@ -42,12 +42,12 @@
|
||||||
|
void main(int argc, char **argv)
|
||||||
|
{
|
||||||
|
int bbfound = 0; /* %%BoundingBox: found */
|
||||||
|
- int urx, ury, llx, lly;
|
||||||
|
+ int urx = 0, ury = 0, llx = 0, lly = 0;
|
||||||
|
int furx, fury, fllx, flly;
|
||||||
|
int showpage = 0, centre = 0, rotate = 0, aspect = 0, maximise = 0;
|
||||||
|
char buf[BUFSIZ];
|
||||||
|
- FILE *input;
|
||||||
|
- FILE *output;
|
||||||
|
+ FILE *input = stdin;
|
||||||
|
+ FILE *output = stdout;
|
||||||
|
|
||||||
|
program = *argv++; argc--;
|
||||||
|
|
||||||
|
@@ -163,9 +163,14 @@
|
||||||
|
yoffset -= lly * yscale;
|
||||||
|
}
|
||||||
|
fputs("%%EndComments\n", output);
|
||||||
|
- if (showpage)
|
||||||
|
- fputs("save /showpage{}def /copypage{}def /erasepage{}def\n", output);
|
||||||
|
- else
|
||||||
|
+ if (showpage) {
|
||||||
|
+ fputs("/startEpsffit {\n", output);
|
||||||
|
+ fputs(" /EpsffitSave {save} def\n", output);
|
||||||
|
+ fputs(" userdict 200 dict begin\n", output);
|
||||||
|
+ fputs(" /showpage{}def /copypage{}def /erasepage{}def\n", output);
|
||||||
|
+ fputs("}def\n", output);
|
||||||
|
+ fputs("startEpsffit\n", output);
|
||||||
|
+ } else
|
||||||
|
fputs("%%BeginProcSet: epsffit 1 0\n", output);
|
||||||
|
fputs("gsave\n", output);
|
||||||
|
fprintf(output, "%.3f %.3f translate\n", xoffset, yoffset);
|
||||||
|
@@ -181,7 +186,7 @@
|
||||||
|
if (bbfound) {
|
||||||
|
fputs("grestore\n", output);
|
||||||
|
if (showpage)
|
||||||
|
- fputs("restore showpage\n", output); /* just in case */
|
||||||
|
+ fputs("end EpsffitSave restore showpage\n", output); /* just in case */
|
||||||
|
} else
|
||||||
|
message(FATAL, "no %%%%BoundingBox:\n");
|
||||||
|
|
||||||
|
--- psutils/psnup.c.orig Wed Mar 12 00:53:02 1997
|
||||||
|
+++ psutils/psnup.c Wed Jun 4 11:02:36 1997
|
||||||
|
@@ -68,10 +68,10 @@
|
||||||
|
|
||||||
|
void main(int argc, char *argv[])
|
||||||
|
{
|
||||||
|
- int horiz, vert, rotate, column, flip, leftright, topbottom;
|
||||||
|
+ int horiz = 0, vert = 0, rotate = 0, column, flip, leftright, topbottom;
|
||||||
|
int nup = 1;
|
||||||
|
double draw = 0; /* draw page borders */
|
||||||
|
- double scale; /* page scale */
|
||||||
|
+ double scale = 0; /* page scale */
|
||||||
|
double uscale = 0; /* user supplied scale */
|
||||||
|
double ppwid, pphgt; /* paper dimensions */
|
||||||
|
double margin, border; /* paper & page margins */
|
83
psutils.spec
Normal file
83
psutils.spec
Normal file
@ -0,0 +1,83 @@
|
|||||||
|
Summary: PostScript Utilities
|
||||||
|
Name: psutils
|
||||||
|
Version: 1.17
|
||||||
|
Release: 10
|
||||||
|
Copyright: distributable
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Source: ftp://ftp.dcs.ed.ac.uk/pub/ajcd/psutils-p17.tar.gz
|
||||||
|
Patch0: psutils-p17-Makefile.patch
|
||||||
|
Patch1: psutils-p17-misc.patch
|
||||||
|
BuildRoot: %{_tmppath}/psutils-root
|
||||||
|
|
||||||
|
# Patch1 derived from
|
||||||
|
# jurix.jura.uni-sb.de/pub/linux/source/networking/printing/psutils.dif
|
||||||
|
|
||||||
|
%description
|
||||||
|
This archive contains some utilities for manipulating PostScript documents.
|
||||||
|
Page selection and rearrangement are supported, including arrangement into
|
||||||
|
signatures for booklet printing, and page merging for n-up printing.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n psutils
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
make -f Makefile.unix RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
make -f Makefile.unix MANDIR=$RPM_BUILD_ROOT/usr/share/man/man1 DESTDIR=$RPM_BUILD_ROOT install
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(0644, root, root, 0755)
|
||||||
|
%doc README LICENSE
|
||||||
|
%attr(0755, root, root) /usr/bin/*
|
||||||
|
/usr/share/man/*/*
|
||||||
|
/usr/lib/psutils
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 8 2000 Tim Powers <timp@redhat.com>
|
||||||
|
- built for dist-7.1
|
||||||
|
|
||||||
|
* Mon Jul 24 2000 Prospector <prospector@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Mon Jul 03 2000 Prospector <bugzilla@redhat.com>
|
||||||
|
- automatic rebuild
|
||||||
|
|
||||||
|
* Fri May 26 2000 Tim Powers <timp@redhat.com>
|
||||||
|
- man pages in /usr/share/man (FHS compliant location)
|
||||||
|
- grabbed spec from contrib
|
||||||
|
- initial build for Powertools
|
||||||
|
|
||||||
|
* Wed May 12 1999 Peter Soos <sp@osb.hu>
|
||||||
|
- Corrected the file and directory attributes to rebuild the package
|
||||||
|
under RedHat Linux 6.0
|
||||||
|
|
||||||
|
* Fri Dec 25 1998 Peter Soos <sp@osb.hu>
|
||||||
|
- Corrected the file and directory attributes
|
||||||
|
|
||||||
|
* Tue Jun 23 1998 Peter Soos <sp@osb.hu>
|
||||||
|
- Using %attr for ability to rebuild the package as an ordinary user.
|
||||||
|
|
||||||
|
* Wed Jun 04 1997 Timo Karjalainen <timok@iki.fi>
|
||||||
|
- Reverted back to un-gzipped man-pages (Redhat style)
|
||||||
|
- Added patch to compile everything cleanly
|
||||||
|
- Some minor changes to specfile
|
||||||
|
|
||||||
|
* Thu Mar 27 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
|
||||||
|
- new version:
|
||||||
|
Patchlevel 17 had some minor bugfixes and improvements
|
||||||
|
- Trailer information now put before %%EOF comments if no %%Trailer
|
||||||
|
- psselect can now add blank pages.
|
||||||
|
- Piped input works in Linux
|
||||||
|
- spec file rewrited for using Buildroot,
|
||||||
|
- man pages gziped.
|
Loading…
Reference in New Issue
Block a user