Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/psutils.git#56def795934ff857e5a5c2f6dc9bf3e917a62dbd
This commit is contained in:
parent
f06732b37a
commit
7ff17d8d6d
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
psutils-p17-clean.tar.gz
|
||||
/psutils-1.21.tar.xz
|
||||
/psutils-1.23.tar.xz
|
||||
/psutils-2.03.tar.gz
|
||||
|
@ -1,40 +0,0 @@
|
||||
diff -up psutils-1.23/configure.paperconf psutils-1.23/configure
|
||||
--- psutils-1.23/configure.paperconf 2014-01-22 10:31:58.000000000 +0100
|
||||
+++ psutils-1.23/configure 2015-05-20 14:25:40.636115433 +0200
|
||||
@@ -15700,7 +15700,7 @@ fi
|
||||
|
||||
|
||||
if test -z "$PAPER"; then
|
||||
- PAPER=paper
|
||||
+ PAPER=paperconf
|
||||
fi
|
||||
|
||||
|
||||
diff -up psutils-1.23/psutil.c.paperconf psutils-1.23/psutil.c
|
||||
--- psutils-1.23/psutil.c.paperconf 2014-01-16 11:20:54.000000000 +0100
|
||||
+++ psutils-1.23/psutil.c 2015-05-29 13:24:12.834350330 +0200
|
||||
@@ -88,13 +87,21 @@ int paper_size(const char *paper_name, d
|
||||
int res = 0;
|
||||
if (paper_name == NULL) /* Use default paper name */
|
||||
paper_name = pgetline(PAPER);
|
||||
- if (paper_name && (cmd = xasprintf(PAPER " --unit=pt --size %s", paper_name)) && (l = pgetline(cmd)))
|
||||
- res = sscanf(l, "%lg %lg", width, height);
|
||||
+ if (paper_name && (cmd = xasprintf(PAPER " -s %s", paper_name)) && (l = pgetline(cmd)))
|
||||
+ {
|
||||
+ for (int i = 0; i < strlen(l); i++)
|
||||
+ {
|
||||
+ if (l[i] == ',')
|
||||
+ {
|
||||
+ l[i] = '.';
|
||||
+ }
|
||||
+ }
|
||||
+ res = sscanf(l, "%lg %lg", width, height);
|
||||
+ }
|
||||
free(l);
|
||||
free(cmd);
|
||||
return res == 2;
|
||||
}
|
||||
-
|
||||
/* Make a file seekable, using temporary files if necessary */
|
||||
FILE *seekable(FILE *fp)
|
||||
{
|
155
psutils.spec
155
psutils.spec
@ -1,86 +1,151 @@
|
||||
Summary: PostScript Utilities
|
||||
Name: psutils
|
||||
Version: 1.23
|
||||
Release: 18%{?dist}
|
||||
License: psutils
|
||||
|
||||
# We can't follow https://fedoraproject.org/wiki/Packaging:SourceURL#Github
|
||||
# and use upstream tarball for building because ./bootstrap downloads gnulib.
|
||||
# wget https://github.com/rrthomas/psutils/archive/master.zip && unzip master.zip && cd psutils-master/
|
||||
# ./bootstrap && autoreconf -vfi && ./configure && make dist-xz
|
||||
Source: psutils-%{version}.tar.xz
|
||||
URL: https://github.com/rrthomas/psutils
|
||||
|
||||
# BZ#1072371
|
||||
# https://github.com/rrthomas/psutils/commit/cca570c806bf4bde07f400b2bab9266e02998145
|
||||
Patch0: psutils-paperconf.patch
|
||||
# Unbundle gnulib
|
||||
%bcond_without psutils_enables_unbundling_gnulib
|
||||
|
||||
Name: psutils
|
||||
Version: 2.03
|
||||
Release: 1%{?dist}
|
||||
Summary: PostScript utilities
|
||||
# COPYING: GPLv3 text
|
||||
# epsffit.1: GPLv3+
|
||||
# epsffit.in.in: GPLv3+
|
||||
# extractres.in.in: psutils
|
||||
# includeres.in.in: psutils
|
||||
# psbook.1: GPLv3+
|
||||
# psbook.in.in: GPLv3+
|
||||
# psjoin.1: GPLv3+
|
||||
# psjoin.in.in: GPLv3+
|
||||
# psnup.in.in: GPLv3+
|
||||
# psresize.1: GPLv3+
|
||||
# psresize.in.in: GPLv3+
|
||||
# psselect.1: GPLv3+
|
||||
# psselect.in.in: GPLv3+
|
||||
# pstops.1: GPLv3+
|
||||
# pstops.in.in: GPLv3+
|
||||
# PSUtils.pm: GPLv3+
|
||||
# README: GPLv3+
|
||||
## Not in any binary package
|
||||
# aclocal.m4: FSFULLR
|
||||
# build-aux/compile: GPLv2+ with Autoconf exception
|
||||
# build-aux/config.guess: GPLv3+ with Autoconf exception
|
||||
# build-aux/config.sub: GPLv3+ with Autoconf exception
|
||||
# build-aux/depcomp: GPLv2+ with Autoconf exception
|
||||
# build-aux/install-sh: MIT
|
||||
# build-aux/missing: GPLv2+ with Autoconf exception
|
||||
# build-aux/mdate-sh: GPLv2+ with Autoconf exception
|
||||
# build-aux/test-driver: GPLv2+ with Autoconf exception
|
||||
# build-aux/texinfo.tex: GPLv3+ with TeX exception
|
||||
# configure: FSFULLR
|
||||
# INSTALL: FSFAP
|
||||
# m4/00gnulib.m4: FSFULLR
|
||||
# m4/ax_check_gnu_make.m4: FSFAP
|
||||
# m4/gnulib-common.m4: FSFULLR
|
||||
# m4/gnulib-comp.m4: GPLv3+ with Autoconf exception
|
||||
# m4/relocatable-lib.m4: FSFULLR
|
||||
# Makefile.in: FSFULLR
|
||||
# old-scripts/fixwfwps: See LICENSE
|
||||
# pre-inst-env: GPLv2+
|
||||
# pre-inst-env.in: GPLv2+
|
||||
License: GPLv3+ and psutils
|
||||
URL: https://github.com/rrthomas/%{name}
|
||||
Source: %{url}/releases/download/v%{version}/%{name}-%{version}.tar.gz
|
||||
BuildArch: noarch
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake >= 1.11
|
||||
BuildRequires: bash
|
||||
# coreutils for chmod in Makefile.am
|
||||
BuildRequires: coreutils
|
||||
# gcc is a default autoconf dependency
|
||||
BuildRequires: gcc
|
||||
%if %{with psutils_enables_unbundling_gnulib}
|
||||
BuildRequires: gnulib-devel
|
||||
%endif
|
||||
BuildRequires: grep
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: sed
|
||||
# Run-time:
|
||||
BuildRequires: paper
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl(:VERSION) >= 5.14
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(Fcntl)
|
||||
BuildRequires: perl(File::Basename)
|
||||
BuildRequires: perl(File::Copy)
|
||||
BuildRequires: perl(File::Temp)
|
||||
BuildRequires: perl(Getopt::Long)
|
||||
BuildRequires: perl(IPC::Run3)
|
||||
BuildRequires: perl(List::Util)
|
||||
BuildRequires: perl(POSIX)
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(warnings)
|
||||
# Tests:
|
||||
BuildRequires: diffutils
|
||||
# Only for building
|
||||
Provides: bundled(gnulib)%(perl -ne 'if($. == 1 and /\A(\d+)-(\d+)-(\d+)/) {print qq{ = $1$2$3}}' %{_defaultdocdir}/gnulib/ChangeLog 2>/dev/null)
|
||||
# psutils-perl was merged into psutils-2.03-1.fc34
|
||||
Provides: %{name}-perl = %{version}-%{release}
|
||||
Obsoletes: %{name}-perl < %{version}-%{release}
|
||||
Requires: paper
|
||||
|
||||
Requires: /usr/bin/paperconf
|
||||
|
||||
# copylib - https://fedorahosted.org/fpc/ticket/174
|
||||
Provides: bundled(gnulib)
|
||||
# Filter private modules
|
||||
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(PSUtils\\)
|
||||
%global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(PSUtils\\)
|
||||
|
||||
%description
|
||||
Utilities for manipulating PostScript documents.
|
||||
Page selection and rearrangement are supported, including arrangement into
|
||||
signatures for booklet printing, and page merging for n-up printing.
|
||||
|
||||
%package perl
|
||||
Summary: psutils scripts requiring perl
|
||||
BuildArch: noarch
|
||||
|
||||
%description perl
|
||||
Various scripts from the psutils distribution that require perl.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .paperconf
|
||||
# Use /usr/bin/perl instead of /usr/bin/env perl
|
||||
sed -i -e 's,/usr/bin/env perl,%{__perl},' \
|
||||
extractres psjoin
|
||||
%if %{with psutils_enables_unbundling_gnulib}
|
||||
gnulib-tool --import --no-changelog relocatable-perl
|
||||
%endif
|
||||
autoreconf -fi
|
||||
|
||||
%build
|
||||
%configure
|
||||
%{__make} %{?_smp_mflags}
|
||||
%configure --disable-relocatable
|
||||
%{make_build}
|
||||
|
||||
%install
|
||||
%{__make} install DESTDIR=%{buildroot}
|
||||
%{make_install}
|
||||
|
||||
%check
|
||||
unset PSUTILS_UNINSTALLED
|
||||
make check %{?_smp_mflags}
|
||||
|
||||
%files
|
||||
%doc README LICENSE
|
||||
%license COPYING
|
||||
# ChangeLog is not helpful
|
||||
# old-scripts excluded intentionally
|
||||
%doc README
|
||||
%{_bindir}/epsffit
|
||||
%{_bindir}/extractres
|
||||
%{_bindir}/includeres
|
||||
%{_bindir}/psbook
|
||||
%{_bindir}/psjoin
|
||||
%{_bindir}/psnup
|
||||
%{_bindir}/psresize
|
||||
%{_bindir}/psselect
|
||||
%{_bindir}/pstops
|
||||
%{_datadir}/%{name}
|
||||
%{_mandir}/man1/epsffit.1*
|
||||
%{_mandir}/man1/extractres.1*
|
||||
%{_mandir}/man1/includeres.1*
|
||||
%{_mandir}/man1/psbook.1*
|
||||
%{_mandir}/man1/psjoin.1*
|
||||
%{_mandir}/man1/psnup.1*
|
||||
%{_mandir}/man1/psresize.1*
|
||||
%{_mandir}/man1/psselect.1*
|
||||
%{_mandir}/man1/pstops.1*
|
||||
%{_mandir}/man1/psutils.1*
|
||||
|
||||
%files perl
|
||||
%doc LICENSE
|
||||
%{_bindir}/extractres
|
||||
%{_bindir}/includeres
|
||||
%{_bindir}/psjoin
|
||||
%{_mandir}/man1/extractres.1*
|
||||
%{_mandir}/man1/includeres.1*
|
||||
%{_mandir}/man1/psjoin.1*
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Oct 02 2020 Petr Pisar <ppisar@redhat.com> - 2.03-1
|
||||
- 2.03 bump
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.23-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user