remove Apple copyrighted files
This commit is contained in:
parent
5951fd3dca
commit
1340d261fb
51
psutils-copyright.patch
Normal file
51
psutils-copyright.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
diff -up psutils/Makefile.unix.copyright psutils/Makefile.unix
|
||||||
|
--- psutils/Makefile.unix.copyright 2010-01-26 15:06:01.000000000 +0100
|
||||||
|
+++ psutils/Makefile.unix 2010-01-26 15:07:06.000000000 +0100
|
||||||
|
@@ -44,12 +44,12 @@ CFLAGS = -DPAPER=\"$(PAPER)\" -DUNIX -O
|
||||||
|
BIN = psbook psselect pstops epsffit psnup \
|
||||||
|
psresize
|
||||||
|
SHELLSCRIPTS = getafm showchar
|
||||||
|
-PERLSCRIPTS = fixfmps fixmacps fixpsditps fixpspps \
|
||||||
|
+PERLSCRIPTS = fixfmps fixpsditps fixpspps \
|
||||||
|
fixtpps fixwfwps fixwpps fixscribeps fixwwps \
|
||||||
|
fixdlsrps extractres includeres psmerge
|
||||||
|
MANPAGES = psbook.$(MANEXT) psselect.$(MANEXT) pstops.$(MANEXT) epsffit.$(MANEXT) psnup.$(MANEXT) \
|
||||||
|
psresize.$(MANEXT) psmerge.$(MANEXT) fixscribeps.$(MANEXT) getafm.$(MANEXT) \
|
||||||
|
- fixdlsrps.$(MANEXT) fixfmps.$(MANEXT) fixmacps.$(MANEXT) fixpsditps.$(MANEXT) \
|
||||||
|
+ fixdlsrps.$(MANEXT) fixfmps.$(MANEXT) fixpsditps.$(MANEXT) \
|
||||||
|
fixpspps.$(MANEXT) fixtpps.$(MANEXT) fixwfwps.$(MANEXT) fixwpps.$(MANEXT) \
|
||||||
|
fixwwps.$(MANEXT) extractres.$(MANEXT) includeres.$(MANEXT)
|
||||||
|
INCLUDES = md68_0.ps md71_0.ps
|
||||||
|
@@ -106,9 +106,9 @@ fixfmps: fixfmps.pl
|
||||||
|
$(PERL) maketext OS=$(OS) PERL=$(PERL) $? > $@
|
||||||
|
$(CHMOD) $(BINMODE) $@
|
||||||
|
|
||||||
|
-fixmacps: fixmacps.pl
|
||||||
|
- $(PERL) maketext OS=$(OS) PERL=$(PERL) INCLUDE=$(INCLUDEDIR) $? > $@
|
||||||
|
- $(CHMOD) $(BINMODE) $@
|
||||||
|
+#fixmacps: fixmacps.pl
|
||||||
|
+# $(PERL) maketext OS=$(OS) PERL=$(PERL) INCLUDE=$(INCLUDEDIR) $? > $@
|
||||||
|
+# $(CHMOD) $(BINMODE) $@
|
||||||
|
|
||||||
|
fixpsditps: fixpsditps.pl
|
||||||
|
$(PERL) maketext OS=$(OS) PERL=$(PERL) $? > $@
|
||||||
|
@@ -174,8 +174,8 @@ psmerge.$(MANEXT): psmerge.man
|
||||||
|
fixfmps.$(MANEXT): fixfmps.man
|
||||||
|
$(PERL) maketext "MAN=$(MANPAGES)" $? > $@
|
||||||
|
|
||||||
|
-fixmacps.$(MANEXT): fixmacps.man
|
||||||
|
- $(PERL) maketext "MAN=$(MANPAGES)" INCLUDE=$(INCLUDEDIR) $? > $@
|
||||||
|
+#fixmacps.$(MANEXT): fixmacps.man
|
||||||
|
+# $(PERL) maketext "MAN=$(MANPAGES)" INCLUDE=$(INCLUDEDIR) $? > $@
|
||||||
|
|
||||||
|
fixpsditps.$(MANEXT): fixpsditps.man
|
||||||
|
$(PERL) maketext "MAN=$(MANPAGES)" $? > $@
|
||||||
|
@@ -216,7 +216,7 @@ clean:
|
||||||
|
veryclean realclean: clean
|
||||||
|
rm -f $(BIN) $(PERLSCRIPTS) $(MANPAGES)
|
||||||
|
|
||||||
|
-install: install.bin install.script install.man install.include
|
||||||
|
+install: install.bin install.script install.man
|
||||||
|
|
||||||
|
install.bin: $(BIN)
|
||||||
|
-mkdir $(BINDIR)
|
@ -28,7 +28,7 @@
|
|||||||
BIN = psbook psselect pstops epsffit psnup \
|
BIN = psbook psselect pstops epsffit psnup \
|
||||||
psresize
|
psresize
|
||||||
@@ -219,28 +219,28 @@
|
@@ -219,28 +219,28 @@
|
||||||
install: install.bin install.script install.man install.include
|
install: install.bin install.script install.man
|
||||||
|
|
||||||
install.bin: $(BIN)
|
install.bin: $(BIN)
|
||||||
- -mkdir $(BINDIR)
|
- -mkdir $(BINDIR)
|
||||||
|
9
psutils-remove-copyrighted-files
Normal file
9
psutils-remove-copyrighted-files
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
archive_name=psutils-p17.tar.gz
|
||||||
|
tar xzf $archive_name
|
||||||
|
rm psutils/fixmacps*
|
||||||
|
rm psutils/md68_0.ps
|
||||||
|
rm psutils/md71_0.ps
|
||||||
|
patch -p0 < psutils-copyright.patch
|
||||||
|
tar czf $archive_name psutils/
|
||||||
|
rm -r psutils/
|
19
psutils.spec
19
psutils.spec
@ -1,10 +1,12 @@
|
|||||||
Summary: PostScript Utilities
|
Summary: PostScript Utilities
|
||||||
Name: psutils
|
Name: psutils
|
||||||
Version: 1.17
|
Version: 1.17
|
||||||
Release: 33%{dist}
|
Release: 34%{dist}
|
||||||
License: psutils
|
License: psutils
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Source: psutils-p17.tar.gz
|
Source: ftp://ftp.knackered.org/pub/psutils/psutils-p17.tar.gz
|
||||||
|
Source1: psutils-remove-copyrighted-files
|
||||||
|
URL: http://www.tardis.ed.ac.uk/~ajcd/psutils/
|
||||||
Patch0: psutils-p17-Makefile.patch
|
Patch0: psutils-p17-Makefile.patch
|
||||||
Patch1: psutils-p17-misc.patch
|
Patch1: psutils-p17-misc.patch
|
||||||
Patch2: psutils-p17-paper.patch
|
Patch2: psutils-p17-paper.patch
|
||||||
@ -12,6 +14,7 @@ Patch3: psutils-p17-strip.patch
|
|||||||
Patch4: psutils-manpage.patch
|
Patch4: psutils-manpage.patch
|
||||||
Patch5: psutils-psmerge.patch
|
Patch5: psutils-psmerge.patch
|
||||||
Patch6: psutils-datadir.patch
|
Patch6: psutils-datadir.patch
|
||||||
|
Patch7: psutils-copyright.patch
|
||||||
BuildRoot: %{_tmppath}/psutils-root
|
BuildRoot: %{_tmppath}/psutils-root
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -75,7 +78,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_bindir}/extractres
|
%{_bindir}/extractres
|
||||||
%{_bindir}/fixdlsrps
|
%{_bindir}/fixdlsrps
|
||||||
%{_bindir}/fixfmps
|
%{_bindir}/fixfmps
|
||||||
%{_bindir}/fixmacps
|
#%%{_bindir}/fixmacps
|
||||||
%{_bindir}/fixpsditps
|
%{_bindir}/fixpsditps
|
||||||
%{_bindir}/fixpspps
|
%{_bindir}/fixpspps
|
||||||
%{_bindir}/fixscribeps
|
%{_bindir}/fixscribeps
|
||||||
@ -85,11 +88,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_bindir}/fixwwps
|
%{_bindir}/fixwwps
|
||||||
%{_bindir}/includeres
|
%{_bindir}/includeres
|
||||||
%{_bindir}/psmerge
|
%{_bindir}/psmerge
|
||||||
%{_datadir}/psutils
|
#%%{_datadir}/psutils
|
||||||
%{_mandir}/man1/extractres.1*
|
%{_mandir}/man1/extractres.1*
|
||||||
%{_mandir}/man1/fixdlsrps.1*
|
%{_mandir}/man1/fixdlsrps.1*
|
||||||
%{_mandir}/man1/fixfmps.1*
|
%{_mandir}/man1/fixfmps.1*
|
||||||
%{_mandir}/man1/fixmacps.1*
|
#%%{_mandir}/man1/fixmacps.1*
|
||||||
%{_mandir}/man1/fixpsditps.1*
|
%{_mandir}/man1/fixpsditps.1*
|
||||||
%{_mandir}/man1/fixpspps.1*
|
%{_mandir}/man1/fixpspps.1*
|
||||||
%{_mandir}/man1/fixscribeps.1*
|
%{_mandir}/man1/fixscribeps.1*
|
||||||
@ -102,6 +105,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 26 2010 Daniel Novotny <dnovotny@redhat.com> 1.17-34
|
||||||
|
- remove Apple copyrighted files (merge review: #226324)
|
||||||
|
- fixed URLs to upstream
|
||||||
|
|
||||||
* Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.17-33
|
* Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.17-33
|
||||||
- Convert specfile to UTF-8.
|
- Convert specfile to UTF-8.
|
||||||
|
|
||||||
@ -210,7 +217,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
- Corrected the file and directory attributes
|
- Corrected the file and directory attributes
|
||||||
|
|
||||||
* Tue Jun 23 1998 Peter Soos <sp@osb.hu>
|
* Tue Jun 23 1998 Peter Soos <sp@osb.hu>
|
||||||
- Using %attr for ability to rebuild the package as an ordinary user.
|
- Using %%attr for ability to rebuild the package as an ordinary user.
|
||||||
|
|
||||||
* Wed Jun 04 1997 Timo Karjalainen <timok@iki.fi>
|
* Wed Jun 04 1997 Timo Karjalainen <timok@iki.fi>
|
||||||
- Reverted back to un-gzipped man-pages (Redhat style)
|
- Reverted back to un-gzipped man-pages (Redhat style)
|
||||||
|
Loading…
Reference in New Issue
Block a user