- Fix parallel build (#510281)
- Remove ImageMagick support, to work around bug 507035
This commit is contained in:
parent
efabfb0c9a
commit
d773a5676b
35
pstoedit-3.45-build.patch
Normal file
35
pstoedit-3.45-build.patch
Normal file
@ -0,0 +1,35 @@
|
||||
--- pstoedit-3.45/src/Makefile.in.orig 2007-09-09 18:07:30.000000000 +0200
|
||||
+++ pstoedit-3.45/src/Makefile.in 2009-07-09 10:14:02.366021602 +0200
|
||||
@@ -329,19 +355,24 @@
|
||||
|
||||
libp2edrvstd_la_LIBADD = -L. libpstoedit.la
|
||||
libp2edrvstd_la_LDFLAGS = -no-undefined -module
|
||||
+libp2edrvstd_la_DEPENDENCIES = libpstoedit.la
|
||||
libp2edrvlplot_la_SOURCES = drvlplot.cpp drvlplot.h initlibrary.cpp
|
||||
libp2edrvlplot_la_LIBADD = $(LIBPLOTTER_LDFLAGS) -L. libpstoedit.la
|
||||
libp2edrvlplot_la_LDFLAGS = -no-undefined -module
|
||||
+libp2edrvlplot_la_DEPENDENCIES = libpstoedit.la
|
||||
libp2edrvswf_la_SOURCES = drvswf.cpp drvswf.h initlibrary.cpp
|
||||
libp2edrvswf_la_LIBADD = $(LIBMING_LDFLAGS) -L. libpstoedit.la
|
||||
libp2edrvswf_la_LDFLAGS = -no-undefined -module
|
||||
+libp2edrvswf_la_DEPENDENCIES = libpstoedit.la
|
||||
libp2edrvmagick___la_SOURCES = drvmagick++.cpp drvmagick++.h initlibrary.cpp
|
||||
libp2edrvmagick___la_LIBADD = -L. libpstoedit.la
|
||||
libp2edrvmagick___la_LDFLAGS = -no-undefined ${LIBMAGICK_LDFLAGS} -module
|
||||
+libp2edrvmagick___la_DEPENDENCIES = libpstoedit.la
|
||||
@USE_EMFBYSOURCE_FALSE@libp2edrvwmf_la_SOURCES = drvwmf.cpp drvwmf.h initlibrary.cpp
|
||||
@USE_EMFBYSOURCE_TRUE@libp2edrvwmf_la_SOURCES = emflib.cpp drvwmf.cpp drvwmf.h initlibrary.cpp
|
||||
@USE_EMFBYSOURCE_FALSE@libp2edrvwmf_la_LDFLAGS = -no-undefined $(LIBEMF_LDFLAGS) -L. libpstoedit.la -module
|
||||
@USE_EMFBYSOURCE_TRUE@libp2edrvwmf_la_LDFLAGS = -no-undefined -L. libpstoedit.la -module
|
||||
+libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
|
||||
libpstoedit_la_SOURCES = \
|
||||
dynload.cpp dynload.h \
|
||||
callgs.cpp \
|
||||
@@ -362,6 +393,7 @@
|
||||
libpstoedit_la_LDFLAGS = -no-undefined
|
||||
pstoedit_SOURCES = cmdmain.cpp
|
||||
pstoedit_LDFLAGS = -no-undefined -L. libpstoedit.la ${LIBLD_LDFLAGS}
|
||||
+pstoedit_DEPENDENCIES = libpstoedit.la
|
||||
pkginclude_HEADERS = \
|
||||
pstoedit.h \
|
||||
pstoedll.h \
|
@ -1,6 +1,6 @@
|
||||
Name: pstoedit
|
||||
Version: 3.45
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
Summary: Translates PostScript and PDF graphics into other vector formats
|
||||
|
||||
Group: Applications/Productivity
|
||||
@ -12,10 +12,11 @@ Patch1: pstoedit-3.45-quiet.patch
|
||||
Patch2: pstoedit-3.45-gcc43.patch
|
||||
Patch3: pstoedit-3.45-asy.patch
|
||||
Patch4: pstoedit-3.45-elif.patch
|
||||
# Patch5: fix parallel build
|
||||
Patch5: pstoedit-3.45-build.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: ghostscript
|
||||
BuildRequires: gd-devel
|
||||
BuildRequires: ImageMagick-c++-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: dos2unix
|
||||
BuildRequires: ghostscript
|
||||
@ -36,7 +37,6 @@ drivers
|
||||
Summary: Headers for developing programs that will use %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: ImageMagick-c++-devel
|
||||
Requires: libpng-devel
|
||||
|
||||
%description devel
|
||||
@ -51,12 +51,14 @@ applications
|
||||
%patch2 -p1 -b .gcc43
|
||||
%patch3 -p1 -b .asy
|
||||
%patch4 -p1 -b .elif
|
||||
%patch5 -p1 -b .build
|
||||
dos2unix doc/*.htm doc/readme.txt
|
||||
|
||||
|
||||
%build
|
||||
%configure --disable-static --with-emf --without-swf
|
||||
# Cannot be built in parallel
|
||||
make
|
||||
# Buildling without ImageMagick support, to work around bug 507035
|
||||
%configure --disable-static --with-emf --without-swf --without-magick
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
@ -97,6 +99,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 9 2009 Denis Leroy <denis@poolshark.org> - 3.45-8
|
||||
- Fix parallel build (#510281)
|
||||
- Remove ImageMagick support, to work around bug 507035
|
||||
|
||||
* Tue Mar 10 2009 Denis Leroy <denis@poolshark.org> - 3.45-7
|
||||
- Removed EMF BR for ia64 arch (#489412)
|
||||
- Rebuild for ImageMagick
|
||||
|
Loading…
Reference in New Issue
Block a user