Update to 22.14
This commit is contained in:
parent
9306273d3b
commit
e9fb9aa808
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
psmisc-22.10.tar.gz
|
psmisc-22.10.tar.gz
|
||||||
/psmisc-22.13.tar.gz
|
/psmisc-22.13.tar.gz
|
||||||
|
/psmisc-22.14.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/killall.c b/src/killall.c
|
|
||||||
index 8b590c2..2550fc1 100644
|
|
||||||
--- a/src/killall.c
|
|
||||||
+++ b/src/killall.c
|
|
||||||
@@ -331,7 +331,7 @@ kill_all (int signal, int names, char **namelist, struct passwd *pwent)
|
|
||||||
pgids = NULL; /* silence gcc */
|
|
||||||
else
|
|
||||||
{
|
|
||||||
- pgids = malloc (pids * sizeof (pid_t));
|
|
||||||
+ pgids = calloc (pids, sizeof (pid_t));
|
|
||||||
if (!pgids)
|
|
||||||
{
|
|
||||||
perror ("malloc");
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/peekfd.c b/src/peekfd.c
|
|
||||||
index 2c30f25..6d759b9 100644
|
|
||||||
--- a/src/peekfd.c
|
|
||||||
+++ b/src/peekfd.c
|
|
||||||
@@ -199,7 +199,7 @@ int main(int argc, char **argv)
|
|
||||||
numfds = argc - optind;
|
|
||||||
fds = malloc(sizeof(int) * numfds);
|
|
||||||
for (i = 0; i < numfds; i++)
|
|
||||||
- fds[i] = atoi(argv[optind + i + 1]);
|
|
||||||
+ fds[i] = atoi(argv[optind + i]);
|
|
||||||
}
|
|
||||||
|
|
||||||
attach(target_pid);
|
|
@ -1,53 +0,0 @@
|
|||||||
diff --git a/src/peekfd.c b/src/peekfd.c
|
|
||||||
index 6d759b9..c4a3474 100644
|
|
||||||
--- a/src/peekfd.c
|
|
||||||
+++ b/src/peekfd.c
|
|
||||||
@@ -55,6 +55,9 @@
|
|
||||||
#define REG_PARAM1 orig_gpr3
|
|
||||||
#define REG_PARAM2 gpr[4]
|
|
||||||
#define REG_PARAM3 gpr[5]
|
|
||||||
+#ifndef PT_ORIG_R3
|
|
||||||
+ #define PT_ORIG_R3 34
|
|
||||||
+#endif
|
|
||||||
#elif defined(ARM)
|
|
||||||
#ifndef __ARM_EABI__
|
|
||||||
#error arm oabi not supported
|
|
||||||
@@ -73,9 +76,6 @@
|
|
||||||
#define REG_PARAM1 regs[4]
|
|
||||||
#define REG_PARAM2 regs[5]
|
|
||||||
#define REG_PARAM3 regs[6]
|
|
||||||
-#ifndef PT_ORIG_R3
|
|
||||||
- #define PT_ORIG_R3 34
|
|
||||||
-#endif
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#define MAX_ATTACHED_PIDS 1024
|
|
||||||
@@ -222,11 +222,11 @@ int main(int argc, char **argv)
|
|
||||||
if (WIFSTOPPED(status)) {
|
|
||||||
#ifdef PPC
|
|
||||||
struct pt_regs regs;
|
|
||||||
- regs.gpr[0] = ptrace(PTRACE_PEEKUSER, pid, 4 * PT_R0, 0);
|
|
||||||
- regs.gpr[3] = ptrace(PTRACE_PEEKUSER, pid, 4 * PT_R3, 0);
|
|
||||||
- regs.gpr[4] = ptrace(PTRACE_PEEKUSER, pid, 4 * PT_R4, 0);
|
|
||||||
- regs.gpr[5] = ptrace(PTRACE_PEEKUSER, pid, 4 * PT_R5, 0);
|
|
||||||
- regs.orig_gpr3 = ptrace(PTRACE_PEEKUSER, pid, 4 * PT_ORIG_R3, 0);
|
|
||||||
+ regs.gpr[0] = ptrace(PTRACE_PEEKUSER, pid, __WORDSIZE/8 * PT_R0, 0);
|
|
||||||
+ regs.gpr[3] = ptrace(PTRACE_PEEKUSER, pid, __WORDSIZE/8 * PT_R3, 0);
|
|
||||||
+ regs.gpr[4] = ptrace(PTRACE_PEEKUSER, pid, __WORDSIZE/8 * PT_R4, 0);
|
|
||||||
+ regs.gpr[5] = ptrace(PTRACE_PEEKUSER, pid, __WORDSIZE/8 * PT_R5, 0);
|
|
||||||
+ regs.orig_gpr3 = ptrace(PTRACE_PEEKUSER, pid, __WORDSIZE/8 * PT_ORIG_R3, 0);
|
|
||||||
#elif defined(ARM)
|
|
||||||
struct pt_regs regs;
|
|
||||||
ptrace(PTRACE_GETREGS, pid, 0, ®s);
|
|
||||||
@@ -271,7 +271,11 @@ int main(int argc, char **argv)
|
|
||||||
|
|
||||||
for (i = 0; i < regs.REG_PARAM3; i++) {
|
|
||||||
#ifdef _BIG_ENDIAN
|
|
||||||
+#if __WORDSIZE == 64
|
|
||||||
+ unsigned int a = bswap_64(ptrace(PTRACE_PEEKTEXT, pid, regs.REG_PARAM2 + i, 0));
|
|
||||||
+#else
|
|
||||||
unsigned int a = bswap_32(ptrace(PTRACE_PEEKTEXT, pid, regs.REG_PARAM2 + i, 0));
|
|
||||||
+#endif
|
|
||||||
#else
|
|
||||||
unsigned int a = ptrace(PTRACE_PEEKTEXT, pid, regs.REG_PARAM2 + i, 0);
|
|
||||||
#endif
|
|
23
psmisc.spec
23
psmisc.spec
@ -1,22 +1,19 @@
|
|||||||
Summary: Utilities for managing processes on your system
|
Summary: Utilities for managing processes on your system
|
||||||
Name: psmisc
|
Name: psmisc
|
||||||
Version: 22.13
|
Version: 22.14
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
URL: http://sourceforge.net/projects/psmisc
|
URL: http://sourceforge.net/projects/psmisc
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
|
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: autoconf automake
|
BuildRequires: autoconf automake
|
||||||
|
|
||||||
Patch1: psmisc-22.13-peekfd-segv.patch
|
#The following has been reworked by upstream in a different way ... we'll see
|
||||||
Patch2: psmisc-22.13-fuser-silent.patch
|
#Patch1: psmisc-22.13-fuser-silent.patch
|
||||||
Patch3: psmisc-22.13-killall-pgid.patch
|
|
||||||
Patch4: psmisc-22.13-ppc64.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The psmisc package contains utilities for managing processes on your
|
The psmisc package contains utilities for managing processes on your
|
||||||
@ -29,11 +26,6 @@ of processes that are using specified files or filesystems.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --prefix=%{_prefix} --enable-selinux
|
%configure --prefix=%{_prefix} --enable-selinux
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -46,11 +38,7 @@ mv $RPM_BUILD_ROOT%{_bindir}/fuser $RPM_BUILD_ROOT/sbin
|
|||||||
|
|
||||||
%find_lang %name
|
%find_lang %name
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
|
||||||
/sbin/fuser
|
/sbin/fuser
|
||||||
%{_bindir}/killall
|
%{_bindir}/killall
|
||||||
%{_bindir}/pstree
|
%{_bindir}/pstree
|
||||||
@ -67,6 +55,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc AUTHORS ChangeLog COPYING README
|
%doc AUTHORS ChangeLog COPYING README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 19 2011 Jaromir Capik <jcapik@redhat.com> 22.14-1
|
||||||
|
- Update to 22.14
|
||||||
|
|
||||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 22.13-8
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 22.13-8
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user