- fix #417801 - exclude peekfd on secondary architectures
This commit is contained in:
parent
316c27fb74
commit
b813ce5564
30
psmisc-22.6-secarch.patch
Normal file
30
psmisc-22.6-secarch.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -up psmisc-22.6/src/Makefile.am.secarch psmisc-22.6/src/Makefile.am
|
||||||
|
--- psmisc-22.6/src/Makefile.am.secarch 2007-12-10 12:11:04.000000000 +0100
|
||||||
|
+++ psmisc-22.6/src/Makefile.am 2007-12-10 12:11:37.000000000 +0100
|
||||||
|
@@ -5,14 +5,17 @@ bin_PROGRAMS = fuser killall pstree oldf
|
||||||
|
if WANT_PEEKFD_I386
|
||||||
|
bin_PROGRAMS += peekfd
|
||||||
|
AM_CFLAGS += -DI386
|
||||||
|
+ peekfd_SOURCES = peekfd.c
|
||||||
|
endif
|
||||||
|
if WANT_PEEKFD_X86_64
|
||||||
|
bin_PROGRAMS += peekfd
|
||||||
|
AM_CFLAGS += -DX86_64
|
||||||
|
+ peekfd_SOURCES = peekfd.c
|
||||||
|
endif
|
||||||
|
if WANT_PEEKFD_PPC
|
||||||
|
bin_PROGRAMS += peekfd
|
||||||
|
AM_CFLAGS += -DPPC
|
||||||
|
+ peekfd_SOURCES = peekfd.c
|
||||||
|
endif
|
||||||
|
|
||||||
|
oldfuser_SOURCES = oldfuser.c comm.h signals.c signals.h loop.h i18n.h
|
||||||
|
@@ -23,8 +26,6 @@ killall_SOURCES = killall.c comm.h signa
|
||||||
|
|
||||||
|
killall_LDADD = @SELINUX_LIB@
|
||||||
|
|
||||||
|
-peekfd_SOURCES = peekfd.c
|
||||||
|
-
|
||||||
|
pstree_SOURCES = pstree.c comm.h i18n.h
|
||||||
|
|
||||||
|
pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@
|
10
psmisc.spec
10
psmisc.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Utilities for managing processes on your system
|
Summary: Utilities for managing processes on your system
|
||||||
Name: psmisc
|
Name: psmisc
|
||||||
Version: 22.6
|
Version: 22.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: BSD/GPLv2+
|
License: BSD/GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
@ -42,6 +42,9 @@ mkdir -p $RPM_BUILD_ROOT/sbin
|
|||||||
mv $RPM_BUILD_ROOT%{_bindir}/fuser $RPM_BUILD_ROOT/sbin
|
mv $RPM_BUILD_ROOT%{_bindir}/fuser $RPM_BUILD_ROOT/sbin
|
||||||
rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/pidof.1*
|
rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/pidof.1*
|
||||||
rm -f $RPM_BUILD_ROOT/%{_bindir}/oldfuser
|
rm -f $RPM_BUILD_ROOT/%{_bindir}/oldfuser
|
||||||
|
%ifnarch %ix86 x86_64 ppc
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/peekfd.1*
|
||||||
|
%endif
|
||||||
|
|
||||||
%find_lang %name
|
%find_lang %name
|
||||||
|
|
||||||
@ -57,10 +60,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/fuser.1*
|
%{_mandir}/man1/fuser.1*
|
||||||
%{_mandir}/man1/killall.1*
|
%{_mandir}/man1/killall.1*
|
||||||
%{_mandir}/man1/pstree.1*
|
%{_mandir}/man1/pstree.1*
|
||||||
|
%ifarch %ix86 x86_64 ppc
|
||||||
%{_bindir}/peekfd
|
%{_bindir}/peekfd
|
||||||
%{_mandir}/man1/peekfd.1*
|
%{_mandir}/man1/peekfd.1*
|
||||||
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 10 2007 Tomas Smetana <tsmetana@redhat.com> 22.6-2
|
||||||
|
- fix #417801 - exclude peekfd on secondary architectures
|
||||||
|
|
||||||
* Mon Dec 03 2007 Tomas Smetana <tsmetana@redhat.com> 22.6-1
|
* Mon Dec 03 2007 Tomas Smetana <tsmetana@redhat.com> 22.6-1
|
||||||
- update to new upstream version
|
- update to new upstream version
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user