- fix #441871 - pstree fails to show most processes; patch by Emil Jerabek
This commit is contained in:
parent
51f7118672
commit
113766c2b8
11
psmisc-22.6-pstree-overflow.patch
Normal file
11
psmisc-22.6-pstree-overflow.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up psmisc-22.6/src/pstree.c.overflow psmisc-22.6/src/pstree.c
|
||||||
|
--- psmisc-22.6/src/pstree.c.overflow 2008-04-14 12:53:07.000000000 +0200
|
||||||
|
+++ psmisc-22.6/src/pstree.c 2008-04-14 13:05:51.000000000 +0200
|
||||||
|
@@ -608,6 +608,7 @@ read_proc (void)
|
||||||
|
perror (path);
|
||||||
|
exit (1);
|
||||||
|
}
|
||||||
|
+ memset(readbuf, '\0', BUFSIZ + 1);
|
||||||
|
fread(readbuf, BUFSIZ, 1, file) ;
|
||||||
|
if (ferror(file) == 0)
|
||||||
|
{
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Utilities for managing processes on your system
|
Summary: Utilities for managing processes on your system
|
||||||
Name: psmisc
|
Name: psmisc
|
||||||
Version: 22.6
|
Version: 22.6
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: BSD/GPLv2+
|
License: BSD/GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
@ -9,6 +9,7 @@ URL: http://psmisc.sourceforge.net
|
|||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch0: psmisc-22.6-types.patch
|
Patch0: psmisc-22.6-types.patch
|
||||||
|
Patch1: psmisc-22.6-pstree-overflow.patch
|
||||||
|
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -26,6 +27,7 @@ of processes that are using specified files or filesystems.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch -p1 -b .types
|
%patch -p1 -b .types
|
||||||
|
%patch1 -p1 -b .overflow
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
|
||||||
@ -66,6 +68,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 14 2008 Tomas Smetana <tsmetana@redhat.com> 22.6-6
|
||||||
|
- fix #441871 - pstree fails to show most processes;
|
||||||
|
patch by Emil Jerabek
|
||||||
|
|
||||||
* Mon Apr 07 2008 Tomas Smetana <tsmetana@redhat.com> 22.6-5
|
* Mon Apr 07 2008 Tomas Smetana <tsmetana@redhat.com> 22.6-5
|
||||||
- fix configure.ac to include all the required headers for peekfd
|
- fix configure.ac to include all the required headers for peekfd
|
||||||
- remove kernel-headers again -- not needed in rawhide
|
- remove kernel-headers again -- not needed in rawhide
|
||||||
|
Loading…
Reference in New Issue
Block a user