Update to 22.20.
- Contains a fix for: http://sourceforge.net/p/psmisc/bugs/53/ - Fix src/pstree.c when SELinux is available.
This commit is contained in:
parent
a5f3b690da
commit
006b356a9b
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ psmisc-22.10.tar.gz
|
|||||||
/psmisc-22.15.tar.gz
|
/psmisc-22.15.tar.gz
|
||||||
/psmisc-22.16.tar.gz
|
/psmisc-22.16.tar.gz
|
||||||
/psmisc-22.19.tar.gz
|
/psmisc-22.19.tar.gz
|
||||||
|
/psmisc-22.20.tar.gz
|
||||||
|
39
psmisc-22.20-fix-selinux-in-pstree.patch
Normal file
39
psmisc-22.20-fix-selinux-in-pstree.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- psmisc-22.20/src/pstree.c 2012-09-19 14:05:43.000000000 +0100
|
||||||
|
+++ psmisc-22.20-selinux/src/pstree.c 2012-10-08 19:18:13.992951873 +0100
|
||||||
|
@@ -140,7 +140,12 @@
|
||||||
|
static int dumped = 0; /* used by dump_by_user */
|
||||||
|
static int charlen = 0; /* length of character */
|
||||||
|
|
||||||
|
+#ifdef WITH_SELINUX
|
||||||
|
+static void fix_orphans(security_context_t scontext);
|
||||||
|
+#else
|
||||||
|
static void fix_orphans(void);
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Allocates additional buffer space for width and more as needed.
|
||||||
|
* The first call will allocate the first buffer.
|
||||||
|
@@ -787,7 +792,11 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
(void) closedir(dir);
|
||||||
|
+#ifdef WITH_SELINUX
|
||||||
|
+ fix_orphans(scontext);
|
||||||
|
+#else
|
||||||
|
fix_orphans();
|
||||||
|
+#endif
|
||||||
|
if (print_args)
|
||||||
|
free(buffer);
|
||||||
|
if (empty) {
|
||||||
|
@@ -796,7 +805,11 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifdef WITH_SELINUX
|
||||||
|
+static void fix_orphans(security_context_t scontext)
|
||||||
|
+#else
|
||||||
|
static void fix_orphans(void)
|
||||||
|
+#endif
|
||||||
|
{
|
||||||
|
/* When using kernel 3.3 with hidepid feature enabled on /proc
|
||||||
|
* then we need fake root pid and gather all the orphan processes
|
14
psmisc.spec
14
psmisc.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Utilities for managing processes on your system
|
Summary: Utilities for managing processes on your system
|
||||||
Name: psmisc
|
Name: psmisc
|
||||||
Version: 22.19
|
Version: 22.20
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
@ -15,6 +15,9 @@ BuildRequires: autoconf automake
|
|||||||
#The following has been reworked by upstream in a different way ... we'll see
|
#The following has been reworked by upstream in a different way ... we'll see
|
||||||
#Patch1: psmisc-22.13-fuser-silent.patch
|
#Patch1: psmisc-22.13-fuser-silent.patch
|
||||||
|
|
||||||
|
# Patch sent upstream 2012-10-08.
|
||||||
|
Patch2: psmisc-22.20-fix-selinux-in-pstree.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The psmisc package contains utilities for managing processes on your
|
The psmisc package contains utilities for managing processes on your
|
||||||
system: pstree, killall and fuser. The pstree command displays a tree
|
system: pstree, killall and fuser. The pstree command displays a tree
|
||||||
@ -26,6 +29,8 @@ of processes that are using specified files or filesystems.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --prefix=%{_prefix} --enable-selinux
|
%configure --prefix=%{_prefix} --enable-selinux
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -55,6 +60,11 @@ mv $RPM_BUILD_ROOT%{_bindir}/fuser $RPM_BUILD_ROOT/sbin
|
|||||||
%doc AUTHORS ChangeLog COPYING README
|
%doc AUTHORS ChangeLog COPYING README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 08 2012 Richard W.M. Jones <rjones@redhat.com> 22.20-1
|
||||||
|
- Update to 22.20.
|
||||||
|
Contains a fix for: http://sourceforge.net/p/psmisc/bugs/53/
|
||||||
|
- Fix src/pstree.c when SELinux is available.
|
||||||
|
|
||||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 22.19-2
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 22.19-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user