procps-ng/procps-ng-3.3.10-libsystemd.patch
2016-11-28 20:40:26 +01:00

38 lines
1.3 KiB
Diff

From 4e7f42375a9aa860365e6007a53a357df60964f1 Mon Sep 17 00:00:00 2001
From: Craig Small <csmall@enc.com.au>
Date: Thu, 9 Jul 2015 22:12:10 +1000
Subject: [PATCH] build-sys: use merged systemd library
Since systemd 209 released in Feb 2014 three systemd libraries
including systemd-login have been merged. This change merely
checks for, and links to, the new library.
References:
http://lists.freedesktop.org/archives/systemd-devel/2014-February/017146.html
https://bugs.debian.org/731256
---
configure.ac | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 612097f..48d4a59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,10 +150,10 @@ AC_ARG_WITH([systemd],
[], [with_systemd=no]
)
if test "x$with_systemd" != xno; then
- PKG_CHECK_MODULES([SYSTEMD], [libsystemd-login >= 206], [], [
- AC_CHECK_LIB(systemd-login, sd_pid_get_slice, [have_systemd=yes], [have_systemd=no])
+ PKG_CHECK_MODULES([SYSTEMD], [libsystemd], [], [
+ AC_CHECK_LIB(systemd, sd_pid_get_slice, [have_systemd=yes], [have_systemd=no])
if test "x$have_systemd" = xno; then
- AC_MSG_ERROR([systemd support missing/incomplete (requires >= 206)])
+ AC_MSG_ERROR([systemd support missing/incomplete (requires >= 209)])
fi
SYSTEMD_LIBS="-lsystemd-login"
])
--
2.9.3