- add IPv6 support to comsat notification (#198403)
- Resolves: #198403 - package man page for mailstat - change mail spool directory to /var/spool/mail
This commit is contained in:
parent
53e398df85
commit
24b860b03a
@ -1,7 +1,7 @@
|
|||||||
Summary: The procmail mail processing program.
|
Summary: The procmail mail processing program.
|
||||||
Name: procmail
|
Name: procmail
|
||||||
Version: 3.22
|
Version: 3.22
|
||||||
Release: 17.1
|
Release: 18
|
||||||
License: GPL or Artistic
|
License: GPL or Artistic
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: ftp://ftp.procmail.org/pub/procmail/procmail-%{version}.tar.gz
|
Source: ftp://ftp.procmail.org/pub/procmail/procmail-%{version}.tar.gz
|
||||||
@ -12,6 +12,7 @@ Patch1: procmail-3.15.1-man.patch
|
|||||||
Patch2: procmail_3.22-8.debian.patch
|
Patch2: procmail_3.22-8.debian.patch
|
||||||
Patch3: procmail-3.22-large_files.patch
|
Patch3: procmail-3.22-large_files.patch
|
||||||
Patch4: procmail-3.22-truncate.patch
|
Patch4: procmail-3.22-truncate.patch
|
||||||
|
Patch5: procmail-3.22-ipv6.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -27,8 +28,7 @@ Procmail is also the basis for the SmartList mailing list processor.
|
|||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1 -b .largefiles
|
%patch3 -p1 -b .largefiles
|
||||||
%patch4 -p1 -b .truncate
|
%patch4 -p1 -b .truncate
|
||||||
|
%patch5 -p1 -b .ipv6
|
||||||
find . -type d -exec chmod 755 {} \;
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
||||||
@ -42,6 +42,7 @@ make \
|
|||||||
BASENAME=${RPM_BUILD_ROOT}%{_prefix} MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
|
BASENAME=${RPM_BUILD_ROOT}%{_prefix} MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
|
||||||
install
|
install
|
||||||
|
|
||||||
|
cp debian/mailstat.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
|
||||||
cp %SOURCE2 telsas_procmailrc
|
cp %SOURCE2 telsas_procmailrc
|
||||||
|
|
||||||
|
|
||||||
@ -60,6 +61,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_mandir}/man[15]/*
|
%{_mandir}/man[15]/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 27 2006 Miroslav Lichvar <mlichvar@redhat.com> 3.22-18
|
||||||
|
- add IPv6 support to comsat notification (#198403)
|
||||||
|
- package man page for mailstat
|
||||||
|
- change mail spool directory to /var/spool/mail
|
||||||
|
|
||||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.22-17.1
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.22-17.1
|
||||||
- rebuild
|
- rebuild
|
||||||
|
|
||||||
|
@ -164,52 +164,8 @@
|
|||||||
return 1;
|
return 1;
|
||||||
}
|
}
|
||||||
|
|
||||||
--- procmail-3.22.orig/src/authenticate.c
|
|
||||||
+++ procmail-3.22/src/authenticate.c
|
|
||||||
@@ -39,13 +39,13 @@
|
|
||||||
#include "authenticate.h"
|
|
||||||
|
|
||||||
#ifndef MAILSPOOLDIR
|
|
||||||
-#define MAILSPOOLDIR "/var/spool/mail/" /* watch the trailing / */
|
|
||||||
+#define MAILSPOOLDIR "/var/mail/" /* watch the trailing / */
|
|
||||||
#endif
|
|
||||||
#ifndef MAILSPOOLSUFFIX
|
|
||||||
#define MAILSPOOLSUFFIX "" /* suffix to force maildir or MH style */
|
|
||||||
#endif
|
|
||||||
#ifndef MAILSPOOLHASH
|
|
||||||
-#define MAILSPOOLHASH 0 /* 2 would deliver to /var/spool/mail/b/a/bar */
|
|
||||||
+#define MAILSPOOLHASH 0 /* 2 would deliver to /var/mail/b/a/bar */
|
|
||||||
#endif
|
|
||||||
/*#define MAILSPOOLHOME "/.mail" /* watch the leading / */
|
|
||||||
/* delivers to $HOME/.mail */
|
|
||||||
--- procmail-3.22.orig/src/autoconf
|
--- procmail-3.22.orig/src/autoconf
|
||||||
+++ procmail-3.22/src/autoconf
|
+++ procmail-3.22/src/autoconf
|
||||||
@@ -89,7 +89,7 @@
|
|
||||||
# #define NOfcntl_lock
|
|
||||||
#Ok #define USElockf
|
|
||||||
#Ok #define USEflock
|
|
||||||
-#Ok #define MAILSPOOLDIR "/var/spool/mail/"
|
|
||||||
+#Ok #define MAILSPOOLDIR "/var/mail/"
|
|
||||||
#Ok #define SENDMAIL "/usr/sbin/sendmail"
|
|
||||||
# #define buggy_SENDMAIL
|
|
||||||
# #define DEFflagsendmail ""
|
|
||||||
@@ -1416,14 +1416,14 @@
|
|
||||||
|
|
||||||
found=no
|
|
||||||
|
|
||||||
-for a in /var/spool/mail /usr/spool/mail /var/mail /usr/mail /spool/mail
|
|
||||||
+for a in /var/mail /var/spool/mail /usr/spool/mail /usr/mail /spool/mail
|
|
||||||
do
|
|
||||||
test -d $a -a $found != yes &&
|
|
||||||
echo '#define MAILSPOOLDIR "'$a'/"' >>$ACONF && found=yes
|
|
||||||
done
|
|
||||||
if test $found != yes
|
|
||||||
then
|
|
||||||
- echo '#define MAILSPOOLDIR "/var/spool/mail/"' >>$ACONF
|
|
||||||
+ echo '#define MAILSPOOLDIR "/var/mail/"' >>$ACONF
|
|
||||||
echo Could not find the system-mailbox directory, supplied default.
|
|
||||||
fi
|
|
||||||
|
|
||||||
@@ -1470,15 +1470,14 @@
|
@@ -1470,15 +1470,14 @@
|
||||||
grep 'Mlocal.*procmail' >$DEVNULL ||
|
grep 'Mlocal.*procmail' >$DEVNULL ||
|
||||||
echo '#define CF_no_procmail_yet' >>$ACONF
|
echo '#define CF_no_procmail_yet' >>$ACONF
|
||||||
@ -382,17 +338,6 @@
|
|||||||
simply instruct procmail to use a different lockfile. This can
|
simply instruct procmail to use a different lockfile. This can
|
||||||
be achieved by putting following recipe at the bottom of
|
be achieved by putting following recipe at the bottom of
|
||||||
your .procmailrc file:
|
your .procmailrc file:
|
||||||
--- procmail-3.22.orig/FEATURES
|
|
||||||
+++ procmail-3.22/FEATURES
|
|
||||||
@@ -30,7 +30,7 @@
|
|
||||||
per message, the similar MH directory folders (numbered files),
|
|
||||||
and Maildir directory folders (a multi-directory format that requires
|
|
||||||
no locking)
|
|
||||||
- + Native support for /var/spool/mail/b/a/bar type mailspools
|
|
||||||
+ + Native support for /var/mail/b/a/bar type mailspools
|
|
||||||
+ Variable assignment and substitution is an extremely complete subset
|
|
||||||
of the standard /bin/sh syntax
|
|
||||||
+ Provides a mail log file, which logs all mail arrival, shows
|
|
||||||
--- procmail-3.22.orig/Makefile
|
--- procmail-3.22.orig/Makefile
|
||||||
+++ procmail-3.22/Makefile
|
+++ procmail-3.22/Makefile
|
||||||
@@ -79,7 +79,7 @@
|
@@ -79,7 +79,7 @@
|
||||||
|
Loading…
Reference in New Issue
Block a user