Fix building with cmocka >= 1.1.6
This commit is contained in:
parent
7e14989e3f
commit
210218d4d8
31
priv_wrapper-fix-cmocka-1.1.6+-support.patch
Normal file
31
priv_wrapper-fix-cmocka-1.1.6+-support.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 295bcbe9de1fb37531678d482efb12583b77c6d0 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Fri, 17 Feb 2023 17:51:27 +0100
|
||||
Subject: [PATCH] cmake: Fix cmocka >= 1.1.6 find_package() in CONFIG mode
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
|
||||
---
|
||||
tests/CMakeLists.txt | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
||||
index d33cf15..46147cf 100644
|
||||
--- a/tests/CMakeLists.txt
|
||||
+++ b/tests/CMakeLists.txt
|
||||
@@ -1,5 +1,9 @@
|
||||
project(tests C)
|
||||
|
||||
+if (TARGET cmocka::cmocka)
|
||||
+ set(CMOCKA_LIBRARY cmocka::cmocka)
|
||||
+endif()
|
||||
+
|
||||
include_directories(
|
||||
${CMAKE_BINARY_DIR}
|
||||
${CMAKE_CURRENT_SOURCE_DIR}
|
||||
--
|
||||
2.39.2
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: priv_wrapper
|
||||
Version: 1.0.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
|
||||
Summary: A library to disable resource limits and other privilege dropping
|
||||
License: GPLv3+
|
||||
@ -10,6 +10,8 @@ Source0: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz
|
||||
Source1: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz.asc
|
||||
Source2: priv_wrapper.keyring
|
||||
|
||||
Patch0: priv_wrapper-fix-cmocka-1.1.6+-support.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gnupg2
|
||||
@ -63,6 +65,9 @@ development/testing.
|
||||
%{_mandir}/man1/priv_wrapper.1*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 27 2023 Andreas Schneider <asn@redhat.com> - 1.0.1-3
|
||||
- Fix building with cmocka >= 1.1.6
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user