21c7e5a87c
- new version 2.4.4 with lots of fixes - fixed reesolv.conf docs (#165072) Thanks to Matt Domsch for the initial patch - enabled CBCP (#199278)
53 lines
1.8 KiB
Diff
53 lines
1.8 KiB
Diff
--- ppp-2.4.4/pppd/Makefile.linux.lib64 2006-07-19 14:16:01.000000000 +0200
|
|
+++ ppp-2.4.4/pppd/Makefile.linux 2006-07-19 14:25:03.000000000 +0200
|
|
@@ -8,6 +8,7 @@
|
|
BINDIR = $(DESTDIR)/sbin
|
|
MANDIR = $(DESTDIR)/share/man/man8
|
|
INCDIR = $(DESTDIR)/include
|
|
+LIBDIR = $(DESTDIR)/lib/$(shell gcc -print-multi-os-directory 2> /dev/null)
|
|
|
|
TARGETS = pppd
|
|
|
|
@@ -32,7 +33,7 @@
|
|
|
|
CC = gcc
|
|
#
|
|
-COPTS = -Wall $(RPM_OPT_FLAGS)
|
|
+COPTS = -Wall $(RPM_OPT_FLAGS) -DLIBDIR=\""$(LIBDIR)"\"
|
|
LIBS = -lutil
|
|
|
|
# Uncomment the next 2 lines to include support for Microsoft's
|
|
--- ppp-2.4.4/pppd/plugins/Makefile.linux.lib64 2006-07-19 14:16:01.000000000 +0200
|
|
+++ ppp-2.4.4/pppd/plugins/Makefile.linux 2006-07-19 14:21:08.000000000 +0200
|
|
@@ -7,7 +7,7 @@
|
|
DESTDIR = $(INSTROOT)@DESTDIR@
|
|
BINDIR = $(DESTDIR)/sbin
|
|
MANDIR = $(DESTDIR)/share/man/man8
|
|
-LIBDIR = $(DESTDIR)/lib/pppd/$(VERSION)
|
|
+LIBDIR = $(DESTDIR)/lib/$(shell $(CC) -print-multi-os-directory 2> /dev/null)/pppd/$(VERSION)
|
|
|
|
SUBDIRS := rp-pppoe pppoatm
|
|
# Uncomment the next line to include the radius authentication plugin
|
|
--- ppp-2.4.4/pppd/pathnames.h.lib64 2005-08-26 01:59:34.000000000 +0200
|
|
+++ ppp-2.4.4/pppd/pathnames.h 2006-07-19 14:26:24.000000000 +0200
|
|
@@ -57,7 +57,7 @@
|
|
|
|
#ifdef PLUGIN
|
|
#ifdef __STDC__
|
|
-#define _PATH_PLUGIN DESTDIR "/lib/pppd/" VERSION
|
|
+#define _PATH_PLUGIN LIBDIR "/pppd/" VERSION
|
|
#else /* __STDC__ */
|
|
#define _PATH_PLUGIN "/usr/lib/pppd"
|
|
#endif /* __STDC__ */
|
|
--- ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux.lib64 2006-07-19 15:29:53.000000000 +0200
|
|
+++ ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux 2006-07-19 15:30:23.000000000 +0200
|
|
@@ -6,7 +6,7 @@
|
|
|
|
#***********************************************************************
|
|
|
|
-DESTDIR = @DESTDIR@
|
|
+DESTDIR = $(INSTROOT)@DESTDIR@
|
|
LIBDIR = $(DESTDIR)/lib/pppd/$(VERSION)
|
|
|
|
VERSION = $(shell awk -F '"' '/VERSION/ { print $$2; }' ../../patchlevel.h)
|