Fixed ppp-2.4.5-eaptls-mppe-0.99.patch, #817011
Added definition of global variable, function pointer (eaptls_check_hook)
This commit is contained in:
parent
f000f7ccd9
commit
d725ecd04b
@ -283,13 +283,14 @@ diff -Naur ppp-2.4.5/pppd/auth.c ppp-2.4.5-eaptls-mppe-0.99/pppd/auth.c
|
|||||||
#ifdef CBCP_SUPPORT
|
#ifdef CBCP_SUPPORT
|
||||||
#include "cbcp.h"
|
#include "cbcp.h"
|
||||||
#endif
|
#endif
|
||||||
@@ -183,6 +186,11 @@
|
@@ -183,6 +186,12 @@
|
||||||
/* Hook for a plugin to get the CHAP password for authenticating us */
|
/* Hook for a plugin to get the CHAP password for authenticating us */
|
||||||
int (*chap_passwd_hook) __P((char *user, char *passwd)) = NULL;
|
int (*chap_passwd_hook) __P((char *user, char *passwd)) = NULL;
|
||||||
|
|
||||||
+#ifdef USE_EAPTLS
|
+#ifdef USE_EAPTLS
|
||||||
+/* Hook for a plugin to get the EAP-TLS password for authenticating us */
|
+/* Hook for a plugin to get the EAP-TLS password for authenticating us */
|
||||||
+int (*eaptls_passwd_hook) __P((char *user, char *passwd)) = NULL;
|
+int (*eaptls_passwd_hook) __P((char *user, char *passwd)) = NULL;
|
||||||
|
++int (*eaptls_check_hook) __P((void)) = NULL;
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
/* Hook for a plugin to say whether it is OK if the peer
|
/* Hook for a plugin to say whether it is OK if the peer
|
||||||
|
5
ppp.spec
5
ppp.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The Point-to-Point Protocol daemon
|
Summary: The Point-to-Point Protocol daemon
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.5
|
Version: 2.4.5
|
||||||
Release: 21%{?dist}
|
Release: 22%{?dist}
|
||||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.samba.org/ppp
|
URL: http://www.samba.org/ppp
|
||||||
@ -159,6 +159,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc PLUGINS
|
%doc PLUGINS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 29 2012 Michal Sekletar <msekleta@redhat.com>
|
||||||
|
- Resolves: #817011 - fixed ppp-2.4.5-eaptls-mppe-0.99 patch, added variable definition
|
||||||
|
|
||||||
* Mon May 21 2012 Michal Sekletar <msekleta@redhat.com>
|
* Mon May 21 2012 Michal Sekletar <msekleta@redhat.com>
|
||||||
- Resolves: #817013 - fixed support for multilink channels in pppol2tp plugin
|
- Resolves: #817013 - fixed support for multilink channels in pppol2tp plugin
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user