Also build all DSOs with distro's LDFLAGS
Related: rhbz#1563157
This commit is contained in:
parent
5da2a6a5b0
commit
cf1e6c7c6b
@ -77,8 +77,29 @@ index 9cb316d..7b23b25 100644
|
|||||||
|
|
||||||
install: all
|
install: all
|
||||||
$(INSTALL) -d -m 755 $(LIBDIR)
|
$(INSTALL) -d -m 755 $(LIBDIR)
|
||||||
|
diff --git a/pppd/plugins/radius/Makefile.linux b/pppd/plugins/radius/Makefile.linux
|
||||||
|
index 707326b..2150332 100644
|
||||||
|
--- a/pppd/plugins/radius/Makefile.linux
|
||||||
|
+++ b/pppd/plugins/radius/Makefile.linux
|
||||||
|
@@ -43,13 +43,13 @@ install: all
|
||||||
|
$(INSTALL) -c -m 444 pppd-radattr.8 $(MANDIR)
|
||||||
|
|
||||||
|
radius.so: radius.o libradiusclient.a
|
||||||
|
- $(CC) -o radius.so -shared radius.o libradiusclient.a
|
||||||
|
+ $(CC) $(LDFLAGS) -o radius.so -shared radius.o libradiusclient.a
|
||||||
|
|
||||||
|
radattr.so: radattr.o
|
||||||
|
- $(CC) -o radattr.so -shared radattr.o
|
||||||
|
+ $(CC) $(LDFLAGS) -o radattr.so -shared radattr.o
|
||||||
|
|
||||||
|
radrealms.so: radrealms.o
|
||||||
|
- $(CC) -o radrealms.so -shared radrealms.o
|
||||||
|
+ $(CC) $(LDFLAGS) -o radrealms.so -shared radrealms.o
|
||||||
|
|
||||||
|
CLIENTOBJS = avpair.o buildreq.o config.o dict.o ip_util.o \
|
||||||
|
clientid.o sendserver.o lock.o util.o md5.o
|
||||||
diff --git a/pppd/plugins/rp-pppoe/Makefile.linux b/pppd/plugins/rp-pppoe/Makefile.linux
|
diff --git a/pppd/plugins/rp-pppoe/Makefile.linux b/pppd/plugins/rp-pppoe/Makefile.linux
|
||||||
index fa49efb..d735c51 100644
|
index fa49efb..5e06b52 100644
|
||||||
--- a/pppd/plugins/rp-pppoe/Makefile.linux
|
--- a/pppd/plugins/rp-pppoe/Makefile.linux
|
||||||
+++ b/pppd/plugins/rp-pppoe/Makefile.linux
|
+++ b/pppd/plugins/rp-pppoe/Makefile.linux
|
||||||
@@ -31,7 +31,7 @@ CFLAGS=$(COPTS) -I../../../include '-DRP_VERSION="$(RP_VERSION)"'
|
@@ -31,7 +31,7 @@ CFLAGS=$(COPTS) -I../../../include '-DRP_VERSION="$(RP_VERSION)"'
|
||||||
@ -90,6 +111,15 @@ index fa49efb..d735c51 100644
|
|||||||
|
|
||||||
pppoe-discovery.o: pppoe-discovery.c
|
pppoe-discovery.o: pppoe-discovery.c
|
||||||
$(CC) $(CFLAGS) -c -o pppoe-discovery.o pppoe-discovery.c
|
$(CC) $(CFLAGS) -c -o pppoe-discovery.o pppoe-discovery.c
|
||||||
|
@@ -40,7 +40,7 @@ debug.o: debug.c
|
||||||
|
$(CC) $(CFLAGS) -c -o debug.o debug.c
|
||||||
|
|
||||||
|
rp-pppoe.so: plugin.o discovery.o if.o common.o
|
||||||
|
- $(CC) -o rp-pppoe.so -shared plugin.o discovery.o if.o common.o
|
||||||
|
+ $(CC) $(LDFLAGS) -o rp-pppoe.so -shared plugin.o discovery.o if.o common.o
|
||||||
|
|
||||||
|
install: all
|
||||||
|
$(INSTALL) -d -m 755 $(LIBDIR)
|
||||||
diff --git a/pppdump/Makefile.linux b/pppdump/Makefile.linux
|
diff --git a/pppdump/Makefile.linux b/pppdump/Makefile.linux
|
||||||
index 95c6805..33e5107 100644
|
index 95c6805..33e5107 100644
|
||||||
--- a/pppdump/Makefile.linux
|
--- a/pppdump/Makefile.linux
|
||||||
|
6
ppp.spec
6
ppp.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: The Point-to-Point Protocol daemon
|
Summary: The Point-to-Point Protocol daemon
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.7
|
Version: 2.4.7
|
||||||
Release: 19%{?dist}
|
Release: 20%{?dist}
|
||||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.samba.org/ppp
|
URL: http://www.samba.org/ppp
|
||||||
@ -175,6 +175,10 @@ install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdo
|
|||||||
%doc PLUGINS
|
%doc PLUGINS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 6 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.7-20
|
||||||
|
- Also build all DSOs with distro's LDFLAGS
|
||||||
|
Related: rhbz#1563157
|
||||||
|
|
||||||
* Wed Apr 4 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.7-19
|
* Wed Apr 4 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.7-19
|
||||||
- Build with distro's LDFLAGS
|
- Build with distro's LDFLAGS
|
||||||
Resolves: rhbz#1563157
|
Resolves: rhbz#1563157
|
||||||
|
Loading…
Reference in New Issue
Block a user