- updated to latest upstream sources (#538058)
This commit is contained in:
parent
d823272bd5
commit
c8dba00848
@ -1,3 +1 @@
|
||||
ppp-2.4.2.tar.gz
|
||||
ppp-2.4.3.tar.gz
|
||||
ppp-2.4.4.tar.gz
|
||||
ppp-2.4.5.tar.gz
|
||||
|
@ -2,7 +2,7 @@ diff -up ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux.atm-make ppp-2.4.4/pppd/p
|
||||
--- ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux.atm-make 2008-08-28 17:36:10.000000000 -0400
|
||||
+++ ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux 2008-08-28 17:36:56.000000000 -0400
|
||||
@@ -1,5 +1,5 @@
|
||||
CC = gcc
|
||||
#CC = gcc
|
||||
-COPTS = -O2 -g
|
||||
+COPTS = $(RPM_OPT_FLAGS)
|
||||
CFLAGS = $(COPTS) -I../.. -I../../../include -fPIC
|
||||
|
@ -1,28 +0,0 @@
|
||||
--- ppp-2.4.2/pppd/plugins/pppoatm/pppoatm.c.mtu 2004-10-07 13:32:05.660910432 +0100
|
||||
+++ ppp-2.4.2/pppd/plugins/pppoatm/pppoatm.c 2004-10-07 13:58:20.096559832 +0100
|
||||
@@ -175,8 +175,10 @@
|
||||
{
|
||||
int sock;
|
||||
struct ifreq ifr;
|
||||
- if (mtu > pppoatm_max_mtu)
|
||||
- error("Couldn't increase MTU to %d", mtu);
|
||||
+ if (pppoatm_max_mtu && mtu > pppoatm_max_mtu) {
|
||||
+ warn("Couldn't increase MTU to %d. Using %d", mtu, pppoatm_max_mtu);
|
||||
+ mtu = pppoatm_max_mtu;
|
||||
+ }
|
||||
sock = socket(AF_INET, SOCK_DGRAM, 0);
|
||||
if (sock < 0)
|
||||
fatal("Couldn't create IP socket: %m");
|
||||
@@ -192,8 +194,10 @@
|
||||
int pcomp,
|
||||
int accomp)
|
||||
{
|
||||
- if (mru > pppoatm_max_mru)
|
||||
- error("Couldn't increase MRU to %d", mru);
|
||||
+ if (pppoatm_max_mru && mru > pppoatm_max_mru) {
|
||||
+ warn("Couldn't increase MRU to %d. Using %d", mru, pppoatm_max_mru);
|
||||
+ mru = pppoatm_max_mru;
|
||||
+ }
|
||||
}
|
||||
|
||||
void plugin_init(void)
|
@ -1,14 +1,14 @@
|
||||
--- ppp-2.4.3/pppd/plugins/rp-pppoe/discovery.c.fix 2004-11-04 11:07:37.000000000 +0100
|
||||
+++ ppp-2.4.3/pppd/plugins/rp-pppoe/discovery.c 2004-11-22 16:00:24.522462124 +0100
|
||||
@@ -13,6 +13,8 @@
|
||||
|
||||
#include "pppoe.h"
|
||||
#include "pppd/pppd.h"
|
||||
|
||||
+void warn __P((char *, ...)); /* log a warning message */
|
||||
+
|
||||
#ifdef HAVE_SYSLOG_H
|
||||
#include <syslog.h>
|
||||
#endif
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
--- ppp-2.4.3/pppd/ipv6cp.c.fix 2004-11-13 03:28:15.000000000 +0100
|
||||
+++ ppp-2.4.3/pppd/ipv6cp.c 2004-11-22 16:00:27.049114044 +0100
|
||||
@@ -151,6 +151,7 @@
|
||||
@ -30,30 +30,6 @@
|
||||
/*
|
||||
* ipv6_check_options - check that any IP-related options are OK,
|
||||
* and assign appropriate defaults.
|
||||
--- ppp-2.4.3/include/linux/if_pppox.h.fix 2001-12-15 01:34:24.000000000 +0100
|
||||
+++ ppp-2.4.3/include/linux/if_pppox.h 2004-11-22 16:00:27.049114044 +0100
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
|
||||
#include <asm/types.h>
|
||||
-#include <asm/byteorder.h>
|
||||
+#include <endian.h>
|
||||
|
||||
#ifdef __KERNEL__
|
||||
#include <linux/if_ether.h>
|
||||
@@ -97,10 +97,10 @@
|
||||
#define PTT_GEN_ERR __constant_htons(0x0203)
|
||||
|
||||
struct pppoe_hdr {
|
||||
-#if defined(__LITTLE_ENDIAN_BITFIELD)
|
||||
+#if __BYTE_ORDER == __LITTLE_ENDIAN
|
||||
__u8 ver : 4;
|
||||
__u8 type : 4;
|
||||
-#elif defined(__BIG_ENDIAN_BITFIELD)
|
||||
+#elif __BYTE_ORDER == __BIG_ENDIAN
|
||||
__u8 type : 4;
|
||||
__u8 ver : 4;
|
||||
#else
|
||||
--- ppp-2.4.3/pppdump/deflate.c.fix 2004-02-02 04:36:46.000000000 +0100
|
||||
+++ ppp-2.4.3/pppdump/deflate.c 2004-11-22 16:02:18.071820020 +0100
|
||||
@@ -39,6 +39,7 @@
|
||||
|
@ -5,6 +5,6 @@
|
||||
#include <string.h>
|
||||
#include <netinet/in.h> /* htonl() */
|
||||
+#include <sys/types.h> /* u_int32_t */
|
||||
#include <net/ppp_defs.h>
|
||||
#include "sha1.h"
|
||||
|
||||
static void
|
||||
|
@ -28,7 +28,7 @@
|
||||
--- ppp-2.4.3/pppd/plugins/Makefile.linux.make 2004-11-14 08:57:35.000000000 +0100
|
||||
+++ ppp-2.4.3/pppd/plugins/Makefile.linux 2004-11-22 15:46:49.873309203 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
CC = gcc
|
||||
#CC = gcc
|
||||
-COPTS = -O2 -g
|
||||
+COPTS = $(RPM_OPT_FLAGS)
|
||||
CFLAGS = $(COPTS) -I.. -I../../include -fPIC
|
||||
@ -47,13 +47,13 @@
|
||||
# MS-CHAP authentication protocol.
|
||||
--- ppp-2.4.3/pppd/plugins/rp-pppoe/Makefile.linux.make 2004-11-14 08:58:37.000000000 +0100
|
||||
+++ ppp-2.4.3/pppd/plugins/rp-pppoe/Makefile.linux 2004-11-22 15:46:49.875308929 +0100
|
||||
@@ -24,7 +24,7 @@
|
||||
@@ -25,7 +25,7 @@
|
||||
# Version is set ONLY IN THE MAKEFILE! Don't delete this!
|
||||
VERSION=3.3
|
||||
RP_VERSION=3.8p
|
||||
|
||||
-COPTS=-O2 -g
|
||||
+COPTS=$(RPM_OPT_FLAGS)
|
||||
CFLAGS=$(COPTS) -I../../../include/linux
|
||||
CFLAGS=$(COPTS) -I../../../include '-DRP_VERSION="$(RP_VERSION)"'
|
||||
all: rp-pppoe.so pppoe-discovery
|
||||
|
||||
--- ppp-2.4.3/pppdump/Makefile.linux.make 2004-10-31 02:36:52.000000000 +0200
|
||||
|
@ -1,104 +0,0 @@
|
||||
diff -up ppp-2.4.4/pppd/ipcp.c.bogus_dns_addr ppp-2.4.4/pppd/ipcp.c
|
||||
--- ppp-2.4.4/pppd/ipcp.c.bogus_dns_addr 2005-08-26 01:59:34.000000000 +0200
|
||||
+++ ppp-2.4.4/pppd/ipcp.c 2008-12-11 12:39:05.000000000 +0100
|
||||
@@ -715,7 +715,8 @@ ipcp_cilen(f)
|
||||
#define LENCIADDRS(neg) (neg ? CILEN_ADDRS : 0)
|
||||
#define LENCIVJ(neg, old) (neg ? (old? CILEN_COMPRESS : CILEN_VJ) : 0)
|
||||
#define LENCIADDR(neg) (neg ? CILEN_ADDR : 0)
|
||||
-#define LENCIDNS(neg) (neg ? (CILEN_ADDR) : 0)
|
||||
+#define LENCIDNS(neg) LENCIADDR(neg)
|
||||
+#define LENCIWINS(neg) LENCIADDR(neg)
|
||||
|
||||
/*
|
||||
* First see if we want to change our options to the old
|
||||
@@ -737,7 +738,9 @@ ipcp_cilen(f)
|
||||
LENCIVJ(go->neg_vj, go->old_vj) +
|
||||
LENCIADDR(go->neg_addr) +
|
||||
LENCIDNS(go->req_dns1) +
|
||||
- LENCIDNS(go->req_dns2)) ;
|
||||
+ LENCIDNS(go->req_dns2) +
|
||||
+ LENCIWINS(go->winsaddr[0]) +
|
||||
+ LENCIWINS(go->winsaddr[1])) ;
|
||||
}
|
||||
|
||||
|
||||
@@ -810,6 +813,19 @@ ipcp_addci(f, ucp, lenp)
|
||||
} else \
|
||||
neg = 0; \
|
||||
}
|
||||
+
|
||||
+#define ADDCIWINS(opt, addr) \
|
||||
+ if (addr) { \
|
||||
+ if (len >= CILEN_ADDR) { \
|
||||
+ u_int32_t l; \
|
||||
+ PUTCHAR(opt, ucp); \
|
||||
+ PUTCHAR(CILEN_ADDR, ucp); \
|
||||
+ l = ntohl(addr); \
|
||||
+ PUTLONG(l, ucp); \
|
||||
+ len -= CILEN_ADDR; \
|
||||
+ } else \
|
||||
+ addr = 0; \
|
||||
+ }
|
||||
|
||||
ADDCIADDRS(CI_ADDRS, !go->neg_addr && go->old_addrs, go->ouraddr,
|
||||
go->hisaddr);
|
||||
@@ -823,6 +839,10 @@ ipcp_addci(f, ucp, lenp)
|
||||
|
||||
ADDCIDNS(CI_MS_DNS2, go->req_dns2, go->dnsaddr[1]);
|
||||
|
||||
+ ADDCIWINS(CI_MS_WINS1, go->winsaddr[0]);
|
||||
+
|
||||
+ ADDCIWINS(CI_MS_WINS2, go->winsaddr[1]);
|
||||
+
|
||||
*lenp -= len;
|
||||
}
|
||||
|
||||
@@ -1159,6 +1179,15 @@ ipcp_nakci(f, p, len, treat_as_reject)
|
||||
try.neg_addr = 1;
|
||||
no.neg_addr = 1;
|
||||
break;
|
||||
+ case CI_MS_WINS1:
|
||||
+ case CI_MS_WINS2:
|
||||
+ if (cilen != CILEN_ADDR)
|
||||
+ goto bad;
|
||||
+ GETLONG(l, p);
|
||||
+ ciaddr1 = htonl(l);
|
||||
+ if (ciaddr1)
|
||||
+ try.winsaddr[citype == CI_MS_WINS2] = ciaddr1;
|
||||
+ break;
|
||||
}
|
||||
p = next;
|
||||
}
|
||||
@@ -1275,6 +1304,21 @@ ipcp_rejci(f, p, len)
|
||||
try.neg = 0; \
|
||||
}
|
||||
|
||||
+#define REJCIWINS(opt, addr) \
|
||||
+ if (addr && \
|
||||
+ ((cilen = p[1]) == CILEN_ADDR) && \
|
||||
+ len >= cilen && \
|
||||
+ p[0] == opt) { \
|
||||
+ u_int32_t l; \
|
||||
+ len -= cilen; \
|
||||
+ INCPTR(2, p); \
|
||||
+ GETLONG(l, p); \
|
||||
+ cilong = htonl(l); \
|
||||
+ /* Check rejected value. */ \
|
||||
+ if (cilong != addr) \
|
||||
+ goto bad; \
|
||||
+ try.winsaddr[opt == CI_MS_WINS2] = 0; \
|
||||
+ }
|
||||
|
||||
REJCIADDRS(CI_ADDRS, !go->neg_addr && go->old_addrs,
|
||||
go->ouraddr, go->hisaddr);
|
||||
@@ -1288,6 +1332,10 @@ ipcp_rejci(f, p, len)
|
||||
|
||||
REJCIDNS(CI_MS_DNS2, req_dns2, go->dnsaddr[1]);
|
||||
|
||||
+ REJCIWINS(CI_MS_WINS1, go->winsaddr[0]);
|
||||
+
|
||||
+ REJCIWINS(CI_MS_WINS2, go->winsaddr[1]);
|
||||
+
|
||||
/*
|
||||
* If there are any remaining CIs, then this packet is bad.
|
||||
*/
|
@ -1,20 +0,0 @@
|
||||
diff -up ppp-2.4.4/pppd/main.c.closelog ppp-2.4.4/pppd/main.c
|
||||
--- ppp-2.4.4/pppd/main.c.closelog 2008-03-06 22:54:19.000000000 +0100
|
||||
+++ ppp-2.4.4/pppd/main.c 2008-03-06 22:54:31.000000000 +0100
|
||||
@@ -1567,6 +1567,8 @@ safe_fork(int infd, int outfd, int errfd
|
||||
if (errfd == 0 || errfd == 1)
|
||||
errfd = dup(errfd);
|
||||
|
||||
+ closelog();
|
||||
+
|
||||
/* dup the in, out, err fds to 0, 1, 2 */
|
||||
if (infd != 0)
|
||||
dup2(infd, 0);
|
||||
@@ -1575,7 +1577,6 @@ safe_fork(int infd, int outfd, int errfd
|
||||
if (errfd != 2)
|
||||
dup2(errfd, 2);
|
||||
|
||||
- closelog();
|
||||
if (log_to_fd > 2)
|
||||
close(log_to_fd);
|
||||
if (the_channel->close)
|
@ -26,7 +26,7 @@
|
||||
|
||||
#***********************************************************************
|
||||
|
||||
-DESTDIR = @DESTDIR@
|
||||
-DESTDIR = $(INSTROOT)@DESTDIR@
|
||||
-LIBDIR = $(DESTDIR)/lib/pppd/$(VERSION)
|
||||
+DESTDIR = $(INSTROOT)@DESTDIR@
|
||||
+LIBDIR = $(DESTDIR)/lib/$(shell gcc -print-multi-os-directory 2> /dev/null)/pppd/$(VERSION)
|
||||
|
@ -1,34 +0,0 @@
|
||||
diff -up ppp-2.4.4/pppd/sys-linux.c.new_speeds ppp-2.4.4/pppd/sys-linux.c
|
||||
--- ppp-2.4.4/pppd/sys-linux.c.new_speeds 2008-05-12 17:44:11.000000000 -0400
|
||||
+++ ppp-2.4.4/pppd/sys-linux.c 2008-05-12 17:50:51.000000000 -0400
|
||||
@@ -849,6 +849,30 @@ struct speed {
|
||||
#ifdef B921600
|
||||
{ 921600, B921600 },
|
||||
#endif
|
||||
+#ifdef B1000000
|
||||
+ { 1000000, B1000000 },
|
||||
+#endif
|
||||
+#ifdef B1152000
|
||||
+ { 1152000, B1152000 },
|
||||
+#endif
|
||||
+#ifdef B1500000
|
||||
+ { 1500000, B1500000 },
|
||||
+#endif
|
||||
+#ifdef B2000000
|
||||
+ { 2000000, B2000000 },
|
||||
+#endif
|
||||
+#ifdef B2500000
|
||||
+ { 2500000, B2500000 },
|
||||
+#endif
|
||||
+#ifdef B3000000
|
||||
+ { 3000000, B3000000 },
|
||||
+#endif
|
||||
+#ifdef B3500000
|
||||
+ { 3500000, B3500000 },
|
||||
+#endif
|
||||
+#ifdef B4000000
|
||||
+ { 4000000, B4000000 },
|
||||
+#endif
|
||||
{ 0, 0 }
|
||||
};
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up ppp-2.4.4/pppd/chap_ms.c.response_len ppp-2.4.4/pppd/chap_ms.c
|
||||
--- ppp-2.4.4/pppd/chap_ms.c.response_len 2008-03-06 23:07:18.000000000 +0100
|
||||
+++ ppp-2.4.4/pppd/chap_ms.c 2008-03-06 23:07:49.000000000 +0100
|
||||
@@ -852,7 +852,7 @@ ChapMS2(u_char *rchallenge, u_char *Peer
|
||||
u_char *p = &response[MS_CHAP2_PEER_CHALLENGE];
|
||||
int i;
|
||||
|
||||
- BZERO(response, sizeof(*response));
|
||||
+ BZERO(response, MS_CHAP2_RESPONSE_LEN);
|
||||
|
||||
/* Generate the Peer-Challenge if requested, or copy it if supplied. */
|
||||
if (!PeerChallenge)
|
17
ppp.spec
17
ppp.spec
@ -1,7 +1,7 @@
|
||||
Summary: The PPP (Point-to-Point Protocol) daemon.
|
||||
Name: ppp
|
||||
Version: 2.4.4
|
||||
Release: 14%{?dist}
|
||||
Version: 2.4.5
|
||||
Release: 1%{?dist}
|
||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.samba.org/ppp
|
||||
@ -18,17 +18,12 @@ Patch8: ppp-2.4.3-fix.patch
|
||||
Patch9: ppp-2.4.3-fix64.patch
|
||||
Patch11: ppp-2.4.2-change_resolv_conf.patch
|
||||
Patch13: ppp-2.4.4-no_strip.patch
|
||||
Patch16: ppp-2.4.2-pppoatm-mtu.patch
|
||||
Patch17: ppp-2.4.2-pppoatm-make.patch
|
||||
Patch19: ppp-2.4.3-local.patch
|
||||
Patch20: ppp-2.4.3-ipv6-accept-remote.patch
|
||||
Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
|
||||
Patch22: ppp-2.4.4-cbcp.patch
|
||||
Patch23: ppp-2.4.2-dontwriteetc.patch
|
||||
Patch24: ppp-2.4.4-closelog.patch
|
||||
Patch25: ppp-2.4.4-response_len.patch
|
||||
Patch26: ppp-2.4.4-new_speeds.patch
|
||||
Patch27: ppp-2.4.4-bogus_dns_addr.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
BuildPrereq: pam-devel, libpcap-devel
|
||||
@ -62,17 +57,12 @@ This package contains the header files for building plugins for ppp.
|
||||
%patch9 -p1 -b .fix64
|
||||
%patch11 -p1 -b .change_resolv_conf
|
||||
%patch13 -p1 -b .no_strip
|
||||
%patch16 -p1 -b .atm-mtu
|
||||
%patch17 -p1 -b .atm-make
|
||||
%patch19 -p1 -b .local
|
||||
%patch20 -p1 -b .ipv6cp
|
||||
%patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
|
||||
%patch22 -p1 -b .cbcp
|
||||
%patch23 -p1 -b .dontwriteetc
|
||||
%patch24 -p1 -b .closelog
|
||||
%patch25 -p1 -b .response_len
|
||||
%patch26 -p1 -b .new_speeds
|
||||
%patch27 -p1 -b .bogus_dns_addr
|
||||
|
||||
rm -f scripts/*.local
|
||||
rm -f scripts/*.change_resolv_conf
|
||||
@ -137,6 +127,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc PLUGINS
|
||||
|
||||
%changelog
|
||||
* Fri Nov 20 2009 Jiri Skala <jskala@redhat.com> - 2.4.5-1
|
||||
- updated to latest upstream sources (#538058)
|
||||
|
||||
* Thu Oct 08 2009 Jiri Skala <jskala@redhat.com> - 2.4.4-14
|
||||
- fixed #519042 - ppp package is missing URL in spec
|
||||
- fixed #524575 - ppp: no_strip patch modifies backup files created by previous patches
|
||||
|
Loading…
Reference in New Issue
Block a user