- put logs into /var/log/ppp (#118837)
This commit is contained in:
parent
94ca026894
commit
c4b72070a5
@ -1,48 +1,19 @@
|
|||||||
--- ppp-2.4.2/chat/chat.8.dontwriteetc 2002-09-07 12:37:49.000000000 +0200
|
diff -up ppp-2.4.4/chat/chat.8.dontwriteetc ppp-2.4.4/chat/chat.8
|
||||||
+++ ppp-2.4.2/chat/chat.8 2004-05-07 10:45:30.000000000 +0200
|
--- ppp-2.4.4/chat/chat.8.dontwriteetc 2004-11-13 13:22:49.000000000 +0100
|
||||||
@@ -200,7 +200,7 @@
|
+++ ppp-2.4.4/chat/chat.8 2008-03-03 15:37:55.000000000 +0100
|
||||||
|
@@ -200,7 +200,7 @@ The \fBSAY\fR directive allows the scrip
|
||||||
at the terminal via standard error. If \fBchat\fR is being run by
|
at the terminal via standard error. If \fBchat\fR is being run by
|
||||||
pppd, and pppd is running as a daemon (detached from its controlling
|
pppd, and pppd is running as a daemon (detached from its controlling
|
||||||
terminal), standard error will normally be redirected to the file
|
terminal), standard error will normally be redirected to the file
|
||||||
-/etc/ppp/connect-errors.
|
-/etc/ppp/connect\-errors.
|
||||||
+/var/log/ppp/connect-errors.
|
+/var/log/ppp/connect\-errors.
|
||||||
.LP
|
.LP
|
||||||
\fBSAY\fR strings must be enclosed in single or double quotes. If
|
\fBSAY\fR strings must be enclosed in single or double quotes. If
|
||||||
carriage return and line feed are needed in the string to be output,
|
carriage return and line feed are needed in the string to be output,
|
||||||
--- ppp-2.4.2/linux/Makefile.top.dontwriteetc 2002-09-07 12:37:49.000000000 +0200
|
diff -up ppp-2.4.4/pppd/pathnames.h.dontwriteetc ppp-2.4.4/pppd/pathnames.h
|
||||||
+++ ppp-2.4.2/linux/Makefile.top 2004-05-07 10:44:40.000000000 +0200
|
--- ppp-2.4.4/pppd/pathnames.h.dontwriteetc 2008-03-03 15:26:51.000000000 +0100
|
||||||
@@ -5,6 +5,8 @@
|
+++ ppp-2.4.4/pppd/pathnames.h 2008-03-03 15:26:51.000000000 +0100
|
||||||
INCDIR = $(DESTDIR)/usr/include
|
@@ -28,9 +28,9 @@
|
||||||
MANDIR = $(DESTDIR)/usr/man
|
|
||||||
ETCDIR = $(DESTDIR)/etc/ppp
|
|
||||||
+RUNDIR = $(DESTDIR)/var/run/ppp
|
|
||||||
+LOGDIR = $(DESTDIR)/var/log/ppp
|
|
||||||
|
|
||||||
# uid 0 = root
|
|
||||||
INSTALL= install
|
|
||||||
@@ -16,7 +18,7 @@
|
|
||||||
cd pppstats; $(MAKE) $(MFLAGS) all
|
|
||||||
cd pppdump; $(MAKE) $(MFLAGS) all
|
|
||||||
|
|
||||||
-install: $(BINDIR) $(MANDIR)/man8 install-progs install-etcppp install-devel
|
|
||||||
+install: $(BINDIR) $(RUNDIR) $(LOGDIR) $(MANDIR)/man8 install-progs install-etcppp install-devel
|
|
||||||
|
|
||||||
install-progs:
|
|
||||||
cd chat; $(MAKE) BINDIR=$(BINDIR) MANDIR=$(MANDIR) $(MFLAGS) install
|
|
||||||
@@ -44,6 +46,10 @@
|
|
||||||
$(INSTALL) -d -m 755 $@
|
|
||||||
$(ETCDIR):
|
|
||||||
$(INSTALL) -d -m 755 $@
|
|
||||||
+$(RUNDIR):
|
|
||||||
+ $(INSTALL) -d -m 755 $@
|
|
||||||
+$(LOGDIR):
|
|
||||||
+ $(INSTALL) -d -m 755 $@
|
|
||||||
|
|
||||||
clean:
|
|
||||||
rm -f `find . -name '*.[oas]' -print`
|
|
||||||
--- ppp-2.4.2/pppd/pathnames.h.dontwriteetc 2004-05-07 10:29:29.000000000 +0200
|
|
||||||
+++ ppp-2.4.2/pppd/pathnames.h 2004-05-07 11:40:08.000000000 +0200
|
|
||||||
@@ -27,9 +27,9 @@
|
|
||||||
#define _PATH_AUTHUP _ROOT_PATH "/etc/ppp/auth-up"
|
#define _PATH_AUTHUP _ROOT_PATH "/etc/ppp/auth-up"
|
||||||
#define _PATH_AUTHDOWN _ROOT_PATH "/etc/ppp/auth-down"
|
#define _PATH_AUTHDOWN _ROOT_PATH "/etc/ppp/auth-down"
|
||||||
#define _PATH_TTYOPT _ROOT_PATH "/etc/ppp/options."
|
#define _PATH_TTYOPT _ROOT_PATH "/etc/ppp/options."
|
||||||
@ -54,3 +25,35 @@
|
|||||||
|
|
||||||
#define _PATH_USEROPT ".ppprc"
|
#define _PATH_USEROPT ".ppprc"
|
||||||
#define _PATH_PSEUDONYM ".ppp_pseudonym"
|
#define _PATH_PSEUDONYM ".ppp_pseudonym"
|
||||||
|
diff -up ppp-2.4.4/linux/Makefile.top.dontwriteetc ppp-2.4.4/linux/Makefile.top
|
||||||
|
--- ppp-2.4.4/linux/Makefile.top.dontwriteetc 2006-06-04 07:04:14.000000000 +0200
|
||||||
|
+++ ppp-2.4.4/linux/Makefile.top 2008-03-03 15:42:10.000000000 +0100
|
||||||
|
@@ -5,6 +5,8 @@ BINDIR = $(DESTDIR)/sbin
|
||||||
|
INCDIR = $(DESTDIR)/include
|
||||||
|
MANDIR = $(DESTDIR)/share/man
|
||||||
|
ETCDIR = $(INSTROOT)@SYSCONF@/ppp
|
||||||
|
+RUNDIR = $(DESTDIR)/var/run/ppp
|
||||||
|
+LOGDIR = $(DESTDIR)/var/log/ppp
|
||||||
|
|
||||||
|
# uid 0 = root
|
||||||
|
INSTALL= install
|
||||||
|
@@ -16,7 +18,7 @@ all:
|
||||||
|
cd pppstats; $(MAKE) $(MFLAGS) all
|
||||||
|
cd pppdump; $(MAKE) $(MFLAGS) all
|
||||||
|
|
||||||
|
-install: $(BINDIR) $(MANDIR)/man8 install-progs install-devel
|
||||||
|
+install: $(BINDIR) $(RUNDIR) $(LOGDIR) $(MANDIR)/man8 install-progs install-devel
|
||||||
|
|
||||||
|
install-progs:
|
||||||
|
cd chat; $(MAKE) $(MFLAGS) install
|
||||||
|
@@ -44,6 +46,10 @@ $(MANDIR)/man8:
|
||||||
|
$(INSTALL) -d -m 755 $@
|
||||||
|
$(ETCDIR):
|
||||||
|
$(INSTALL) -d -m 755 $@
|
||||||
|
+$(RUNDIR):
|
||||||
|
+ $(INSTALL) -d -m 755 $@
|
||||||
|
+$(LOGDIR):
|
||||||
|
+ $(INSTALL) -d -m 755 $@
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f `find . -name '*.[oas]' -print`
|
||||||
|
7
ppp.spec
7
ppp.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The PPP (Point-to-Point Protocol) daemon.
|
Summary: The PPP (Point-to-Point Protocol) daemon.
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.4
|
Version: 2.4.4
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: distributable
|
License: distributable
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
|
Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
|
||||||
@ -23,6 +23,7 @@ Patch19: ppp-2.4.3-local.patch
|
|||||||
Patch20: ppp-2.4.3-ipv6-accept-remote.patch
|
Patch20: ppp-2.4.3-ipv6-accept-remote.patch
|
||||||
Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
|
Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
|
||||||
Patch22: ppp-2.4.4-cbcp.patch
|
Patch22: ppp-2.4.4-cbcp.patch
|
||||||
|
Patch23: ppp-2.4.2-dontwriteetc.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
BuildPrereq: pam-devel, libpcap-devel
|
BuildPrereq: pam-devel, libpcap-devel
|
||||||
@ -55,6 +56,7 @@ organization over a modem and phone line.
|
|||||||
%patch20 -p1 -b .ipv6cp
|
%patch20 -p1 -b .ipv6cp
|
||||||
%patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
|
%patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
|
||||||
%patch22 -p1 -b .cbcp
|
%patch22 -p1 -b .cbcp
|
||||||
|
%patch23 -p1 -b .dontwriteetc
|
||||||
|
|
||||||
rm -f scripts/*.local
|
rm -f scripts/*.local
|
||||||
rm -f scripts/*.change_resolv_conf
|
rm -f scripts/*.change_resolv_conf
|
||||||
@ -116,6 +118,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 03 2008 Martin Nagy <mnagy@redhat.com> 2.4.4-5
|
||||||
|
- put logs into /var/log/ppp (#118837)
|
||||||
|
|
||||||
* Mon Feb 11 2008 Martin Nagy <mnagy@redhat.com> 2.4.4-4
|
* Mon Feb 11 2008 Martin Nagy <mnagy@redhat.com> 2.4.4-4
|
||||||
- rebuild for gcc-4.3
|
- rebuild for gcc-4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user