Keep lock files in /var/lock (https://github.com/ppp-project/ppp/pull/227)
This commit is contained in:
parent
e8f51851e7
commit
bfc43d320d
@ -1,26 +0,0 @@
|
|||||||
From c5a5f795b1defcb6d168e79c4d1fc371dfc556ca Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jiri Skala <jskala@redhat.com>
|
|
||||||
Date: Wed, 9 Apr 2014 09:29:50 +0200
|
|
||||||
Subject: [PATCH 20/27] pppd: put lock files in /var/lock/ppp
|
|
||||||
|
|
||||||
Resolves: #708260
|
|
||||||
---
|
|
||||||
pppd/utils.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/pppd/utils.c b/pppd/utils.c
|
|
||||||
index 6051b9a..8407492 100644
|
|
||||||
--- a/pppd/utils.c
|
|
||||||
+++ b/pppd/utils.c
|
|
||||||
@@ -846,7 +846,7 @@ complete_read(int fd, void *buf, size_t count)
|
|
||||||
/* Procedures for locking the serial device using a lock file. */
|
|
||||||
#ifndef LOCK_DIR
|
|
||||||
#ifdef __linux__
|
|
||||||
-#define LOCK_DIR "/var/lock"
|
|
||||||
+#define LOCK_DIR "/var/lock/ppp"
|
|
||||||
#else
|
|
||||||
#ifdef SVR4
|
|
||||||
#define LOCK_DIR "/var/spool/locks"
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
@ -1,2 +1 @@
|
|||||||
d /run/ppp 0755 root root
|
d /run/ppp 0755 root root
|
||||||
d /run/lock/ppp 0755 root root
|
|
||||||
|
11
ppp.spec
11
ppp.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.9
|
Version: 2.4.9
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: The Point-to-Point Protocol daemon
|
Summary: The Point-to-Point Protocol daemon
|
||||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||||
URL: http://www.samba.org/ppp
|
URL: http://www.samba.org/ppp
|
||||||
@ -33,7 +33,6 @@ Patch0014: 0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
|
|||||||
Patch0015: 0015-pppd-move-pppd-database-to-var-run-ppp.patch
|
Patch0015: 0015-pppd-move-pppd-database-to-var-run-ppp.patch
|
||||||
Patch0016: 0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
|
Patch0016: 0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
|
||||||
Patch0018: 0018-scritps-fix-ip-up.local-sample.patch
|
Patch0018: 0018-scritps-fix-ip-up.local-sample.patch
|
||||||
Patch0020: 0020-pppd-put-lock-files-in-var-lock-ppp.patch
|
|
||||||
Patch0023: 0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
|
Patch0023: 0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
|
||||||
Patch0024: 0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
|
Patch0024: 0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
|
||||||
Patch0025: ppp-2.4.8-pppd-install-pppd-binary-using-standard-perms-755.patch
|
Patch0025: ppp-2.4.8-pppd-install-pppd-binary-using-standard-perms-755.patch
|
||||||
@ -72,8 +71,7 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
|
|||||||
This package contains the header files for building plugins for ppp.
|
This package contains the header files for building plugins for ppp.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -qn %{name}-%{name}-%{version}
|
%autosetup -p1 -n %{name}-%{name}-%{version}
|
||||||
%autopatch -p1
|
|
||||||
|
|
||||||
tar -xJf %{SOURCE12}
|
tar -xJf %{SOURCE12}
|
||||||
|
|
||||||
@ -117,7 +115,6 @@ install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdo
|
|||||||
|
|
||||||
# ghosts
|
# ghosts
|
||||||
mkdir -p %{buildroot}%{_rundir}/ppp
|
mkdir -p %{buildroot}%{_rundir}/ppp
|
||||||
mkdir -p %{buildroot}%{_rundir}/lock/ppp
|
|
||||||
|
|
||||||
%pre
|
%pre
|
||||||
/usr/bin/getent group dip >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 40 dip >/dev/null 2>&1 || :
|
/usr/bin/getent group dip >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 40 dip >/dev/null 2>&1 || :
|
||||||
@ -150,7 +147,6 @@ mkdir -p %{buildroot}%{_rundir}/lock/ppp
|
|||||||
%{_mandir}/man8/ppp-watch.8*
|
%{_mandir}/man8/ppp-watch.8*
|
||||||
%{_libdir}/pppd
|
%{_libdir}/pppd
|
||||||
%ghost %dir %{_rundir}/ppp
|
%ghost %dir %{_rundir}/ppp
|
||||||
%ghost %dir %{_rundir}/lock/ppp
|
|
||||||
%dir %{_sysconfdir}/logrotate.d
|
%dir %{_sysconfdir}/logrotate.d
|
||||||
%attr(700, root, root) %dir %{_localstatedir}/log/ppp
|
%attr(700, root, root) %dir %{_localstatedir}/log/ppp
|
||||||
%config(noreplace) %{_sysconfdir}/ppp/eaptls-client
|
%config(noreplace) %{_sysconfdir}/ppp/eaptls-client
|
||||||
@ -171,6 +167,9 @@ mkdir -p %{buildroot}%{_rundir}/lock/ppp
|
|||||||
%doc PLUGINS
|
%doc PLUGINS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 8 2021 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.9-3
|
||||||
|
- Keep lock files in /var/lock (https://github.com/ppp-project/ppp/pull/227)
|
||||||
|
|
||||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.9-2
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.9-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user