Fixed radiusclient parser
Resolves: RHEL-44665
This commit is contained in:
parent
22f935fff3
commit
ab3c38a57d
49
ppp-2.5.0-radiusclient-parser-fix.patch
Normal file
49
ppp-2.5.0-radiusclient-parser-fix.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
From 7f89208b860ea0c41636410bfdb6a609b2772f47 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Eivind Naess <eivnaes@yahoo.com>
|
||||||
|
Date: Sun, 23 Apr 2023 11:37:01 -0700
|
||||||
|
Subject: [PATCH] Closes #411, Fixing up parsing in radiusclient.conf
|
||||||
|
|
||||||
|
Adding curly braces to fix the code.
|
||||||
|
|
||||||
|
Signed-off-by: Eivind Naess <eivnaes@yahoo.com>
|
||||||
|
---
|
||||||
|
pppd/plugins/radius/config.c | 12 ++++++++----
|
||||||
|
1 file changed, 8 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/pppd/plugins/radius/config.c b/pppd/plugins/radius/config.c
|
||||||
|
index 39744fca1..e1a481487 100644
|
||||||
|
--- a/pppd/plugins/radius/config.c
|
||||||
|
+++ b/pppd/plugins/radius/config.c
|
||||||
|
@@ -235,24 +235,28 @@ int rc_read_config(char *filename)
|
||||||
|
|
||||||
|
switch (option->type) {
|
||||||
|
case OT_STR:
|
||||||
|
- if (set_option_str(filename, line, option, p) < 0)
|
||||||
|
+ if (set_option_str(filename, line, option, p) < 0) {
|
||||||
|
fclose(configfd);
|
||||||
|
return (-1);
|
||||||
|
+ }
|
||||||
|
break;
|
||||||
|
case OT_INT:
|
||||||
|
- if (set_option_int(filename, line, option, p) < 0)
|
||||||
|
+ if (set_option_int(filename, line, option, p) < 0) {
|
||||||
|
fclose(configfd);
|
||||||
|
return (-1);
|
||||||
|
+ }
|
||||||
|
break;
|
||||||
|
case OT_SRV:
|
||||||
|
- if (set_option_srv(filename, line, option, p) < 0)
|
||||||
|
+ if (set_option_srv(filename, line, option, p) < 0) {
|
||||||
|
fclose(configfd);
|
||||||
|
return (-1);
|
||||||
|
+ }
|
||||||
|
break;
|
||||||
|
case OT_AUO:
|
||||||
|
- if (set_option_auo(filename, line, option, p) < 0)
|
||||||
|
+ if (set_option_auo(filename, line, option, p) < 0) {
|
||||||
|
fclose(configfd);
|
||||||
|
return (-1);
|
||||||
|
+ }
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
fatal("rc_read_config: impossible case branch!");
|
9
ppp.spec
9
ppp.spec
@ -18,7 +18,7 @@ Name: ppp
|
|||||||
# These all need to be patched (if necessary) and rebuilt for new
|
# These all need to be patched (if necessary) and rebuilt for new
|
||||||
# versions of ppp.
|
# versions of ppp.
|
||||||
Version: 2.5.0
|
Version: 2.5.0
|
||||||
Release: 11%{?dist}
|
Release: 12%{?dist}
|
||||||
Summary: The Point-to-Point Protocol daemon
|
Summary: The Point-to-Point Protocol daemon
|
||||||
License: bsd-3-clause AND zlib AND licenseref-fedora-public-domain AND bsd-attribution-hpnd-disclaimer AND bsd-4.3tahoe AND bsd-4-clause-uc AND apache-2.0 AND lgpl-2.0-or-later AND (gpl-2.0-or-later OR bsd-2-clause OR bsd-3-clause OR bsd-4-clause) AND gpl-2.0-or-later AND xlock AND gpl-1.0-or-later AND mackerras-3-clause-acknowledgment AND mackerras-3-clause AND hpnd-fenneberg-Livingston AND sun-ppp AND hpnd-inria-imag AND sun-ppp-2000
|
License: bsd-3-clause AND zlib AND licenseref-fedora-public-domain AND bsd-attribution-hpnd-disclaimer AND bsd-4.3tahoe AND bsd-4-clause-uc AND apache-2.0 AND lgpl-2.0-or-later AND (gpl-2.0-or-later OR bsd-2-clause OR bsd-3-clause OR bsd-4-clause) AND gpl-2.0-or-later AND xlock AND gpl-1.0-or-later AND mackerras-3-clause-acknowledgment AND mackerras-3-clause AND hpnd-fenneberg-Livingston AND sun-ppp AND hpnd-inria-imag AND sun-ppp-2000
|
||||||
URL: http://www.samba.org/ppp
|
URL: http://www.samba.org/ppp
|
||||||
@ -40,6 +40,9 @@ Source14: ipv6-down.initscripts
|
|||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch0: ppp-2.5.0-use-change-resolv-function.patch
|
Patch0: ppp-2.5.0-use-change-resolv-function.patch
|
||||||
|
|
||||||
|
# https://github.com/ppp-project/ppp/commit/7f89208b860ea0c41636410bfdb6a609b2772f47
|
||||||
|
Patch1: ppp-2.5.0-radiusclient-parser-fix.patch
|
||||||
|
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -180,6 +183,10 @@ mkdir -p %{buildroot}%{_rundir}/pppd/lock
|
|||||||
%{_libdir}/pkgconfig/pppd.pc
|
%{_libdir}/pkgconfig/pppd.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 27 2024 Jaroslav Škarvada <jskarvad@redhat.com> - 2.5.0-12
|
||||||
|
- Fixed radiusclient parser
|
||||||
|
Resolves: RHEL-44665
|
||||||
|
|
||||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2.5.0-11
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2.5.0-11
|
||||||
- Bump release for June 2024 mass rebuild
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user