Added workaround for Windows Server 2019
Resolves: rhbz#1867047
This commit is contained in:
parent
22365d4cf2
commit
a9d0d03ee8
27
ppp-2.4.8-ws-2019-workaround.patch
Normal file
27
ppp-2.4.8-ws-2019-workaround.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 3cd95baf3f1de1d5a9bc89be0f4c3215ceb5aefe Mon Sep 17 00:00:00 2001
|
||||||
|
From: yannayl <yannayl@users.noreply.github.com>
|
||||||
|
Date: Sun, 12 Jul 2020 12:12:08 +0300
|
||||||
|
Subject: [PATCH] Accept Malformed Windows Success Message
|
||||||
|
|
||||||
|
Windows Server 2019 skip a space when sending a success message.
|
||||||
|
This commit accepts such a malformed message and continues normally.
|
||||||
|
|
||||||
|
Signed-off-by: Yannay Linveh <yannayl@gmail.com>
|
||||||
|
Signed-off-by: yannayl <yannayl@users.noreply.github.com>
|
||||||
|
---
|
||||||
|
pppd/chap_ms.c | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/pppd/chap_ms.c b/pppd/chap_ms.c
|
||||||
|
index 1de50428..ffb6bd13 100644
|
||||||
|
--- a/pppd/chap_ms.c
|
||||||
|
+++ b/pppd/chap_ms.c
|
||||||
|
@@ -423,6 +423,8 @@ chapms2_check_success(int id, unsigned char *msg, int len)
|
||||||
|
len -= MS_AUTH_RESPONSE_LENGTH;
|
||||||
|
if ((len >= 3) && !strncmp((char *)msg, " M=", 3)) {
|
||||||
|
msg += 3; /* Eat the delimiter */
|
||||||
|
+ } else if ((len >= 2) && !strncmp((char *)msg, "M=", 2)) {
|
||||||
|
+ msg += 2; /* Eat the delimiter */
|
||||||
|
} else if (len) {
|
||||||
|
/* Packet has extra text which does not begin " M=" */
|
||||||
|
error("MS-CHAPv2 Success packet is badly formed.");
|
8
ppp.spec
8
ppp.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.8
|
Version: 2.4.8
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: The Point-to-Point Protocol daemon
|
Summary: The Point-to-Point Protocol daemon
|
||||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||||
URL: http://www.samba.org/ppp
|
URL: http://www.samba.org/ppp
|
||||||
@ -52,6 +52,8 @@ Patch0026: ppp-2.4.8-eaptls-mppe-1.300.patch
|
|||||||
Patch0032: ppp-2.4.8-CVE-2020-8597.patch
|
Patch0032: ppp-2.4.8-CVE-2020-8597.patch
|
||||||
# rhbz#1612918, https://github.com/paulusmack/ppp/pull/149
|
# rhbz#1612918, https://github.com/paulusmack/ppp/pull/149
|
||||||
Patch0033: ppp-2.4.8-man-fix.patch
|
Patch0033: ppp-2.4.8-man-fix.patch
|
||||||
|
# rhbz#1867047, https://github.com/paulusmack/ppp/commit/3cd95baf3f1de1d5a9bc89be0f4c3215ceb5aefe.patch
|
||||||
|
Patch0034: ppp-2.4.8-ws-2019-workaround.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: pam-devel, libpcap-devel, systemd, systemd-devel, glib2-devel
|
BuildRequires: pam-devel, libpcap-devel, systemd, systemd-devel, glib2-devel
|
||||||
@ -186,6 +188,10 @@ mkdir -p %{buildroot}%{_rundir}/lock/ppp
|
|||||||
%doc PLUGINS
|
%doc PLUGINS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 10 2020 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.8-8
|
||||||
|
- Added workaround for Windows Server 2019
|
||||||
|
Resolves: rhbz#1867047
|
||||||
|
|
||||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.8-7
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.8-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user