add ipv6cp-accept-remote to make my DSL work with demand dial and native
IPv6
This commit is contained in:
parent
4dce1cb4f7
commit
9fa254a5b6
40
ppp-2.4.3-ipv6-accept-remote.patch
Normal file
40
ppp-2.4.3-ipv6-accept-remote.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
--- ppp-2.4.3/pppd/ipv6cp.c~ 2005-11-04 09:40:10.000000000 +0000
|
||||||
|
+++ ppp-2.4.3/pppd/ipv6cp.c 2005-11-04 10:20:14.000000000 +0000
|
||||||
|
@@ -235,6 +235,8 @@ static option_t ipv6cp_option_list[] = {
|
||||||
|
|
||||||
|
{ "ipv6cp-accept-local", o_bool, &ipv6cp_allowoptions[0].accept_local,
|
||||||
|
"Accept peer's interface identifier for us", 1 },
|
||||||
|
+ { "ipv6cp-accept-remote", o_bool, &ipv6cp_allowoptions[0].accept_remote,
|
||||||
|
+ "Accept peer's interface identifier for itself", 1 },
|
||||||
|
|
||||||
|
{ "ipv6cp-use-ipaddr", o_bool, &ipv6cp_allowoptions[0].use_ip,
|
||||||
|
"Use (default) IPv4 address as interface identifier", 1 },
|
||||||
|
@@ -427,6 +429,7 @@ ipv6cp_init(unit)
|
||||||
|
memset(ao, 0, sizeof(*ao));
|
||||||
|
|
||||||
|
wo->accept_local = 1;
|
||||||
|
+ wo->accept_remote = 1;
|
||||||
|
wo->neg_ifaceid = 1;
|
||||||
|
ao->neg_ifaceid = 1;
|
||||||
|
|
||||||
|
@@ -952,7 +955,7 @@ ipv6cp_reqci(f, inp, len, reject_if_disa
|
||||||
|
orc = CONFREJ; /* Reject CI */
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
- if (!eui64_iszero(wo->hisid) &&
|
||||||
|
+ if (!eui64_iszero(wo->hisid) && !wo->accept_remote &&
|
||||||
|
!eui64_equals(ifaceid, wo->hisid) &&
|
||||||
|
eui64_iszero(go->hisid)) {
|
||||||
|
|
||||||
|
--- ppp-2.4.3/pppd/ipv6cp.h~ 2002-12-04 23:03:32.000000000 +0000
|
||||||
|
+++ ppp-2.4.3/pppd/ipv6cp.h 2005-11-04 10:20:55.000000000 +0000
|
||||||
|
@@ -150,7 +150,8 @@
|
||||||
|
typedef struct ipv6cp_options {
|
||||||
|
int neg_ifaceid; /* Negotiate interface identifier? */
|
||||||
|
int req_ifaceid; /* Ask peer to send interface identifier? */
|
||||||
|
- int accept_local; /* accept peer's value for iface id? */
|
||||||
|
+ int accept_local; /* accept peer's value for our iface id? */
|
||||||
|
+ int accept_remote; /* accept peer's value for his iface id? */
|
||||||
|
int opt_local; /* ourtoken set by option */
|
||||||
|
int opt_remote; /* histoken set by option */
|
||||||
|
int use_ip; /* use IP as interface identifier */
|
7
ppp.spec
7
ppp.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The PPP (Point-to-Point Protocol) daemon.
|
Summary: The PPP (Point-to-Point Protocol) daemon.
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.3
|
Version: 2.4.3
|
||||||
Release: 4
|
Release: 5
|
||||||
License: distributable
|
License: distributable
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
|
Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
|
||||||
@ -23,6 +23,7 @@ Patch16: ppp-2.4.2-pppoatm-mtu.patch
|
|||||||
Patch17: ppp-2.4.2-pppoatm-make.patch
|
Patch17: ppp-2.4.2-pppoatm-make.patch
|
||||||
Patch18: ppp-2.4.3-radiusplugin.patch
|
Patch18: ppp-2.4.3-radiusplugin.patch
|
||||||
Patch19: ppp-2.4.3-local.patch
|
Patch19: ppp-2.4.3-local.patch
|
||||||
|
Patch20: ppp-2.4.3-ipv6-accept-remote.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
BuildPrereq: pam-devel, libpcap
|
BuildPrereq: pam-devel, libpcap
|
||||||
@ -55,6 +56,7 @@ organization over a modem and phone line.
|
|||||||
%patch17 -p1 -b .atm-make
|
%patch17 -p1 -b .atm-make
|
||||||
%patch18 -p1 -b .radiusplugin
|
%patch18 -p1 -b .radiusplugin
|
||||||
%patch19 -p1 -b .local
|
%patch19 -p1 -b .local
|
||||||
|
%patch20 -p1 -b .ipv6cp
|
||||||
|
|
||||||
|
|
||||||
find . -type f -name "*.sample" | xargs rm -f
|
find . -type f -name "*.sample" | xargs rm -f
|
||||||
@ -116,6 +118,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 4 2005 David Woodhouse <dwmw2@redhat.com> 2.4.3-5
|
||||||
|
- Implement ipv6cp-accept-remote option
|
||||||
|
|
||||||
* Fri Oct 7 2005 Tomas Mraz <tmraz@redhat.com> 2.4.3-4
|
* Fri Oct 7 2005 Tomas Mraz <tmraz@redhat.com> 2.4.3-4
|
||||||
- use include instead of pam_stack in pam config
|
- use include instead of pam_stack in pam config
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user