parent
8f86d050ae
commit
8fed35dbe8
27
0028-Fix-logical-expression-in-eap_client_active-macro.patch
Normal file
27
0028-Fix-logical-expression-in-eap_client_active-macro.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From fcb95abad72ac043f2e5f5ddcffc42b0783a3c2d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michal Sekletar <msekleta@redhat.com>
|
||||||
|
Date: Wed, 10 Dec 2014 12:21:31 +0100
|
||||||
|
Subject: [PATCH] Fix logical expression in eap_client_active macro
|
||||||
|
|
||||||
|
---
|
||||||
|
pppd/eap.h | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/pppd/eap.h b/pppd/eap.h
|
||||||
|
index 3fa5391..087baad 100644
|
||||||
|
--- a/pppd/eap.h
|
||||||
|
+++ b/pppd/eap.h
|
||||||
|
@@ -110,8 +110,8 @@ enum eap_state_code {
|
||||||
|
"SRP1", "SRP2", "SRP3", "MD5Chall", "Open", "SRP4", "BadAuth"
|
||||||
|
|
||||||
|
#ifdef USE_EAPTLS
|
||||||
|
-#define eap_client_active(esp) ((esp)->es_client.ea_state != eapInitial ||\
|
||||||
|
- (esp)->es_client.ea_state != eapPending ||\
|
||||||
|
+#define eap_client_active(esp) ((esp)->es_client.ea_state != eapInitial &&\
|
||||||
|
+ (esp)->es_client.ea_state != eapPending &&\
|
||||||
|
(esp)->es_client.ea_state != eapClosed)
|
||||||
|
#else
|
||||||
|
#define eap_client_active(esp) ((esp)->es_client.ea_state == eapListen)
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
60
ppp.spec
60
ppp.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: The Point-to-Point Protocol daemon
|
Summary: The Point-to-Point Protocol daemon
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.7
|
Version: 2.4.7
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.samba.org/ppp
|
URL: http://www.samba.org/ppp
|
||||||
@ -22,33 +22,34 @@ Source11: ifdown-ppp
|
|||||||
Source12: ppp-watch.tar.xz
|
Source12: ppp-watch.tar.xz
|
||||||
|
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch0001: 0001-build-sys-use-gcc-as-our-compiler-of-choice.patch
|
Patch0001: 0001-build-sys-use-gcc-as-our-compiler-of-choice.patch
|
||||||
Patch0002: 0002-build-sys-enable-PAM-support.patch
|
Patch0002: 0002-build-sys-enable-PAM-support.patch
|
||||||
Patch0003: 0003-build-sys-utilize-compiler-flags-handed-to-us-by-rpm.patch
|
Patch0003: 0003-build-sys-utilize-compiler-flags-handed-to-us-by-rpm.patch
|
||||||
Patch0004: 0004-doc-add-configuration-samples.patch
|
Patch0004: 0004-doc-add-configuration-samples.patch
|
||||||
Patch0005: 0005-build-sys-don-t-hardcode-LIBDIR-but-set-it-according.patch
|
Patch0005: 0005-build-sys-don-t-hardcode-LIBDIR-but-set-it-according.patch
|
||||||
Patch0006: 0006-scritps-use-change_resolv_conf-function.patch
|
Patch0006: 0006-scritps-use-change_resolv_conf-function.patch
|
||||||
Patch0007: 0007-build-sys-don-t-strip-binaries-during-installation.patch
|
Patch0007: 0007-build-sys-don-t-strip-binaries-during-installation.patch
|
||||||
Patch0008: 0008-build-sys-use-prefix-usr-instead-of-usr-local.patch
|
Patch0008: 0008-build-sys-use-prefix-usr-instead-of-usr-local.patch
|
||||||
Patch0009: 0009-pppd-introduce-ipv6-accept-remote.patch
|
Patch0009: 0009-pppd-introduce-ipv6-accept-remote.patch
|
||||||
Patch0010: 0010-build-sys-enable-CBCP.patch
|
Patch0010: 0010-build-sys-enable-CBCP.patch
|
||||||
Patch0011: 0011-build-sys-don-t-put-connect-errors-log-to-etc-ppp.patch
|
Patch0011: 0011-build-sys-don-t-put-connect-errors-log-to-etc-ppp.patch
|
||||||
Patch0012: 0012-pppd-we-don-t-want-to-accidentally-leak-fds.patch
|
Patch0012: 0012-pppd-we-don-t-want-to-accidentally-leak-fds.patch
|
||||||
Patch0013: 0013-everywhere-O_CLOEXEC-harder.patch
|
Patch0013: 0013-everywhere-O_CLOEXEC-harder.patch
|
||||||
Patch0014: 0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
|
Patch0014: 0014-everywhere-use-SOCK_CLOEXEC-when-creating-socket.patch
|
||||||
Patch0015: 0015-pppd-move-pppd-database-to-var-run-ppp.patch
|
Patch0015: 0015-pppd-move-pppd-database-to-var-run-ppp.patch
|
||||||
Patch0016: 0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
|
Patch0016: 0016-rp-pppoe-add-manpage-for-pppoe-discovery.patch
|
||||||
Patch0017: 0017-pppd-rebase-EAP-TLS-patch-v0.994.patch
|
Patch0017: 0017-pppd-rebase-EAP-TLS-patch-v0.994.patch
|
||||||
Patch0018: 0018-scritps-fix-ip-up.local-sample.patch
|
Patch0018: 0018-scritps-fix-ip-up.local-sample.patch
|
||||||
Patch0019: 0019-sys-linux-rework-get_first_ethernet.patch
|
Patch0019: 0019-sys-linux-rework-get_first_ethernet.patch
|
||||||
Patch0020: 0020-pppd-put-lock-files-in-var-lock-ppp.patch
|
Patch0020: 0020-pppd-put-lock-files-in-var-lock-ppp.patch
|
||||||
Patch0021: 0021-build-sys-compile-pppol2tp-plugin-with-RPM_OPT_FLAGS.patch
|
Patch0021: 0021-build-sys-compile-pppol2tp-plugin-with-RPM_OPT_FLAGS.patch
|
||||||
Patch0022: 0022-build-sys-compile-pppol2tp-with-multilink-support.patch
|
Patch0022: 0022-build-sys-compile-pppol2tp-with-multilink-support.patch
|
||||||
Patch0023: 0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
|
Patch0023: 0023-build-sys-install-rp-pppoe-plugin-files-with-standar.patch
|
||||||
Patch0024: 0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
|
Patch0024: 0024-build-sys-install-pppoatm-plugin-files-with-standard.patch
|
||||||
Patch0025: 0025-pppd-install-pppd-binary-using-standard-perms-755.patch
|
Patch0025: 0025-pppd-install-pppd-binary-using-standard-perms-755.patch
|
||||||
Patch0026: 0026-Revert-pppd-rebase-EAP-TLS-patch-v0.994.patch
|
Patch0026: 0026-Revert-pppd-rebase-EAP-TLS-patch-v0.994.patch
|
||||||
Patch0027: 0027-pppd-EAP-TLS-patch-v0.997.patch
|
Patch0027: 0027-pppd-EAP-TLS-patch-v0.997.patch
|
||||||
|
Patch0028: 0028-Fix-logical-expression-in-eap_client_active-macro.patch
|
||||||
|
|
||||||
BuildRequires: pam-devel, libpcap-devel, openssl-devel, systemd, systemd-devel, glib2-devel
|
BuildRequires: pam-devel, libpcap-devel, openssl-devel, systemd, systemd-devel, glib2-devel
|
||||||
Requires: glibc >= 2.0.6, /etc/pam.d/system-auth, libpcap >= 14:0.8.3-6, systemd, initscripts >= 9.54
|
Requires: glibc >= 2.0.6, /etc/pam.d/system-auth, libpcap >= 14:0.8.3-6, systemd, initscripts >= 9.54
|
||||||
@ -167,6 +168,9 @@ install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdo
|
|||||||
%doc PLUGINS
|
%doc PLUGINS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 10 2014 Michal Sekletar <msekleta@redhat.com> - 2.4.7-6
|
||||||
|
- fix logical expression in eap_client_active macro (#1023620)
|
||||||
|
|
||||||
* Wed Nov 19 2014 Michal Sekletar <msekleta@redhat.com> - 2.4.7-5
|
* Wed Nov 19 2014 Michal Sekletar <msekleta@redhat.com> - 2.4.7-5
|
||||||
- don't mark logrotate config as executable (#1164435)
|
- don't mark logrotate config as executable (#1164435)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user