- added pppoe-discovery(8)
This commit is contained in:
parent
9197d9a22a
commit
8c3cba1c1c
109
ppp-2.4.5-manpg.patch
Normal file
109
ppp-2.4.5-manpg.patch
Normal file
@ -0,0 +1,109 @@
|
||||
diff -up ppp-2.4.5/pppd/plugins/rp-pppoe/Makefile.linux.manpg ppp-2.4.5/pppd/plugins/rp-pppoe/Makefile.linux
|
||||
--- ppp-2.4.5/pppd/plugins/rp-pppoe/Makefile.linux.manpg 2010-04-07 14:47:48.211413928 +0200
|
||||
+++ ppp-2.4.5/pppd/plugins/rp-pppoe/Makefile.linux 2010-04-07 14:47:48.281414608 +0200
|
||||
@@ -16,6 +16,7 @@
|
||||
|
||||
DESTDIR = $(INSTROOT)@DESTDIR@
|
||||
BINDIR = $(DESTDIR)/sbin
|
||||
+MANDIR = $(DESTDIR)/share/man/man8
|
||||
LIBDIR = $(DESTDIR)/lib/$(shell gcc -print-multi-os-directory 2> /dev/null)/pppd/$(PPPDVERSION)
|
||||
|
||||
PPPDVERSION = $(shell awk -F '"' '/VERSION/ { print $$2; }' ../../patchlevel.h)
|
||||
@@ -46,6 +47,7 @@ install: all
|
||||
$(INSTALL) -c -m 4550 rp-pppoe.so $(LIBDIR)
|
||||
$(INSTALL) -d -m 755 $(BINDIR)
|
||||
$(INSTALL) -c -m 555 pppoe-discovery $(BINDIR)
|
||||
+ $(INSTALL) -c -m 444 pppoe-discovery.8 $(MANDIR)
|
||||
|
||||
clean:
|
||||
rm -f *.o *.so pppoe-discovery
|
||||
diff -up ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.8.manpg ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.8
|
||||
--- ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.8.manpg 2010-04-07 14:49:31.059416743 +0200
|
||||
+++ ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.8 2010-04-07 14:50:11.008416347 +0200
|
||||
@@ -0,0 +1,86 @@
|
||||
+.\" pppoe-discovery.8 written by
|
||||
+.\" Ben Hutchings <ben@decadentplace.org.uk>, based on pppoe.8.
|
||||
+.\" Licenced under the GPL version 2 or later.
|
||||
+.TH PPPOE-DISCOVERY 8
|
||||
+.SH NAME
|
||||
+pppoe\-discovery \- perform PPPoE discovery
|
||||
+.SH SYNOPSIS
|
||||
+.B pppoe\-discovery
|
||||
+[
|
||||
+.I options
|
||||
+]
|
||||
+.br
|
||||
+.BR pppoe\-discovery " { " \-V " | " \-h " }"
|
||||
+.SH DESCRIPTION
|
||||
+.LP
|
||||
+\fBpppoe\-discovery\fR performs the same discovery process as
|
||||
+\fBpppoe\fR, but does not initiate a session.
|
||||
+It sends a PADI packet and then prints the names of access
|
||||
+concentrators in each PADO packet it receives.
|
||||
+.SH OPTIONS
|
||||
+.TP
|
||||
+.BI \-I " interface"
|
||||
+.RS
|
||||
+The \fB\-I\fR option specifies the Ethernet interface to use.
|
||||
+Under Linux, it is typically eth0 or eth1.
|
||||
+The interface should be \(lqup\(rq before you start
|
||||
+\fBpppoe\-discovery\fR, but should \fInot\fR be configured to have an
|
||||
+IP address.
|
||||
+The default interface is eth0.
|
||||
+.RE
|
||||
+.TP
|
||||
+.BI \-D " file_name"
|
||||
+.RS
|
||||
+The \fB\-D\fR option causes every packet to be dumped to the specified
|
||||
+\fIfile_name\fR.
|
||||
+This is intended for debugging only.
|
||||
+.RE
|
||||
+.TP
|
||||
+.B \-U
|
||||
+.RS
|
||||
+Causes \fBpppoe\-discovery\fR to use the Host-Uniq tag in its discovery
|
||||
+packets.
|
||||
+This lets you run multiple instances of \fBpppoe\-discovery\fR and/or
|
||||
+\fBpppoe\fR without having their discovery packets interfere with one
|
||||
+another.
|
||||
+You must supply this option to \fIall\fR instances that you intend to
|
||||
+run simultaneously.
|
||||
+.RE
|
||||
+.TP
|
||||
+.BI \-S " service_name"
|
||||
+.RS
|
||||
+Specifies the desired service name.
|
||||
+\fBpppoe\-discovery\fR will only accept access concentrators which can
|
||||
+provide the specified service.
|
||||
+In most cases, you should \fInot\fR specify this option.
|
||||
+Use it only if you know that there are multiple access concentrators
|
||||
+or know that you need a specific service name.
|
||||
+.RE
|
||||
+.TP
|
||||
+.BI \-C " ac_name"
|
||||
+.RS
|
||||
+Specifies the desired access concentrator name.
|
||||
+\fBpppoe\-discovery\fR will only accept the specified access
|
||||
+concentrator.
|
||||
+In most cases, you should \fInot\fR specify this option.
|
||||
+Use it only if you know that there are multiple access concentrators.
|
||||
+If both the \fB\-S\fR and \fB\-C\fR options are specified, they must
|
||||
+\fIboth\fR match.
|
||||
+.RE
|
||||
+.TP
|
||||
+.B \-A
|
||||
+.RS
|
||||
+This option is accepted for compatibility with \fBpppoe\fR, but has no
|
||||
+effect.
|
||||
+.RE
|
||||
+.TP
|
||||
+.BR \-V " | " \-h
|
||||
+.RS
|
||||
+Either of these options causes \fBpppoe\-discovery\fR to print its
|
||||
+version number and usage information, then exit.
|
||||
+.RE
|
||||
+.SH AUTHORS
|
||||
+\fBpppoe\-discovery\fR was written by Marco d'Itri <md@linux.it>,
|
||||
+based on \fBpppoe\fR by David F. Skoll <dfs@roaringpenguin.com>.
|
||||
+.SH SEE ALSO
|
||||
+pppoe(8), pppoe-sniff(8)
|
3
ppp.spec
3
ppp.spec
@ -114,6 +114,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man8/pppd-radattr.8*
|
||||
%{_mandir}/man8/pppd-radius.8*
|
||||
%{_mandir}/man8/pppstats.8*
|
||||
%{_mandir}/man8/pppoe-discovery.8*
|
||||
%{_libdir}/pppd
|
||||
%dir /etc/ppp
|
||||
%dir /var/run/ppp
|
||||
@ -130,7 +131,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/pppd
|
||||
%doc PLUGINS
|
||||
|
||||
%changeloga
|
||||
%changelog
|
||||
* Wed Apr 07 2010 Jiri Skala <jskala@redhat.com> - 2.4.5-8
|
||||
- added pppoe-discovery(8)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user