Link with -E not to break plugins
Resolves: rhbz#1564459
This commit is contained in:
parent
cf1e6c7c6b
commit
8870b357ca
@ -11,6 +11,28 @@ index 2445637..83114f1 100644
|
||||
|
||||
chat.o: chat.c
|
||||
$(CC) -c $(CFLAGS) -o chat.o chat.c
|
||||
diff --git a/pppd/Makefile.linux b/pppd/Makefile.linux
|
||||
index cf11b74..089f164 100644
|
||||
--- a/pppd/Makefile.linux
|
||||
+++ b/pppd/Makefile.linux
|
||||
@@ -188,7 +188,7 @@ endif
|
||||
|
||||
ifdef PLUGIN
|
||||
CFLAGS += -DPLUGIN
|
||||
-LDFLAGS += -Wl,-E
|
||||
+LDFLAGS_PLUGIN += -Wl,-E
|
||||
LIBS += -ldl
|
||||
endif
|
||||
|
||||
@@ -230,7 +230,7 @@ install: pppd
|
||||
$(INSTALL) -c -m 644 pppd.8 $(MANDIR)
|
||||
|
||||
pppd: $(PPPDOBJS)
|
||||
- $(CC) $(CFLAGS) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_PLUGIN) -o pppd $(PPPDOBJS) $(LIBS)
|
||||
|
||||
srp-entry: srp-entry.c
|
||||
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ srp-entry.c $(LIBS)
|
||||
diff --git a/pppd/plugins/Makefile.linux b/pppd/plugins/Makefile.linux
|
||||
index 303833a..04fe876 100644
|
||||
--- a/pppd/plugins/Makefile.linux
|
||||
|
6
ppp.spec
6
ppp.spec
@ -3,7 +3,7 @@
|
||||
Summary: The Point-to-Point Protocol daemon
|
||||
Name: ppp
|
||||
Version: 2.4.7
|
||||
Release: 20%{?dist}
|
||||
Release: 21%{?dist}
|
||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.samba.org/ppp
|
||||
@ -175,6 +175,10 @@ install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/network-scripts/ifdo
|
||||
%doc PLUGINS
|
||||
|
||||
%changelog
|
||||
* Mon Apr 9 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.7-21
|
||||
- Link with -E not to break plugins
|
||||
Resolves: rhbz#1564459
|
||||
|
||||
* Fri Apr 6 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.7-20
|
||||
- Also build all DSOs with distro's LDFLAGS
|
||||
Related: rhbz#1563157
|
||||
|
Loading…
Reference in New Issue
Block a user