fix license tag
This commit is contained in:
parent
cecb2d6fea
commit
8078de6547
@ -1,11 +1,12 @@
|
||||
--- ppp-2.4.1/pppd/utils.c Thu Jun 6 16:22:58 2002
|
||||
+++ ppp-2.4.1/pppd/utils.c Thu Jun 6 16:22:00 2002
|
||||
@@ -254,7 +254,7 @@
|
||||
break;
|
||||
diff -up ppp-2.4.4/pppd/utils.c.varargs ppp-2.4.4/pppd/utils.c
|
||||
--- ppp-2.4.4/pppd/utils.c.varargs 2004-11-04 05:02:26.000000000 -0500
|
||||
+++ ppp-2.4.4/pppd/utils.c 2008-08-28 17:34:29.000000000 -0400
|
||||
@@ -290,7 +290,7 @@ vslprintf(buf, buflen, fmt, args)
|
||||
#if 0 /* not used, and breaks on S/390, apparently */
|
||||
case 'r':
|
||||
f = va_arg(args, char *);
|
||||
-#ifndef __powerpc__
|
||||
+#if !defined(__powerpc__) && !defined(__s390__) && !defined(__s390x__) && !defined(__x86_64__)
|
||||
+#if !defined (__powerpc__) && !defined(__s390__) && !defined(__s390x__) && !defined(__x86_64__)
|
||||
n = vslprintf(buf, buflen + 1, f, va_arg(args, va_list));
|
||||
#else
|
||||
/* On the powerpc, a va_list is an array of 1 structure */
|
||||
|
@ -1,17 +1,7 @@
|
||||
--- ppp-2.4.2/pppd/Makefile.linux.pie 2004-05-14 13:46:14.188327258 +0200
|
||||
+++ ppp-2.4.2/pppd/Makefile.linux 2004-05-14 13:46:16.147058249 +0200
|
||||
@@ -206,7 +206,7 @@
|
||||
$(INSTALL) -c -m 444 pppd.8 $(MANDIR)/man8
|
||||
|
||||
pppd: $(PPPDOBJS)
|
||||
- $(CC) $(CFLAGS) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
|
||||
+ $(CC) $(CFLAGS) -pie $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
|
||||
|
||||
srp-entry: srp-entry.c
|
||||
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ srp-entry.c $(LIBS)
|
||||
--- ppp-2.4.2/chat/Makefile.linux.pie 2004-05-14 13:46:32.699784925 +0200
|
||||
+++ ppp-2.4.2/chat/Makefile.linux 2004-05-14 13:46:45.071085866 +0200
|
||||
@@ -14,7 +14,7 @@
|
||||
diff -up ppp-2.4.4/chat/Makefile.linux.pie ppp-2.4.4/chat/Makefile.linux
|
||||
--- ppp-2.4.4/chat/Makefile.linux.pie 2008-08-28 17:34:49.000000000 -0400
|
||||
+++ ppp-2.4.4/chat/Makefile.linux 2008-08-28 17:34:49.000000000 -0400
|
||||
@@ -18,7 +18,7 @@ INSTALL= install
|
||||
all: chat
|
||||
|
||||
chat: chat.o
|
||||
@ -20,3 +10,15 @@
|
||||
|
||||
chat.o: chat.c
|
||||
$(CC) -c $(CFLAGS) -o chat.o chat.c
|
||||
diff -up ppp-2.4.4/pppd/Makefile.linux.pie ppp-2.4.4/pppd/Makefile.linux
|
||||
--- ppp-2.4.4/pppd/Makefile.linux.pie 2008-08-28 17:34:49.000000000 -0400
|
||||
+++ ppp-2.4.4/pppd/Makefile.linux 2008-08-28 17:35:38.000000000 -0400
|
||||
@@ -207,7 +207,7 @@ install: pppd
|
||||
$(INSTALL) -c -m 444 pppd.8 $(MANDIR)
|
||||
|
||||
pppd: $(PPPDOBJS)
|
||||
- $(CC) $(CFLAGS) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
|
||||
+ $(CC) $(CFLAGS) -pie $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
|
||||
|
||||
srp-entry: srp-entry.c
|
||||
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ srp-entry.c $(LIBS)
|
||||
|
@ -1,9 +1,10 @@
|
||||
--- ppp-2.4.2/pppd/plugins/pppoatm/Makefile.linux.make 2004-10-04 11:37:28.331818344 +0100
|
||||
+++ ppp-2.4.2/pppd/plugins/pppoatm/Makefile.linux 2004-10-04 11:37:54.884781680 +0100
|
||||
diff -up ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux.atm-make ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux
|
||||
--- ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux.atm-make 2008-08-28 17:36:10.000000000 -0400
|
||||
+++ ppp-2.4.4/pppd/plugins/pppoatm/Makefile.linux 2008-08-28 17:36:56.000000000 -0400
|
||||
@@ -1,5 +1,5 @@
|
||||
CC = gcc
|
||||
-COPTS = -O2 -g
|
||||
+COPTS = $(RPM_OPT_FLAGS)
|
||||
CFLAGS = $(COPTS) -I../.. -I../../../include -fPIC
|
||||
LDFLAGS = -shared
|
||||
INSTALL = install -o root
|
||||
INSTALL = install
|
||||
|
@ -1,46 +1,8 @@
|
||||
--- ppp/scripts/ppp-on-rsh.old 2005-07-19 09:16:55.000000000 -0500
|
||||
+++ ppp/scripts/ppp-on-rsh 2005-07-19 09:16:39.000000000 -0500
|
||||
@@ -26,7 +26,7 @@
|
||||
# For this example, we assume that pppd on both local and remote
|
||||
# machines reside in the same place, /usr/local/bin/pppd
|
||||
#
|
||||
-PPPD_LOC=/usr/local/bin/pppd
|
||||
+PPPD_LOC=/usr/sbin/pppd
|
||||
|
||||
#
|
||||
# The location of local options file (where rsh client is running).
|
||||
--- ppp/scripts/secure-card.old 2004-02-01 21:36:46.000000000 -0600
|
||||
+++ ppp/scripts/secure-card 2005-07-19 09:14:19.000000000 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/local/bin/expect -f
|
||||
+#!/usr/bin/expect -f
|
||||
#
|
||||
# This script was written by Jim Isaacson <jcisaac@crl.com>. It is
|
||||
# designed to work as a script to use the SecureCARD(tm) device. This
|
||||
--- ppp/scripts/ppp-on-ssh.old 2000-04-15 04:49:42.000000000 -0500
|
||||
+++ ppp/scripts/ppp-on-ssh 2005-07-19 09:17:25.000000000 -0500
|
||||
@@ -26,7 +26,7 @@
|
||||
# For this example, we assume that pppd on both local and remote
|
||||
# machines reside in the same place, /usr/local/bin/pppd
|
||||
#
|
||||
-PPPD_LOC=/usr/local/bin/pppd
|
||||
+PPPD_LOC=/usr/sbin/pppd
|
||||
|
||||
#
|
||||
# The location of local options file (where ssh client is running).
|
||||
@@ -52,7 +52,7 @@
|
||||
#
|
||||
# The location of ssh client on the local machine
|
||||
#
|
||||
-SSH_LOC=/usr/local/bin/ssh
|
||||
+SSH_LOC=/usr/bin/ssh
|
||||
|
||||
export PPPD_LOC PPPD_LOC_OPT PPPD_REM_OPT PPPD_RHOST SSH_LOC
|
||||
|
||||
--- ppp/configure.old 2004-11-06 05:36:54.000000000 -0600
|
||||
+++ ppp/configure 2005-07-19 09:24:29.000000000 -0500
|
||||
diff -up ppp-2.4.4/configure.local ppp-2.4.4/configure
|
||||
--- ppp-2.4.4/configure.local 2005-07-08 20:23:05.000000000 -0400
|
||||
+++ ppp-2.4.4/configure 2008-08-28 17:38:04.000000000 -0400
|
||||
@@ -2,7 +2,7 @@
|
||||
# $Id: configure,v 1.35 2004/11/06 11:36:54 paulus Exp $
|
||||
# $Id: configure,v 1.37 2005/06/26 23:53:17 carlsonj Exp $
|
||||
|
||||
# Where to install stuff by default
|
||||
-DESTDIR=/usr/local
|
||||
@ -48,9 +10,10 @@
|
||||
SYSCONF=/etc
|
||||
|
||||
# if [ -d /NextApps ]; then
|
||||
--- ppp-2.4.3/pppd/Makefile.linux.old 2005-07-19 09:22:21.000000000 -0500
|
||||
+++ ppp-2.4.3/pppd/Makefile.linux 2005-07-19 09:30:58.000000000 -0500
|
||||
@@ -96,8 +96,8 @@
|
||||
diff -up ppp-2.4.4/pppd/Makefile.linux.local ppp-2.4.4/pppd/Makefile.linux
|
||||
--- ppp-2.4.4/pppd/Makefile.linux.local 2008-08-28 17:37:33.000000000 -0400
|
||||
+++ ppp-2.4.4/pppd/Makefile.linux 2008-08-28 17:37:33.000000000 -0400
|
||||
@@ -97,8 +97,8 @@ endif
|
||||
|
||||
# EAP SRP-SHA1
|
||||
ifdef USE_SRP
|
||||
@ -61,3 +24,45 @@
|
||||
TARGETS += srp-entry
|
||||
EXTRAINSTALL = $(INSTALL) -c -m 555 srp-entry $(BINDIR)/srp-entry
|
||||
MANPAGES += srp-entry.8
|
||||
diff -up ppp-2.4.4/scripts/ppp-on-rsh.local ppp-2.4.4/scripts/ppp-on-rsh
|
||||
--- ppp-2.4.4/scripts/ppp-on-rsh.local 2000-04-15 05:49:28.000000000 -0400
|
||||
+++ ppp-2.4.4/scripts/ppp-on-rsh 2008-08-28 17:37:33.000000000 -0400
|
||||
@@ -26,7 +26,7 @@ PPPD_RHOST=myremotehost
|
||||
# For this example, we assume that pppd on both local and remote
|
||||
# machines reside in the same place, /usr/local/bin/pppd
|
||||
#
|
||||
-PPPD_LOC=/usr/local/bin/pppd
|
||||
+PPPD_LOC=/usr/sbin/pppd
|
||||
|
||||
#
|
||||
# The location of local options file (where rsh client is running).
|
||||
diff -up ppp-2.4.4/scripts/ppp-on-ssh.local ppp-2.4.4/scripts/ppp-on-ssh
|
||||
--- ppp-2.4.4/scripts/ppp-on-ssh.local 2000-04-15 05:49:42.000000000 -0400
|
||||
+++ ppp-2.4.4/scripts/ppp-on-ssh 2008-08-28 17:37:33.000000000 -0400
|
||||
@@ -26,7 +26,7 @@ PPPD_RHOST=myremotehost
|
||||
# For this example, we assume that pppd on both local and remote
|
||||
# machines reside in the same place, /usr/local/bin/pppd
|
||||
#
|
||||
-PPPD_LOC=/usr/local/bin/pppd
|
||||
+PPPD_LOC=/usr/sbin/pppd
|
||||
|
||||
#
|
||||
# The location of local options file (where ssh client is running).
|
||||
@@ -52,7 +52,7 @@ PPPD_REM_OPT=/etc/ppp/options-ssh-rem
|
||||
#
|
||||
# The location of ssh client on the local machine
|
||||
#
|
||||
-SSH_LOC=/usr/local/bin/ssh
|
||||
+SSH_LOC=/usr/bin/ssh
|
||||
|
||||
export PPPD_LOC PPPD_LOC_OPT PPPD_REM_OPT PPPD_RHOST SSH_LOC
|
||||
|
||||
diff -up ppp-2.4.4/scripts/secure-card.local ppp-2.4.4/scripts/secure-card
|
||||
--- ppp-2.4.4/scripts/secure-card.local 2004-02-01 22:36:46.000000000 -0500
|
||||
+++ ppp-2.4.4/scripts/secure-card 2008-08-28 17:37:33.000000000 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/local/bin/expect -f
|
||||
+#!/usr/bin/expect -f
|
||||
#
|
||||
# This script was written by Jim Isaacson <jcisaac@crl.com>. It is
|
||||
# designed to work as a script to use the SecureCARD(tm) device. This
|
||||
|
7
ppp.spec
7
ppp.spec
@ -1,8 +1,8 @@
|
||||
Summary: The PPP (Point-to-Point Protocol) daemon.
|
||||
Name: ppp
|
||||
Version: 2.4.4
|
||||
Release: 7%{?dist}
|
||||
License: distributable
|
||||
Release: 8%{?dist}
|
||||
License: BSD and LGPLv2+ and GPLv2+ and Public Domain
|
||||
Group: System Environment/Daemons
|
||||
Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
|
||||
Source1: ppp-2.3.5-pamd.conf
|
||||
@ -134,6 +134,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc PLUGINS
|
||||
|
||||
%changelog
|
||||
* Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.4.4-8
|
||||
- fix license tag
|
||||
|
||||
* Tue May 13 2008 Martin Nagy <mnagy@redhat.com> 2.4.4-7
|
||||
- add new speeds, patch by Jason Vas Dias (#446132)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user