- call closelog earlier (#222295)
- fix ChapMS2 (#217076) - moving header files to new -devel package (#203542)
This commit is contained in:
parent
c4b72070a5
commit
642ed42b4c
20
ppp-2.4.4-closelog.patch
Normal file
20
ppp-2.4.4-closelog.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -up ppp-2.4.4/pppd/main.c.closelog ppp-2.4.4/pppd/main.c
|
||||||
|
--- ppp-2.4.4/pppd/main.c.closelog 2008-03-06 22:54:19.000000000 +0100
|
||||||
|
+++ ppp-2.4.4/pppd/main.c 2008-03-06 22:54:31.000000000 +0100
|
||||||
|
@@ -1567,6 +1567,8 @@ safe_fork(int infd, int outfd, int errfd
|
||||||
|
if (errfd == 0 || errfd == 1)
|
||||||
|
errfd = dup(errfd);
|
||||||
|
|
||||||
|
+ closelog();
|
||||||
|
+
|
||||||
|
/* dup the in, out, err fds to 0, 1, 2 */
|
||||||
|
if (infd != 0)
|
||||||
|
dup2(infd, 0);
|
||||||
|
@@ -1575,7 +1577,6 @@ safe_fork(int infd, int outfd, int errfd
|
||||||
|
if (errfd != 2)
|
||||||
|
dup2(errfd, 2);
|
||||||
|
|
||||||
|
- closelog();
|
||||||
|
if (log_to_fd > 2)
|
||||||
|
close(log_to_fd);
|
||||||
|
if (the_channel->close)
|
12
ppp-2.4.4-response_len.patch
Normal file
12
ppp-2.4.4-response_len.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up ppp-2.4.4/pppd/chap_ms.c.response_len ppp-2.4.4/pppd/chap_ms.c
|
||||||
|
--- ppp-2.4.4/pppd/chap_ms.c.response_len 2008-03-06 23:07:18.000000000 +0100
|
||||||
|
+++ ppp-2.4.4/pppd/chap_ms.c 2008-03-06 23:07:49.000000000 +0100
|
||||||
|
@@ -852,7 +852,7 @@ ChapMS2(u_char *rchallenge, u_char *Peer
|
||||||
|
u_char *p = &response[MS_CHAP2_PEER_CHALLENGE];
|
||||||
|
int i;
|
||||||
|
|
||||||
|
- BZERO(response, sizeof(*response));
|
||||||
|
+ BZERO(response, MS_CHAP2_RESPONSE_LEN);
|
||||||
|
|
||||||
|
/* Generate the Peer-Challenge if requested, or copy it if supplied. */
|
||||||
|
if (!PeerChallenge)
|
25
ppp.spec
25
ppp.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The PPP (Point-to-Point Protocol) daemon.
|
Summary: The PPP (Point-to-Point Protocol) daemon.
|
||||||
Name: ppp
|
Name: ppp
|
||||||
Version: 2.4.4
|
Version: 2.4.4
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: distributable
|
License: distributable
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
|
Source0: ftp://ftp.samba.org/pub/ppp/ppp-%{version}.tar.gz
|
||||||
@ -24,6 +24,8 @@ Patch20: ppp-2.4.3-ipv6-accept-remote.patch
|
|||||||
Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
|
Patch21: ppp-2.4.3-usepeerdns-var_run_ppp_resolv.conf.patch
|
||||||
Patch22: ppp-2.4.4-cbcp.patch
|
Patch22: ppp-2.4.4-cbcp.patch
|
||||||
Patch23: ppp-2.4.2-dontwriteetc.patch
|
Patch23: ppp-2.4.2-dontwriteetc.patch
|
||||||
|
Patch24: ppp-2.4.4-closelog.patch
|
||||||
|
Patch25: ppp-2.4.4-response_len.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
BuildPrereq: pam-devel, libpcap-devel
|
BuildPrereq: pam-devel, libpcap-devel
|
||||||
@ -36,6 +38,13 @@ transmitting datagrams over serial point-to-point links. PPP is
|
|||||||
usually used to dial in to an ISP (Internet Service Provider) or other
|
usually used to dial in to an ISP (Internet Service Provider) or other
|
||||||
organization over a modem and phone line.
|
organization over a modem and phone line.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Headers for ppp plugin development
|
||||||
|
Group: Development/Libraries
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains the header files for building plugins for ppp.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .make
|
%patch0 -p1 -b .make
|
||||||
@ -57,6 +66,8 @@ organization over a modem and phone line.
|
|||||||
%patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
|
%patch21 -p1 -b .usepeerdns-var_run_ppp_resolv
|
||||||
%patch22 -p1 -b .cbcp
|
%patch22 -p1 -b .cbcp
|
||||||
%patch23 -p1 -b .dontwriteetc
|
%patch23 -p1 -b .dontwriteetc
|
||||||
|
%patch24 -p1 -b .closelog
|
||||||
|
%patch25 -p1 -b .response_len
|
||||||
|
|
||||||
rm -f scripts/*.local
|
rm -f scripts/*.local
|
||||||
rm -f scripts/*.change_resolv_conf
|
rm -f scripts/*.change_resolv_conf
|
||||||
@ -104,7 +115,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man8/pppd-radattr.8*
|
%{_mandir}/man8/pppd-radattr.8*
|
||||||
%{_mandir}/man8/pppd-radius.8*
|
%{_mandir}/man8/pppd-radius.8*
|
||||||
%{_mandir}/man8/pppstats.8*
|
%{_mandir}/man8/pppstats.8*
|
||||||
%{_includedir}/pppd
|
|
||||||
%{_libdir}/pppd
|
%{_libdir}/pppd
|
||||||
%dir /etc/ppp
|
%dir /etc/ppp
|
||||||
%dir /var/run/ppp
|
%dir /var/run/ppp
|
||||||
@ -114,10 +124,19 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%config /etc/ppp/pap-secrets
|
%config /etc/ppp/pap-secrets
|
||||||
%config /etc/pam.d/ppp
|
%config /etc/pam.d/ppp
|
||||||
%config /etc/logrotate.d/ppp
|
%config /etc/logrotate.d/ppp
|
||||||
%doc FAQ PLUGINS README README.cbcp README.linux README.MPPE README.MSCHAP80 README.MSCHAP81 README.pwfd README.pppoe scripts sample
|
%doc FAQ README README.cbcp README.linux README.MPPE README.MSCHAP80 README.MSCHAP81 README.pwfd README.pppoe scripts sample
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_includedir}/pppd
|
||||||
|
%doc PLUGINS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 06 2008 Martin Nagy <mnagy@redhat.com> 2.4.4-6
|
||||||
|
- call closelog earlier (#222295)
|
||||||
|
- fix ChapMS2 (#217076)
|
||||||
|
- moving header files to new -devel package (#203542)
|
||||||
|
|
||||||
* Mon Mar 03 2008 Martin Nagy <mnagy@redhat.com> 2.4.4-5
|
* Mon Mar 03 2008 Martin Nagy <mnagy@redhat.com> 2.4.4-5
|
||||||
- put logs into /var/log/ppp (#118837)
|
- put logs into /var/log/ppp (#118837)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user