ppc64-diag/ppc64-diag-permission.patch

64 lines
3.4 KiB
Diff

diff -up ppc64-diag-2.7.4/diags/Makefile.am.than ppc64-diag-2.7.4/diags/Makefile.am
--- ppc64-diag-2.7.4/diags/Makefile.am.than 2018-03-09 14:23:50.504115816 +0100
+++ ppc64-diag-2.7.4/diags/Makefile.am 2018-03-09 14:24:31.454855174 +0100
@@ -43,7 +43,7 @@ DIAG_CRONTAB_SCRIPT = diags/run_diag_enc
install-exec-hook-diag:
install -d --mode=755 $(DESTDIR)/var/log/ppc64-diag/diag_disk
install -d --mode=755 $(DESTDIR)/etc/cron.daily/
- install -D --mode=744 $(DIAG_CRONTAB_SCRIPT) $(DESTDIR)/etc/cron.daily/
+ install -D --mode=644 $(DIAG_CRONTAB_SCRIPT) $(DESTDIR)/etc/cron.daily/
INSTALL_EXEC_HOOKS += install-exec-hook-diag
diff -up ppc64-diag-2.7.4/ela/Makefile.am.than ppc64-diag-2.7.4/ela/Makefile.am
--- ppc64-diag-2.7.4/ela/Makefile.am.than 2018-03-09 14:12:39.942018046 +0100
+++ ppc64-diag-2.7.4/ela/Makefile.am 2018-03-09 14:13:19.962739978 +0100
@@ -69,8 +69,8 @@ CLEAN_LOCALS += clean-local-ela
install-exec-hook-ela:
install -d --mode=755 $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
- install -D --mode=744 $(CATALOG) $(DESTDIR)/usr/share/ppc64-diag/message_catalog/
- install -D --mode=744 $(CATALOG_REGEX) \
+ install -D --mode=644 $(CATALOG) $(DESTDIR)/usr/share/ppc64-diag/message_catalog/
+ install -D --mode=644 $(CATALOG_REGEX) \
$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
INSTALL_EXEC_HOOKS += install-exec-hook-ela
diff -up ppc64-diag-2.7.4/rtas_errd/Makefile.am.than ppc64-diag-2.7.4/rtas_errd/Makefile.am
--- ppc64-diag-2.7.4/rtas_errd/Makefile.am.than 2018-03-09 14:21:08.211186688 +0100
+++ ppc64-diag-2.7.4/rtas_errd/Makefile.am 2018-03-09 14:21:16.781341284 +0100
@@ -46,7 +46,7 @@ rtas_scripts = rtas_errd/rc.powerfail
install-exec-hook-rtas-errd:
install -d --mode=755 $(DESTDIR)/etc/
- install -D --mode=744 $(rtas_scripts) $(DESTDIR)/etc/
+ install -D --mode=755 $(rtas_scripts) $(DESTDIR)/etc/
uninstall-hook-rtas-errd:
rm -f $(DESTDIR)/etc/rc.powerfail
diff -up ppc64-diag-2.7.4/scripts/Makefile.am.than ppc64-diag-2.7.4/scripts/Makefile.am
diff -up ppc64-diag-2.7.4/scripts/Makefile.am.than ppc64-diag-2.7.4/scripts/Makefile.am
--- ppc64-diag-2.7.4/scripts/Makefile.am.than 2018-03-09 14:32:56.393971751 +0100
+++ ppc64-diag-2.7.4/scripts/Makefile.am 2018-03-09 14:33:18.374368602 +0100
@@ -13,7 +13,7 @@ SERVICE_SCRIPT = scripts/rtas_errd.servi
install-exec-hook-scripts:
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
+ install -D --mode=755 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
diff -up ppc64-diag-2.7.4/lpd/Makefile.am.than ppc64-diag-2.7.4/lpd/Makefile.am
--- ppc64-diag-2.7.4/lpd/Makefile.am.than 2018-03-09 14:35:40.576936043 +0100
+++ ppc64-diag-2.7.4/lpd/Makefile.am 2018-03-09 14:36:05.927393740 +0100
@@ -47,7 +47,7 @@ AM_LOCALS += all-local-lpd
install-exec-hook-lpd:
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag
- install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
+ install -D --mode=755 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysattn
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysfault