ppc64-diag/SOURCES/ppc64-diag-scriptlocation.p...

139 lines
6.6 KiB
Diff

diff -up ppc64-diag-2.7.4/scripts/Makefile.am.script_loc ppc64-diag-2.7.4/scripts/Makefile.am
--- ppc64-diag-2.7.4/scripts/Makefile.am.script_loc 2017-07-24 06:43:44.000000000 +0200
+++ ppc64-diag-2.7.4/scripts/Makefile.am 2018-03-08 17:14:52.827188427 +0100
@@ -11,20 +11,21 @@ INIT_FILES = scripts/rtas_errd scripts/o
SERVICE_SCRIPT = scripts/rtas_errd.service scripts/opal_errd.service
install-exec-hook-scripts:
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
- install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag
+ install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
+ install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
install -d --mode=755 $(DESTDIR)/usr/lib/systemd/system/
install -D --mode=644 $(SERVICE_SCRIPT) $(DESTDIR)/usr/lib/systemd/system/
uninstall-hook-scripts:
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_setup
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_mkrsrc
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_notify
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_migrate
- rm -f $(DESTDIR)/etc/ppc64-diag/servevent_parse.pl
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_setup
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_notify
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_migrate
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/servevent_parse.pl
rm -f $(DESTDIR)/etc/ppc64-diag/ppc64-diag.config
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/rtas_errd
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/opal_errd
diff -up ppc64-diag-2.7.4/scripts/ppc64_diag_migrate.script_loc ppc64-diag-2.7.4/scripts/ppc64_diag_migrate
--- ppc64-diag-2.7.4/scripts/ppc64_diag_migrate.script_loc 2017-07-24 06:43:44.000000000 +0200
+++ ppc64-diag-2.7.4/scripts/ppc64_diag_migrate 2018-03-08 17:11:16.843240860 +0100
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
#
# This script is to be registered with servicelog as a notification tool. It
# is responsible for performing whatever actions may be necessary following
diff -up ppc64-diag-2.7.4/scripts/ppc64_diag_mkrsrc.script_loc ppc64-diag-2.7.4/scripts/ppc64_diag_mkrsrc
--- ppc64-diag-2.7.4/scripts/ppc64_diag_mkrsrc.script_loc 2017-07-24 06:43:44.000000000 +0200
+++ ppc64-diag-2.7.4/scripts/ppc64_diag_mkrsrc 2018-03-08 17:11:16.843240860 +0100
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
#
# This script is to be registered with servicelog as a notification tool. It
# is responsible for creating a new IBM.ServiceEvent RMC resource when a
@@ -27,7 +27,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-require "/etc/ppc64-diag/servevent_parse.pl";
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
# Check to make sure that devices.chrp.base.ServiceRM is installed
$rc = system("which rpm >/dev/null 2>&1");
diff -up ppc64-diag-2.7.4/scripts/ppc64_diag_notify.script_loc ppc64-diag-2.7.4/scripts/ppc64_diag_notify
--- ppc64-diag-2.7.4/scripts/ppc64_diag_notify.script_loc 2017-07-24 06:43:44.000000000 +0200
+++ ppc64-diag-2.7.4/scripts/ppc64_diag_notify 2018-03-08 17:11:16.843240860 +0100
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
#
# This script is to be registered with servicelog as a notification tool. It
# is responsible for sending out e-mail notifications of new ppc64 platform
@@ -22,7 +22,7 @@
use Getopt::Long;
-require "/etc/ppc64-diag/servevent_parse.pl";
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
sub usage {
print "$0 [OPTIONS]\n";
@@ -156,7 +156,7 @@ if ($flag_email) {
chomp $hostname;
$subject = "$hostname: serviceable platform event logged";
- if (open(MAILLIST, "< /etc/ppc64-diag/mail_list")) {
+ if (open(MAILLIST, "< /usr/libexec/ppc64-diag/mail_list")) {
while (<MAILLIST>) {
chomp;
$pos = index($_, "#");
diff -up ppc64-diag-2.7.4/scripts/ppc64_diag_servagent.script_loc ppc64-diag-2.7.4/scripts/ppc64_diag_servagent
--- ppc64-diag-2.7.4/scripts/ppc64_diag_servagent.script_loc 2017-07-24 06:43:44.000000000 +0200
+++ ppc64-diag-2.7.4/scripts/ppc64_diag_servagent 2018-03-08 17:11:16.843240860 +0100
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
#
# This script is to be registered with servicelog as a notification tool. It
# is responsible for invoking Electronic Service Agent in response to a
@@ -25,7 +25,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-require "/etc/ppc64-diag/servevent_parse.pl";
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
if (!-e "/usr/svcagent/bin/callsa2") {
# eSA is not installed; exit quietly
diff -up ppc64-diag-2.7.4/scripts/ppc64_diag_setup.script_loc ppc64-diag-2.7.4/scripts/ppc64_diag_setup
--- ppc64-diag-2.7.4/scripts/ppc64_diag_setup.script_loc 2017-07-24 06:43:44.000000000 +0200
+++ ppc64-diag-2.7.4/scripts/ppc64_diag_setup 2018-03-08 17:11:16.843240860 +0100
@@ -89,15 +89,15 @@ sub unregister {
@notification_tools = (
- ["/etc/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
+ ["/usr/libexec/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
"--match='serviceable=1' ".
"--type=EVENT --method=pairs_stdin"],
- ["/etc/ppc64-diag/ppc64_diag_mkrsrc",
+ ["/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc",
"--match='serviceable=1' ".
"--type=EVENT --method=pairs_stdin"],
- ["/etc/ppc64-diag/ppc64_diag_migrate",
+ ["/usr/libexec/ppc64-diag/ppc64_diag_migrate",
"--match=\'refcode=\"#MIGRATE\" and serviceable=0\' ".
"--type=EVENT --method=pairs_stdin"],
);
diff -up ppc64-diag-2.7.4/scripts/rtas_errd.script_loc ppc64-diag-2.7.4/scripts/rtas_errd
--- ppc64-diag-2.7.4/scripts/rtas_errd.script_loc 2018-03-08 17:11:16.833240678 +0100
+++ ppc64-diag-2.7.4/scripts/rtas_errd 2018-03-08 17:11:16.843240860 +0100
@@ -69,7 +69,7 @@ case "$1" in
echo "registering ppc64-diag with system"
rm -f /var/cache/ppc64-diag.registered
mkdir -v /var/cache/ppc64-diag.registered
- /etc/ppc64-diag/ppc64_diag_setup --register
+ /usr/libexec/ppc64-diag/ppc64_diag_setup --register
fi
echo -n "Starting rtas_errd (platform error handling) daemon: "
if [ $INSSERV -eq 1 ]; then