4bf4133332
Also cleaned up additional patches. Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
80 lines
3.1 KiB
Diff
80 lines
3.1 KiB
Diff
From 47c29d1884912af81e392cbae3b17f6cfb720c1f Mon Sep 17 00:00:00 2001
|
|
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
Date: Thu, 25 Sep 2014 16:28:35 +0530
|
|
Subject: [PATCH 1/5] Update message location
|
|
|
|
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
---
|
|
ela/Makefile | 8 ++++----
|
|
ela/catalogs.h | 2 +-
|
|
ela/explain_syslog.cpp | 2 +-
|
|
ela/syslog_to_svclog.cpp | 2 +-
|
|
4 files changed, 7 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/ela/Makefile b/ela/Makefile
|
|
index 2205cd2..ad52c5e 100644
|
|
--- a/ela/Makefile
|
|
+++ b/ela/Makefile
|
|
@@ -67,8 +67,8 @@ catalogs.o: catalogs.h
|
|
|
|
install: all
|
|
@$(call install_sbin,$(CMDS),$(DESTDIR))
|
|
- @$(call install_files,$(CATALOG),744,$(DESTDIR)/etc/ppc64-diag/message_catalog)
|
|
- @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex)
|
|
+ @$(call install_files,$(CATALOG),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog)
|
|
+ @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex)
|
|
$(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
|
|
@$(foreach d,$(SUBDIRS), $(MAKE) -C $d install;)
|
|
|
|
@@ -78,6 +78,6 @@ clean:
|
|
|
|
uninstall:
|
|
@$(call uninstall_sbin,$(CMDS),$(DESTDIR))
|
|
- @$(call uninstall_files,$(CATALOG),$(DESTDIR)/etc/ppc64-diag/)
|
|
- @$(call uninstall_files,$(CATALOG_REGEX),$(DESTDIR)/etc/ppc64-diag/)
|
|
+ @$(call uninstall_files,$(CATALOG),$(DESTDIR)/usr/share/ppc64-diag/)
|
|
+ @$(call uninstall_files,$(CATALOG_REGEX),$(DESTDIR)/usr/share/ppc64-diag/)
|
|
@$(foreach d,$(SUBDIRS), $(MAKE) -C $d uninstall;)
|
|
diff --git a/ela/catalogs.h b/ela/catalogs.h
|
|
index 71ad14c..a8f82c2 100644
|
|
--- a/ela/catalogs.h
|
|
+++ b/ela/catalogs.h
|
|
@@ -21,7 +21,7 @@ using namespace std;
|
|
#include <stdio.h>
|
|
#include <regex.h>
|
|
|
|
-#define ELA_CATALOG_DIR "/etc/ppc64-diag/message_catalog"
|
|
+#define ELA_CATALOG_DIR "/usr/share/ppc64-diag/message_catalog"
|
|
|
|
class Parser {
|
|
protected:
|
|
diff --git a/ela/explain_syslog.cpp b/ela/explain_syslog.cpp
|
|
index 87bda1c..85eae68 100644
|
|
--- a/ela/explain_syslog.cpp
|
|
+++ b/ela/explain_syslog.cpp
|
|
@@ -97,7 +97,7 @@ print_help(void)
|
|
printf(
|
|
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
|
|
"-C catalog_dir\tUse message catalog in catalog_dir. Defaults to\n"
|
|
-"\t\t\t/etc/ppc64-diag/message_catalog.\n"
|
|
+"\t\t\t/usr/share/ppc64-diag/message_catalog.\n"
|
|
"-d\t\tPrint debugging output on stderr.\n"
|
|
"-e end_time\tStop upon reading message with timestamp after end_time.\n"
|
|
"-h\t\tPrint this help text and exit.\n"
|
|
diff --git a/ela/syslog_to_svclog.cpp b/ela/syslog_to_svclog.cpp
|
|
index c62e92a..de5c2c8 100644
|
|
--- a/ela/syslog_to_svclog.cpp
|
|
+++ b/ela/syslog_to_svclog.cpp
|
|
@@ -657,7 +657,7 @@ print_help(void)
|
|
printf(
|
|
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
|
|
"-C catalog_dir\tUse message catalog in catalog_dir. Defaults to\n"
|
|
-"\t\t\t/etc/ppc64-diag/message_catalog.\n"
|
|
+"\t\t\t/usr/share/ppc64-diag/message_catalog.\n"
|
|
"-d\t\tPrint debugging output on stderr.\n"
|
|
"-e end_time\tStop upon reading message with timestamp after end_time.\n"
|
|
"-F\t\tDon't stop at EOF; process newly logged messages as they occur.\n"
|
|
--
|
|
1.8.3.1
|
|
|