112 lines
4.9 KiB
Diff
112 lines
4.9 KiB
Diff
diff -up ppc64-diag-2.4.2/scripts/Makefile.scriptloc ppc64-diag-2.4.2/scripts/Makefile
|
|
--- ppc64-diag-2.4.2/scripts/Makefile.scriptloc 2011-09-05 05:58:06.720541401 -0400
|
|
+++ ppc64-diag-2.4.2/scripts/Makefile 2009-05-21 17:33:06.000000000 -0400
|
|
@@ -12,12 +12,12 @@ CFG_FILES = ppc64-diag.config
|
|
all: $(SCRIPTS) $(INIT_FILES) $(CFG_FILES)
|
|
|
|
install: all
|
|
- @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/etc/ppc64-diag)
|
|
+ @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/usr/libexec/ppc64-diag)
|
|
@$(call install_files,$(INIT_FILES),755,$(DESTDIR)/etc/init.d)
|
|
@$(call install_files,$(CFG_FILES),644,$(DESTDIR)/etc/ppc64-diag)
|
|
|
|
uninstall:
|
|
- @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/etc/ppc64-diag)
|
|
+ @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/usr/libexec/ppc64-diag)
|
|
@$(call uninstall_files,$(INIT_FILES),$(DESTDIR)/etc/init.d)
|
|
@$(call uninstall_files,$(CFG_FILES),$(DESTDIR)/etc/ppc64-diag)
|
|
|
|
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc
|
|
--- ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc.scriptloc 2011-09-05 06:04:22.481785543 -0400
|
|
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc 2011-09-05 06:02:45.519756640 -0400
|
|
@@ -1,4 +1,4 @@
|
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
#
|
|
# This script is to be registered with servicelog as a notification tool. It
|
|
# is responsible for creating a new IBM.ServiceEvent RMC resource when a
|
|
@@ -14,7 +14,7 @@
|
|
# Copyright (C) 2005, 2007 IBM Corporation
|
|
#
|
|
|
|
-require "/etc/ppc64-diag/servevent_parse.pl";
|
|
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
|
|
|
|
# Check to make sure that devices.chrp.base.ServiceRM is installed
|
|
$check = `/bin/rpm -q devices.chrp.base.ServiceRM 2>/dev/null`;
|
|
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_notify.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_notify
|
|
--- ppc64-diag-2.4.2/scripts/ppc64_diag_notify.scriptloc 2011-09-05 06:04:37.194638501 -0400
|
|
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_notify 2011-09-05 06:01:43.164377573 -0400
|
|
@@ -1,4 +1,4 @@
|
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
#
|
|
# This script is to be registered with servicelog as a notification tool. It
|
|
# is responsible for sending out e-mail notifications of new ppc64 platform
|
|
@@ -9,7 +9,7 @@
|
|
|
|
use Getopt::Long;
|
|
|
|
-require "/etc/ppc64-diag/servevent_parse.pl";
|
|
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
|
|
|
|
sub usage {
|
|
print "$0 [OPTIONS]\n";
|
|
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_servagent.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_servagent
|
|
--- ppc64-diag-2.4.2/scripts/ppc64_diag_servagent.scriptloc 2011-09-05 06:04:45.922549428 -0400
|
|
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_servagent 2011-09-05 06:02:34.317866330 -0400
|
|
@@ -1,4 +1,4 @@
|
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
#
|
|
# This script is to be registered with servicelog as a notification tool. It
|
|
# is responsible for invoking Electronic Service Agent in response to a
|
|
@@ -12,7 +12,7 @@
|
|
# Copyright (C) 2007 IBM Corporation
|
|
#
|
|
|
|
-require "/etc/ppc64-diag/servevent_parse.pl";
|
|
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
|
|
|
|
if (!-e "/usr/svcagent/bin/callsa2") {
|
|
# eSA is not installed; exit quietly
|
|
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_setup.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_setup
|
|
--- ppc64-diag-2.4.2/scripts/ppc64_diag_setup.scriptloc 2011-09-05 06:05:06.033350396 -0400
|
|
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_setup 2011-09-05 06:00:35.584058181 -0400
|
|
@@ -76,19 +76,19 @@ sub unregister {
|
|
|
|
@notification_tools = (
|
|
|
|
- ["/etc/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
|
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
|
|
"--match='serviceable=1' ".
|
|
"--type=EVENT --method=pairs_stdin"],
|
|
|
|
- ["/etc/ppc64-diag/ppc64_diag_mkrsrc",
|
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc",
|
|
"--match='serviceable=1' ".
|
|
"--type=EVENT --method=pairs_stdin"],
|
|
|
|
- ["/etc/ppc64-diag/ppc64_diag_servagent",
|
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_servagent",
|
|
"--match='serviceable=1 and (type=2 or type=3)' ".
|
|
"--type=EVENT --method=pairs_stdin"],
|
|
|
|
- ["/etc/ppc64-diag/ppc64_diag_migrate",
|
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_migrate",
|
|
"--match=\'refcode=\"#MIGRATE\" and serviceable=0\' ".
|
|
"--type=EVENT --method=pairs_stdin"],
|
|
);
|
|
diff -up ppc64-diag-2.4.2/scripts/rtas_errd.scriptloc ppc64-diag-2.4.2/scripts/rtas_errd
|
|
--- ppc64-diag-2.4.2/scripts/rtas_errd.scriptloc 2011-09-05 05:59:14.982858075 -0400
|
|
+++ ppc64-diag-2.4.2/scripts/rtas_errd 2011-09-05 05:59:34.531662814 -0400
|
|
@@ -49,7 +49,7 @@ case "$1" in
|
|
echo "registering ppc64-diag with system"
|
|
rm -f /var/cache/ppc64-diag.registered
|
|
mkdir -v /var/cache/ppc64-diag.registered
|
|
- /etc/ppc64-diag/ppc64_diag_setup --register
|
|
+ /usr/libexec/ppc64-diag/ppc64_diag_setup --register
|
|
fi
|
|
echo -n "Starting rtas_errd (platform error handling) daemon: "
|
|
if [[ $INSSERV -eq 1 ]]; then
|