104613e9a6
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/ppc64-diag#2ea38cc97e72a87984c71f3d02b0932fda6108e9
56 lines
2.3 KiB
Diff
56 lines
2.3 KiB
Diff
diff -up ppc64-diag-2.7.4/lpd/Makefile.am.than ppc64-diag-2.7.4/lpd/Makefile.am
|
|
--- ppc64-diag-2.7.4/lpd/Makefile.am.than 2018-03-08 16:44:34.393958279 +0100
|
|
+++ ppc64-diag-2.7.4/lpd/Makefile.am 2018-03-08 16:45:29.624967349 +0100
|
|
@@ -46,16 +46,16 @@ all-local-lpd:
|
|
AM_LOCALS += all-local-lpd
|
|
|
|
install-exec-hook-lpd:
|
|
- install -d --mode=755 $(DESTDIR)/etc/ppc64-diag
|
|
- install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
|
|
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag
|
|
+ install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
|
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysattn
|
|
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysfault
|
|
|
|
INSTALL_EXEC_HOOKS += install-exec-hook-lpd
|
|
|
|
uninstall-hook-lpd:
|
|
- rm -f $(DESTDIR)/etc/ppc64-diag/lp_diag_setup
|
|
- rm -f $(DESTDIR)/etc/ppc64-diag/lp_diag_notify
|
|
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/lp_diag_setup
|
|
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/lp_diag_notify
|
|
rm -f $(sbindir)/usysattn
|
|
rm -f $(sbindir)/usysfault
|
|
|
|
diff -up ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify.than ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify
|
|
--- ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify.than 2018-03-08 16:43:08.482388675 +0100
|
|
+++ ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify 2018-03-08 16:43:32.732831731 +0100
|
|
@@ -1,4 +1,4 @@
|
|
-#!/usr/bin/perl -I /etc/ppc64-diag
|
|
+#!/usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
# @file lp_diag_notify
|
|
#
|
|
# This script is to be registered with servicelog as a notification tool.
|
|
diff -up ppc64-diag-2.7.4/lpd/scripts/lp_diag_setup.than ppc64-diag-2.7.4/lpd/scripts/lp_diag_setup
|
|
--- ppc64-diag-2.7.4/lpd/scripts/lp_diag_setup.than 2018-03-08 16:43:46.263078928 +0100
|
|
+++ ppc64-diag-2.7.4/lpd/scripts/lp_diag_setup 2018-03-08 16:44:04.193406516 +0100
|
|
@@ -1,4 +1,4 @@
|
|
-#!/usr/bin/perl -I /etc/ppc64-diag
|
|
+#!/usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
# @file lp_diag_setup
|
|
# @brief Register/unregister Light Path notification tools
|
|
# with servicelog
|
|
@@ -91,10 +91,10 @@ sub unregister {
|
|
}
|
|
|
|
@notification_tools = (
|
|
- ["/etc/ppc64-diag/lp_diag_notify -e",
|
|
+ ["/usr/libexec/ppc64-diag/lp_diag_notify -e",
|
|
"--match='disposition>=1 and severity>=4 and serviceable=1' ".
|
|
"--type=EVENT --method=num_arg"],
|
|
- ["/etc/ppc64-diag/lp_diag_notify -r",
|
|
+ ["/usr/libexec/ppc64-diag/lp_diag_notify -r",
|
|
"--type=REPAIR --method=num_arg"],
|
|
);
|
|
|