4bf4133332
Also cleaned up additional patches. Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
132 lines
4.7 KiB
Diff
132 lines
4.7 KiB
Diff
From 6a9764f7d872c415d0e378254c9d0eae126514a6 Mon Sep 17 00:00:00 2001
|
|
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
Date: Thu, 25 Sep 2014 17:01:20 +0530
|
|
Subject: [PATCH] Update script location
|
|
|
|
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
---
|
|
scripts/Makefile | 4 ++--
|
|
scripts/ppc64_diag_mkrsrc | 4 ++--
|
|
scripts/ppc64_diag_notify | 4 ++--
|
|
scripts/ppc64_diag_servagent | 4 ++--
|
|
scripts/ppc64_diag_setup | 6 +++---
|
|
scripts/rtas_errd | 2 +-
|
|
6 files changed, 12 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/scripts/Makefile b/scripts/Makefile
|
|
index 1ab0d2c..9a3acf5 100644
|
|
--- a/scripts/Makefile
|
|
+++ b/scripts/Makefile
|
|
@@ -13,13 +13,13 @@ CFG_FILES = ppc64-diag.config
|
|
all: $(SCRIPTS) $(INIT_FILES) $(CFG_FILES)
|
|
|
|
install: all
|
|
- @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/etc/ppc64-diag)
|
|
+ @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/usr/libexec/ppc64-diag)
|
|
@$(call install_files,$(INIT_FILES),755,$(DESTDIR)/$(LIBEXEC_DIR))
|
|
@$(call install_files,$(SERVICE_SCRIPT),755,$(DESTDIR)/$(SYSTEMD_DIR))
|
|
@$(call install_files,$(CFG_FILES),644,$(DESTDIR)/etc/ppc64-diag)
|
|
|
|
uninstall:
|
|
- @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/etc/ppc64-diag)
|
|
+ @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/usr/libexec/ppc64-diag)
|
|
@$(call uninstall_files,$(INIT_FILES),$(DESTDIR)/$(LIBEXEC_DIR))
|
|
@$(call uninstall_files,$(SERVICE_SCRIPT),755,$(DESTDIR)/$(SYSTEMD_DIR))
|
|
@$(call uninstall_files,$(CFG_FILES),$(DESTDIR)/etc/ppc64-diag)
|
|
diff --git a/scripts/ppc64_diag_mkrsrc b/scripts/ppc64_diag_mkrsrc
|
|
index 93dac2f..6db33d8 100755
|
|
--- a/scripts/ppc64_diag_mkrsrc
|
|
+++ b/scripts/ppc64_diag_mkrsrc
|
|
@@ -1,4 +1,4 @@
|
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
#
|
|
# This script is to be registered with servicelog as a notification tool. It
|
|
# is responsible for creating a new IBM.ServiceEvent RMC resource when a
|
|
@@ -14,7 +14,7 @@
|
|
# Copyright (C) 2005, 2007 IBM Corporation
|
|
#
|
|
|
|
-require "/etc/ppc64-diag/servevent_parse.pl";
|
|
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
|
|
|
|
# Check to make sure that devices.chrp.base.ServiceRM is installed
|
|
$rc = system("which rpm >/dev/null 2>&1");
|
|
diff --git a/scripts/ppc64_diag_notify b/scripts/ppc64_diag_notify
|
|
index 0374864..9730d06 100755
|
|
--- a/scripts/ppc64_diag_notify
|
|
+++ b/scripts/ppc64_diag_notify
|
|
@@ -1,4 +1,4 @@
|
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
#
|
|
# This script is to be registered with servicelog as a notification tool. It
|
|
# is responsible for sending out e-mail notifications of new ppc64 platform
|
|
@@ -9,7 +9,7 @@
|
|
|
|
use Getopt::Long;
|
|
|
|
-require "/etc/ppc64-diag/servevent_parse.pl";
|
|
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
|
|
|
|
sub usage {
|
|
print "$0 [OPTIONS]\n";
|
|
diff --git a/scripts/ppc64_diag_servagent b/scripts/ppc64_diag_servagent
|
|
index 917f0c3..b1a4a31 100755
|
|
--- a/scripts/ppc64_diag_servagent
|
|
+++ b/scripts/ppc64_diag_servagent
|
|
@@ -1,4 +1,4 @@
|
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
|
#
|
|
# This script is to be registered with servicelog as a notification tool. It
|
|
# is responsible for invoking Electronic Service Agent in response to a
|
|
@@ -12,7 +12,7 @@
|
|
# Copyright (C) 2007 IBM Corporation
|
|
#
|
|
|
|
-require "/etc/ppc64-diag/servevent_parse.pl";
|
|
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
|
|
|
|
if (!-e "/usr/svcagent/bin/callsa2") {
|
|
# eSA is not installed; exit quietly
|
|
diff --git a/scripts/ppc64_diag_setup b/scripts/ppc64_diag_setup
|
|
index b9b691b..091ef55 100755
|
|
--- a/scripts/ppc64_diag_setup
|
|
+++ b/scripts/ppc64_diag_setup
|
|
@@ -76,15 +76,15 @@ sub unregister {
|
|
|
|
@notification_tools = (
|
|
|
|
- ["/etc/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
|
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
|
|
"--match='serviceable=1' ".
|
|
"--type=EVENT --method=pairs_stdin"],
|
|
|
|
- ["/etc/ppc64-diag/ppc64_diag_mkrsrc",
|
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc",
|
|
"--match='serviceable=1' ".
|
|
"--type=EVENT --method=pairs_stdin"],
|
|
|
|
- ["/etc/ppc64-diag/ppc64_diag_migrate",
|
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_migrate",
|
|
"--match=\'refcode=\"#MIGRATE\" and serviceable=0\' ".
|
|
"--type=EVENT --method=pairs_stdin"],
|
|
);
|
|
diff --git a/scripts/rtas_errd b/scripts/rtas_errd
|
|
index c8f9deb..c4cf03a 100755
|
|
--- a/scripts/rtas_errd
|
|
+++ b/scripts/rtas_errd
|
|
@@ -56,7 +56,7 @@ case "$1" in
|
|
echo "registering ppc64-diag with system"
|
|
rm -f /var/cache/ppc64-diag.registered
|
|
mkdir -v /var/cache/ppc64-diag.registered
|
|
- /etc/ppc64-diag/ppc64_diag_setup --register
|
|
+ /usr/libexec/ppc64-diag/ppc64_diag_setup --register
|
|
fi
|
|
echo -n "Starting rtas_errd (platform error handling) daemon: "
|
|
if [ $INSSERV -eq 1 ]; then
|
|
--
|
|
1.8.3.1
|
|
|