ppc64-diag/ppc64-diag-2.4.3-scriptlocation.patch
2012-05-04 15:52:40 +02:00

107 lines
4.7 KiB
Diff

diff -up ppc64-diag-2.4.3/scripts/Makefile.script_loc ppc64-diag-2.4.3/scripts/Makefile
--- ppc64-diag-2.4.3/scripts/Makefile.script_loc 2012-02-14 06:53:59.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/Makefile 2012-05-04 15:32:55.186608517 +0200
@@ -12,12 +12,12 @@ CFG_FILES = ppc64-diag.config
all: $(SCRIPTS) $(INIT_FILES) $(CFG_FILES)
install: all
- @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/etc/ppc64-diag)
+ @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/usr/libexec/ppc64-diag)
@$(call install_files,$(INIT_FILES),755,$(DESTDIR)/etc/init.d)
@$(call install_files,$(CFG_FILES),644,$(DESTDIR)/etc/ppc64-diag)
uninstall:
- @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/etc/ppc64-diag)
+ @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/usr/libexec/ppc64-diag)
@$(call uninstall_files,$(INIT_FILES),$(DESTDIR)/etc/init.d)
@$(call uninstall_files,$(CFG_FILES),$(DESTDIR)/etc/ppc64-diag)
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc
--- ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc.script_loc 2012-01-20 00:53:34.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc 2012-05-04 15:32:55.186608517 +0200
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
#
# This script is to be registered with servicelog as a notification tool. It
# is responsible for creating a new IBM.ServiceEvent RMC resource when a
@@ -14,7 +14,7 @@
# Copyright (C) 2005, 2007 IBM Corporation
#
-require "/etc/ppc64-diag/servevent_parse.pl";
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
# Check to make sure that devices.chrp.base.ServiceRM is installed
$check = `/bin/rpm -q devices.chrp.base.ServiceRM 2>/dev/null`;
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_notify.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_notify
--- ppc64-diag-2.4.3/scripts/ppc64_diag_notify.script_loc 2011-11-08 00:51:25.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_notify 2012-05-04 15:32:55.186608517 +0200
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
#
# This script is to be registered with servicelog as a notification tool. It
# is responsible for sending out e-mail notifications of new ppc64 platform
@@ -9,7 +9,7 @@
use Getopt::Long;
-require "/etc/ppc64-diag/servevent_parse.pl";
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
sub usage {
print "$0 [OPTIONS]\n";
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_servagent.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_servagent
--- ppc64-diag-2.4.3/scripts/ppc64_diag_servagent.script_loc 2011-11-08 00:51:25.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_servagent 2012-05-04 15:32:55.186608517 +0200
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
#
# This script is to be registered with servicelog as a notification tool. It
# is responsible for invoking Electronic Service Agent in response to a
@@ -12,7 +12,7 @@
# Copyright (C) 2007 IBM Corporation
#
-require "/etc/ppc64-diag/servevent_parse.pl";
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
if (!-e "/usr/svcagent/bin/callsa2") {
# eSA is not installed; exit quietly
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_setup.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_setup
--- ppc64-diag-2.4.3/scripts/ppc64_diag_setup.script_loc 2012-02-14 06:53:59.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_setup 2012-05-04 15:34:23.960384271 +0200
@@ -76,15 +76,15 @@ sub unregister {
@notification_tools = (
- ["/etc/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
+ ["/usr/libexec/ppc64-diag/ppc64_diag_notify -q -e root -l /var/log/platform",
"--match='serviceable=1' ".
"--type=EVENT --method=pairs_stdin"],
- ["/etc/ppc64-diag/ppc64_diag_mkrsrc",
+ ["/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc",
"--match='serviceable=1' ".
"--type=EVENT --method=pairs_stdin"],
- ["/etc/ppc64-diag/ppc64_diag_migrate",
+ ["/usr/libexec/ppc64-diag/ppc64_diag_migrate",
"--match=\'refcode=\"#MIGRATE\" and serviceable=0\' ".
"--type=EVENT --method=pairs_stdin"],
);
diff -up ppc64-diag-2.4.3/scripts/rtas_errd.script_loc ppc64-diag-2.4.3/scripts/rtas_errd
--- ppc64-diag-2.4.3/scripts/rtas_errd.script_loc 2012-05-04 15:32:55.173608987 +0200
+++ ppc64-diag-2.4.3/scripts/rtas_errd 2012-05-04 15:32:55.187608480 +0200
@@ -49,7 +49,7 @@ case "$1" in
echo "registering ppc64-diag with system"
rm -f /var/cache/ppc64-diag.registered
mkdir -v /var/cache/ppc64-diag.registered
- /etc/ppc64-diag/ppc64_diag_setup --register
+ /usr/libexec/ppc64-diag/ppc64_diag_setup --register
fi
echo -n "Starting rtas_errd (platform error handling) daemon: "
if [[ $INSSERV -eq 1 ]]; then