49 lines
2.6 KiB
Diff
49 lines
2.6 KiB
Diff
diff -up ppc64-diag-2.7.4/diags/Makefile.am.than ppc64-diag-2.7.4/diags/Makefile.am
|
|
--- ppc64-diag-2.7.4/diags/Makefile.am.than 2018-03-09 14:23:50.504115816 +0100
|
|
+++ ppc64-diag-2.7.4/diags/Makefile.am 2018-03-09 14:24:31.454855174 +0100
|
|
@@ -43,7 +43,7 @@ DIAG_CRONTAB_SCRIPT = diags/run_diag_enc
|
|
install-exec-hook-diag:
|
|
install -d --mode=755 $(DESTDIR)/var/log/ppc64-diag/diag_disk
|
|
install -d --mode=755 $(DESTDIR)/etc/cron.daily/
|
|
- install -D --mode=744 $(DIAG_CRONTAB_SCRIPT) $(DESTDIR)/etc/cron.daily/
|
|
+ install -D --mode=644 $(DIAG_CRONTAB_SCRIPT) $(DESTDIR)/etc/cron.daily/
|
|
|
|
INSTALL_EXEC_HOOKS += install-exec-hook-diag
|
|
|
|
diff -up ppc64-diag-2.7.4/rtas_errd/Makefile.am.than ppc64-diag-2.7.4/rtas_errd/Makefile.am
|
|
--- ppc64-diag-2.7.4/rtas_errd/Makefile.am.than 2018-03-09 14:21:08.211186688 +0100
|
|
+++ ppc64-diag-2.7.4/rtas_errd/Makefile.am 2018-03-09 14:21:16.781341284 +0100
|
|
@@ -46,7 +46,7 @@ rtas_scripts = rtas_errd/rc.powerfail
|
|
|
|
install-exec-hook-rtas-errd:
|
|
install -d --mode=755 $(DESTDIR)/etc/
|
|
- install -D --mode=744 $(rtas_scripts) $(DESTDIR)/etc/
|
|
+ install -D --mode=755 $(rtas_scripts) $(DESTDIR)/etc/
|
|
|
|
uninstall-hook-rtas-errd:
|
|
rm -f $(DESTDIR)/etc/rc.powerfail
|
|
diff -up ppc64-diag-2.7.7/lpd/Makefile.am.orig ppc64-diag-2.7.7/lpd/Makefile.am
|
|
--- ppc64-diag-2.7.7/lpd/Makefile.am.orig 2021-05-17 09:50:40.176840226 +0200
|
|
+++ ppc64-diag-2.7.7/lpd/Makefile.am 2021-05-17 09:51:00.464126336 +0200
|
|
@@ -47,7 +47,7 @@ AM_LOCALS += all-local-lpd
|
|
|
|
install-exec-hook-lpd:
|
|
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag
|
|
- install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
|
+ install -D --mode=755 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
|
(cd $(DESTDIR)/$(sbindir) && $(LN_S) -f usysident usysattn)
|
|
(cd $(DESTDIR)/$(sbindir) && $(LN_S) -f usysident usysfault)
|
|
|
|
diff -up ppc64-diag-2.7.7/scripts/Makefile.am.m ppc64-diag-2.7.7/scripts/Makefile.am
|
|
--- ppc64-diag-2.7.7/scripts/Makefile.am.m 2021-05-17 10:38:25.896078135 +0200
|
|
+++ ppc64-diag-2.7.7/scripts/Makefile.am 2021-05-17 10:40:41.884984190 +0200
|
|
@@ -13,7 +13,7 @@ SERVICE_SCRIPT = scripts/rtas_errd.servi
|
|
install-exec-hook-scripts:
|
|
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
|
install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/
|
|
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
|
+ install -D --mode=755 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
|
install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
|
|
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
|
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
|