Resolves: #1869567, rebase to 2.7.7
This commit is contained in:
parent
e9f4c63d3a
commit
aa3d047699
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@
|
||||
/ppc64-diag-2.7.4.tar.gz
|
||||
/ppc64-diag-2.7.5.tar.gz
|
||||
/ppc64-diag-2.7.6.tar.gz
|
||||
/ppc64-diag-2.7.7.tar.gz
|
||||
|
@ -1,27 +1,3 @@
|
||||
diff -up ppc64-diag-2.7.4/lpd/Makefile.am.than ppc64-diag-2.7.4/lpd/Makefile.am
|
||||
--- ppc64-diag-2.7.4/lpd/Makefile.am.than 2018-03-08 16:44:34.393958279 +0100
|
||||
+++ ppc64-diag-2.7.4/lpd/Makefile.am 2018-03-08 16:45:29.624967349 +0100
|
||||
@@ -46,16 +46,16 @@ all-local-lpd:
|
||||
AM_LOCALS += all-local-lpd
|
||||
|
||||
install-exec-hook-lpd:
|
||||
- install -d --mode=755 $(DESTDIR)/etc/ppc64-diag
|
||||
- install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
|
||||
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag
|
||||
+ install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysattn
|
||||
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysfault
|
||||
|
||||
INSTALL_EXEC_HOOKS += install-exec-hook-lpd
|
||||
|
||||
uninstall-hook-lpd:
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/lp_diag_setup
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/lp_diag_notify
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/lp_diag_setup
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/lp_diag_notify
|
||||
rm -f $(sbindir)/usysattn
|
||||
rm -f $(sbindir)/usysfault
|
||||
|
||||
diff -up ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify.than ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify
|
||||
--- ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify.than 2018-03-08 16:43:08.482388675 +0100
|
||||
+++ ppc64-diag-2.7.4/lpd/scripts/lp_diag_notify 2018-03-08 16:43:32.732831731 +0100
|
||||
@ -53,3 +29,27 @@ diff -up ppc64-diag-2.7.4/lpd/scripts/lp_diag_setup.than ppc64-diag-2.7.4/lpd/sc
|
||||
"--type=REPAIR --method=num_arg"],
|
||||
);
|
||||
|
||||
diff -up ppc64-diag-2.7.7/lpd/Makefile.am.orig ppc64-diag-2.7.7/lpd/Makefile.am
|
||||
--- ppc64-diag-2.7.7/lpd/Makefile.am.orig 2021-05-17 09:41:42.414331949 +0200
|
||||
+++ ppc64-diag-2.7.7/lpd/Makefile.am 2021-05-17 09:42:54.463293519 +0200
|
||||
@@ -46,16 +46,16 @@ all-local-lpd:
|
||||
AM_LOCALS += all-local-lpd
|
||||
|
||||
install-exec-hook-lpd:
|
||||
- install -d --mode=755 $(DESTDIR)/etc/ppc64-diag
|
||||
- install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
|
||||
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag
|
||||
+ install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
(cd $(DESTDIR)/$(sbindir) && $(LN_S) -f usysident usysattn)
|
||||
(cd $(DESTDIR)/$(sbindir) && $(LN_S) -f usysident usysfault)
|
||||
|
||||
INSTALL_EXEC_HOOKS += install-exec-hook-lpd
|
||||
|
||||
uninstall-hook-lpd:
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/lp_diag_setup
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/lp_diag_notify
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/lp_diag_setup
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/lp_diag_notify
|
||||
rm -f $(sbindir)/usysattn
|
||||
rm -f $(sbindir)/usysfault
|
||||
|
||||
|
@ -1,40 +1,3 @@
|
||||
diff -up ppc64-diag-2.7.4/ela/Makefile.am.than ppc64-diag-2.7.4/ela/Makefile.am
|
||||
--- ppc64-diag-2.7.4/ela/Makefile.am.than 2018-03-08 15:41:37.994892051 +0100
|
||||
+++ ppc64-diag-2.7.4/ela/Makefile.am 2018-03-08 15:43:58.847464269 +0100
|
||||
@@ -68,22 +68,22 @@ clean-local-ela:
|
||||
CLEAN_LOCALS += clean-local-ela
|
||||
|
||||
install-exec-hook-ela:
|
||||
- install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/
|
||||
- install -D --mode=744 $(CATALOG) $(DESTDIR)/etc/ppc64-diag/message_catalog/
|
||||
+ install -d --mode=755 $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
|
||||
+ install -D --mode=744 $(CATALOG) $(DESTDIR)/usr/share/ppc64-diag/message_catalog/
|
||||
install -D --mode=744 $(CATALOG_REGEX) \
|
||||
- $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/
|
||||
+ $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
|
||||
|
||||
INSTALL_EXEC_HOOKS += install-exec-hook-ela
|
||||
|
||||
uninstall-hook-ela:
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/cxgb3
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/e1000e
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/exceptions
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/reporters
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/gpfs
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/cxgb3
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/e1000e
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/gpfs
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/cxgb3
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/e1000e
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/exceptions
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/reporters
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/gpfs
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/cxgb3
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/e1000e
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/gpfs
|
||||
|
||||
UNINSTALL_HOOKS += uninstall-hook-ela
|
||||
|
||||
diff -up ppc64-diag-2.7.4/ela/catalogs.h.than ppc64-diag-2.7.4/ela/catalogs.h
|
||||
--- ppc64-diag-2.7.4/ela/catalogs.h.than 2018-03-08 15:44:23.267910229 +0100
|
||||
+++ ppc64-diag-2.7.4/ela/catalogs.h 2018-03-08 15:46:08.669835054 +0100
|
||||
@ -71,3 +34,40 @@ diff -up ppc64-diag-2.7.4/ela/syslog_to_svclog.cpp.than ppc64-diag-2.7.4/ela/sys
|
||||
"-d\t\tPrint debugging output on stderr.\n"
|
||||
"-e end_time\tStop upon reading message with timestamp after end_time.\n"
|
||||
"-F\t\tDon't stop at EOF; process newly logged messages as they occur.\n"
|
||||
diff -up ppc64-diag-2.7.7/ela/Makefile.am.orig ppc64-diag-2.7.7/ela/Makefile.am
|
||||
--- ppc64-diag-2.7.7/ela/Makefile.am.orig 2021-05-17 09:33:12.892415129 +0200
|
||||
+++ ppc64-diag-2.7.7/ela/Makefile.am 2021-05-17 09:39:06.332399898 +0200
|
||||
@@ -62,22 +62,22 @@ clean-local-ela:
|
||||
CLEAN_LOCALS += clean-local-ela
|
||||
|
||||
install-exec-hook-ela:
|
||||
- install -d --mode=655 $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/
|
||||
- install -D --mode=644 $(CATALOG) $(DESTDIR)/etc/ppc64-diag/message_catalog/
|
||||
+ install -d --mode=755 $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
|
||||
+ install -D --mode=644 $(CATALOG) $(DESTDIR)/usr/share/ppc64-diag/message_catalog/
|
||||
install -D --mode=644 $(CATALOG_REGEX) \
|
||||
- $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/
|
||||
+ $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
|
||||
|
||||
INSTALL_EXEC_HOOKS += install-exec-hook-ela
|
||||
|
||||
uninstall-hook-ela:
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/cxgb3
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/e1000e
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/exceptions
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/reporters
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/gpfs
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/cxgb3
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/e1000e
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex/gpfs
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/cxgb3
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/e1000e
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/exceptions
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/reporters
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/gpfs
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/cxgb3
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/e1000e
|
||||
+ rm -f $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/gpfs
|
||||
|
||||
UNINSTALL_HOOKS += uninstall-hook-ela
|
||||
|
||||
|
@ -10,20 +10,6 @@ diff -up ppc64-diag-2.7.4/diags/Makefile.am.than ppc64-diag-2.7.4/diags/Makefile
|
||||
|
||||
INSTALL_EXEC_HOOKS += install-exec-hook-diag
|
||||
|
||||
diff -up ppc64-diag-2.7.4/ela/Makefile.am.than ppc64-diag-2.7.4/ela/Makefile.am
|
||||
--- ppc64-diag-2.7.4/ela/Makefile.am.than 2018-03-09 14:12:39.942018046 +0100
|
||||
+++ ppc64-diag-2.7.4/ela/Makefile.am 2018-03-09 14:13:19.962739978 +0100
|
||||
@@ -69,8 +69,8 @@ CLEAN_LOCALS += clean-local-ela
|
||||
|
||||
install-exec-hook-ela:
|
||||
install -d --mode=755 $(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
|
||||
- install -D --mode=744 $(CATALOG) $(DESTDIR)/usr/share/ppc64-diag/message_catalog/
|
||||
- install -D --mode=744 $(CATALOG_REGEX) \
|
||||
+ install -D --mode=644 $(CATALOG) $(DESTDIR)/usr/share/ppc64-diag/message_catalog/
|
||||
+ install -D --mode=644 $(CATALOG_REGEX) \
|
||||
$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex/
|
||||
|
||||
INSTALL_EXEC_HOOKS += install-exec-hook-ela
|
||||
diff -up ppc64-diag-2.7.4/rtas_errd/Makefile.am.than ppc64-diag-2.7.4/rtas_errd/Makefile.am
|
||||
--- ppc64-diag-2.7.4/rtas_errd/Makefile.am.than 2018-03-09 14:21:08.211186688 +0100
|
||||
+++ ppc64-diag-2.7.4/rtas_errd/Makefile.am 2018-03-09 14:21:16.781341284 +0100
|
||||
@ -36,10 +22,21 @@ diff -up ppc64-diag-2.7.4/rtas_errd/Makefile.am.than ppc64-diag-2.7.4/rtas_errd/
|
||||
|
||||
uninstall-hook-rtas-errd:
|
||||
rm -f $(DESTDIR)/etc/rc.powerfail
|
||||
diff -up ppc64-diag-2.7.4/scripts/Makefile.am.than ppc64-diag-2.7.4/scripts/Makefile.am
|
||||
diff -up ppc64-diag-2.7.4/scripts/Makefile.am.than ppc64-diag-2.7.4/scripts/Makefile.am
|
||||
--- ppc64-diag-2.7.4/scripts/Makefile.am.than 2018-03-09 14:32:56.393971751 +0100
|
||||
+++ ppc64-diag-2.7.4/scripts/Makefile.am 2018-03-09 14:33:18.374368602 +0100
|
||||
diff -up ppc64-diag-2.7.7/lpd/Makefile.am.orig ppc64-diag-2.7.7/lpd/Makefile.am
|
||||
--- ppc64-diag-2.7.7/lpd/Makefile.am.orig 2021-05-17 09:50:40.176840226 +0200
|
||||
+++ ppc64-diag-2.7.7/lpd/Makefile.am 2021-05-17 09:51:00.464126336 +0200
|
||||
@@ -47,7 +47,7 @@ AM_LOCALS += all-local-lpd
|
||||
|
||||
install-exec-hook-lpd:
|
||||
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag
|
||||
- install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
+ install -D --mode=755 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
(cd $(DESTDIR)/$(sbindir) && $(LN_S) -f usysident usysattn)
|
||||
(cd $(DESTDIR)/$(sbindir) && $(LN_S) -f usysident usysfault)
|
||||
|
||||
diff -up ppc64-diag-2.7.7/scripts/Makefile.am.m ppc64-diag-2.7.7/scripts/Makefile.am
|
||||
--- ppc64-diag-2.7.7/scripts/Makefile.am.m 2021-05-17 10:38:25.896078135 +0200
|
||||
+++ ppc64-diag-2.7.7/scripts/Makefile.am 2021-05-17 10:40:41.884984190 +0200
|
||||
@@ -13,7 +13,7 @@ SERVICE_SCRIPT = scripts/rtas_errd.servi
|
||||
install-exec-hook-scripts:
|
||||
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
@ -49,15 +46,3 @@ diff -up ppc64-diag-2.7.4/scripts/Makefile.am.than ppc64-diag-2.7.4/scripts/Make
|
||||
install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
|
||||
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
diff -up ppc64-diag-2.7.4/lpd/Makefile.am.than ppc64-diag-2.7.4/lpd/Makefile.am
|
||||
--- ppc64-diag-2.7.4/lpd/Makefile.am.than 2018-03-09 14:35:40.576936043 +0100
|
||||
+++ ppc64-diag-2.7.4/lpd/Makefile.am 2018-03-09 14:36:05.927393740 +0100
|
||||
@@ -47,7 +47,7 @@ AM_LOCALS += all-local-lpd
|
||||
|
||||
install-exec-hook-lpd:
|
||||
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag
|
||||
- install -D --mode=744 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
+ install -D --mode=755 $(LPD_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysattn
|
||||
$(LN_S) $(sbindir)/usysident $(DESTDIR)/$(sbindir)/usysfault
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: ppc64-diag
|
||||
Version: 2.7.6
|
||||
Release: 10%{?dist}
|
||||
Version: 2.7.7
|
||||
Release: 1%{?dist}
|
||||
Summary: PowerLinux Platform Diagnostics
|
||||
URL: https://github.com/power-ras/%{name}
|
||||
License: GPLv2
|
||||
@ -77,7 +77,7 @@ install -m 644 %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} $RPM_BUILD
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%doc README
|
||||
%doc README.md
|
||||
%dir %{_sysconfdir}/%{name}
|
||||
%dir %{_sysconfdir}/%{name}/ses_pages
|
||||
%dir %{_localstatedir}/log/%{name}/diag_disk
|
||||
@ -170,6 +170,9 @@ if [ "$1" = "0" ]; then # last uninstall
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Mon May 17 2021 Than Ngo <than@redhat.com> - 2.7.7-1
|
||||
- Resolves: #1869567, rebase to 2.7.7
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.7.6-10
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ppc64-diag-2.7.6.tar.gz) = 2de1a3c15ae67a8ab7c4d05efc93ad603197a64463fe70b039ebcbad59f4eb2f2110bc42440cc60ca8ff181034f0a577aa9b2ce00a3672e376810a296a189acf
|
||||
SHA512 (ppc64-diag-2.7.7.tar.gz) = 42d94214345ab8deb7bd9ee8b145052fc2f733ba13d1567dbe6592fe9306670e3cd0ab6122e515464f7050753a992061c056e009673c7f8f6e554e9eaf75c550
|
||||
|
Loading…
Reference in New Issue
Block a user