import ppc64-diag-2.7.9-1.el9
This commit is contained in:
parent
be736879b2
commit
8eed06fbb6
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/ppc64-diag-2.7.8.tar.gz
|
||||
SOURCES/ppc64-diag-2.7.9.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
11da2a442ca94f4e06b68de0c4dcbc3432585611 SOURCES/ppc64-diag-2.7.8.tar.gz
|
||||
f98832e286b997679c6d3818c00b33410851140d SOURCES/ppc64-diag-2.7.9.tar.gz
|
||||
|
@ -106,41 +106,6 @@ Subject: [PATCH 2/4] fix script location
|
||||
scripts/rtas_errd | 2 +-
|
||||
7 files changed, 20 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
|
||||
index 29dcb78..dc88ab9 100644
|
||||
--- a/scripts/Makefile.am
|
||||
+++ b/scripts/Makefile.am
|
||||
@@ -11,20 +11,21 @@ INIT_FILES = scripts/rtas_errd scripts/opal_errd
|
||||
SERVICE_SCRIPT = scripts/rtas_errd.service scripts/opal_errd.service
|
||||
|
||||
install-exec-hook-scripts:
|
||||
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/
|
||||
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
|
||||
- install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag
|
||||
+ install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
+ install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
|
||||
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
install -d --mode=755 $(DESTDIR)/usr/lib/systemd/system/
|
||||
install -D --mode=644 $(SERVICE_SCRIPT) $(DESTDIR)/usr/lib/systemd/system/
|
||||
|
||||
uninstall-hook-scripts:
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_setup
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_mkrsrc
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_notify
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_migrate
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/servevent_parse.pl
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_setup
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_notify
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_migrate
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/servevent_parse.pl
|
||||
rm -f $(DESTDIR)/etc/ppc64-diag/ppc64-diag.config
|
||||
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/rtas_errd
|
||||
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/opal_errd
|
||||
diff --git a/scripts/ppc64_diag_migrate b/scripts/ppc64_diag_migrate
|
||||
index 50b5dd2..5c608eb 100755
|
||||
--- a/scripts/ppc64_diag_migrate
|
||||
+++ b/scripts/ppc64_diag_migrate
|
||||
@@ -1,4 +1,4 @@
|
||||
@ -379,19 +344,35 @@ index f475840..ed70978 100644
|
||||
|
||||
uninstall-hook-rtas-errd:
|
||||
rm -f $(DESTDIR)/etc/rc.powerfail
|
||||
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
|
||||
index dc88ab9..637168f 100644
|
||||
--- a/scripts/Makefile.am
|
||||
+++ b/scripts/Makefile.am
|
||||
@@ -13,7 +13,7 @@ SERVICE_SCRIPT = scripts/rtas_errd.service scripts/opal_errd.service
|
||||
diff -up ppc64-diag-2.7.9/scripts/Makefile.am.me ppc64-diag-2.7.9/scripts/Makefile.am
|
||||
--- ppc64-diag-2.7.9/scripts/Makefile.am.me 2022-10-18 16:32:52.476721485 +0200
|
||||
+++ ppc64-diag-2.7.9/scripts/Makefile.am 2022-10-18 16:36:34.798721016 +0200
|
||||
@@ -12,20 +12,21 @@ INIT_FILES = scripts/rtas_errd scripts/o
|
||||
SERVICE_SCRIPT = scripts/rtas_errd.service scripts/opal_errd.service
|
||||
|
||||
install-exec-hook-scripts:
|
||||
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/
|
||||
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
|
||||
- install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag
|
||||
+ install -D --mode=755 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
|
||||
+ install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
|
||||
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
|
||||
--
|
||||
2.34.1
|
||||
|
||||
install -d --mode=755 $(DESTDIR)/usr/lib/systemd/system/
|
||||
install -D --mode=644 $(SERVICE_SCRIPT) $(DESTDIR)/usr/lib/systemd/system/
|
||||
|
||||
uninstall-hook-scripts:
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_setup
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_mkrsrc
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_notify
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_migrate
|
||||
- rm -f $(DESTDIR)/etc/ppc64-diag/servevent_parse.pl
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_setup
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_notify
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_migrate
|
||||
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/servevent_parse.pl
|
||||
rm -f $(DESTDIR)/etc/ppc64-diag/ppc64-diag.config
|
||||
rm -f $(DESTDIR)/etc/ppc64-diag/diag_nvme.config
|
||||
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/rtas_errd
|
@ -1,5 +1,5 @@
|
||||
Name: ppc64-diag
|
||||
Version: 2.7.8
|
||||
Version: 2.7.9
|
||||
Release: 1%{?dist}
|
||||
Summary: PowerLinux Platform Diagnostics
|
||||
URL: https://github.com/power-ras/%{name}
|
||||
@ -32,7 +32,7 @@ Source4: extract_platdump.8
|
||||
Source5: rtas_errd.8
|
||||
|
||||
# fix paths and permissions
|
||||
Patch0: ppc64-diag-fedora.patch
|
||||
Patch0: ppc64-diag-2.7.9-fedora.patch
|
||||
|
||||
%description
|
||||
This package contains various diagnostic tools for PowerLinux.
|
||||
@ -94,6 +94,7 @@ install -m 644 %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} $RPM_BUILD
|
||||
%{_datadir}/%{name}/message_catalog/*
|
||||
%{_unitdir}/opal_errd.service
|
||||
%{_sysconfdir}/cron.daily/run_diag_encl
|
||||
%{_sysconfdir}/cron.daily/run_diag_nvme
|
||||
|
||||
# get rid of obsolete initscripts for rhel >=7
|
||||
%exclude %{_libexecdir}/%{name}/rtas_errd
|
||||
@ -114,6 +115,7 @@ install -m 644 %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} $RPM_BUILD
|
||||
%{_mandir}/man8/extract_platdump*
|
||||
%{_mandir}/man8/rtas_errd*
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/ppc64-diag.config
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/diag_nvme.config
|
||||
%{_sbindir}/convert_dt_node_props
|
||||
%{_sbindir}/extract_platdump
|
||||
%{_sbindir}/rtas_errd
|
||||
@ -167,6 +169,9 @@ if [ "$1" = "0" ]; then # last uninstall
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Oct 18 2022 Than Ngo <than@redhat.com> - 2.7.9-1
|
||||
- Resolves: #2110128, add NVMe Call Home support
|
||||
|
||||
* Fri May 06 2022 Than Ngo <than@redhat.com> - 2.7.8-1
|
||||
- Resolves: #2051286, rebase to 2.7.8
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user