- update to 2.7.9

- added BR on libvpd >= 2.2.9
This commit is contained in:
Than Ngo 2022-10-18 16:39:32 +02:00
parent d2c49fa407
commit 7470006b3f
6 changed files with 37 additions and 95 deletions

1
.gitignore vendored
View File

@ -14,3 +14,4 @@
/ppc64-diag-2.7.5.tar.gz
/ppc64-diag-2.7.6.tar.gz
/ppc64-diag-2.7.8.tar.gz
/ppc64-diag-2.7.9.tar.gz

View File

@ -1,12 +0,0 @@
diff -up ppc64-diag-2.7.8/opal-dump-parse/opal-dump-parse.c.me ppc64-diag-2.7.8/opal-dump-parse/opal-dump-parse.c
--- ppc64-diag-2.7.8/opal-dump-parse/opal-dump-parse.c.me 2022-05-14 06:21:01.745290071 -0400
+++ ppc64-diag-2.7.8/opal-dump-parse/opal-dump-parse.c 2022-05-14 07:30:08.240914514 -0400
@@ -462,7 +462,7 @@ int main(int argc, char *argv[])
{
int opt = 0;
- while ((opt = getopt(argc, argv, "lh:s:o:")) != -1) {
+ while ((opt = getopt(argc, argv, "hl:s:o:")) != -1) {
switch (opt) {
case 'l':
opt_mdst = 1;

View File

@ -106,41 +106,6 @@ Subject: [PATCH 2/4] fix script location
scripts/rtas_errd | 2 +-
7 files changed, 20 insertions(+), 19 deletions(-)
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 29dcb78..dc88ab9 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -11,20 +11,21 @@ INIT_FILES = scripts/rtas_errd scripts/opal_errd
SERVICE_SCRIPT = scripts/rtas_errd.service scripts/opal_errd.service
install-exec-hook-scripts:
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
- install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag
+ install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
+ install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
install -d --mode=755 $(DESTDIR)/usr/lib/systemd/system/
install -D --mode=644 $(SERVICE_SCRIPT) $(DESTDIR)/usr/lib/systemd/system/
uninstall-hook-scripts:
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_setup
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_mkrsrc
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_notify
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_migrate
- rm -f $(DESTDIR)/etc/ppc64-diag/servevent_parse.pl
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_setup
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_notify
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_migrate
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/servevent_parse.pl
rm -f $(DESTDIR)/etc/ppc64-diag/ppc64-diag.config
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/rtas_errd
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/opal_errd
diff --git a/scripts/ppc64_diag_migrate b/scripts/ppc64_diag_migrate
index 50b5dd2..5c608eb 100755
--- a/scripts/ppc64_diag_migrate
+++ b/scripts/ppc64_diag_migrate
@@ -1,4 +1,4 @@
@ -379,19 +344,35 @@ index f475840..ed70978 100644
uninstall-hook-rtas-errd:
rm -f $(DESTDIR)/etc/rc.powerfail
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index dc88ab9..637168f 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -13,7 +13,7 @@ SERVICE_SCRIPT = scripts/rtas_errd.service scripts/opal_errd.service
diff -up ppc64-diag-2.7.9/scripts/Makefile.am.me ppc64-diag-2.7.9/scripts/Makefile.am
--- ppc64-diag-2.7.9/scripts/Makefile.am.me 2022-10-18 16:32:52.476721485 +0200
+++ ppc64-diag-2.7.9/scripts/Makefile.am 2022-10-18 16:36:34.798721016 +0200
@@ -12,20 +12,21 @@ INIT_FILES = scripts/rtas_errd scripts/o
SERVICE_SCRIPT = scripts/rtas_errd.service scripts/opal_errd.service
install-exec-hook-scripts:
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -d --mode=755 $(DESTDIR)/etc/ppc64-diag/
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
- install -D --mode=744 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/etc/ppc64-diag/
- install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag
+ install -D --mode=755 $(PPC64_DIAG_SCRIPT) $(DESTDIR)/usr/libexec/ppc64-diag/
install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
+ install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag/
install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
--
2.34.1
install -d --mode=755 $(DESTDIR)/usr/lib/systemd/system/
install -D --mode=644 $(SERVICE_SCRIPT) $(DESTDIR)/usr/lib/systemd/system/
uninstall-hook-scripts:
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_setup
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_mkrsrc
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_notify
- rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_migrate
- rm -f $(DESTDIR)/etc/ppc64-diag/servevent_parse.pl
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_setup
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_mkrsrc
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_notify
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/ppc64_diag_migrate
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/servevent_parse.pl
rm -f $(DESTDIR)/etc/ppc64-diag/ppc64-diag.config
rm -f $(DESTDIR)/etc/ppc64-diag/diag_nvme.config
rm -f $(DESTDIR)/usr/libexec/ppc64-diag/rtas_errd

View File

@ -1,30 +0,0 @@
diff --git a/lpd/lp_diag.c b/lpd/lp_diag.c
index 8dd92e6..988a021 100644
--- a/lpd/lp_diag.c
+++ b/lpd/lp_diag.c
@@ -653,11 +653,11 @@ UI_help(MENU *my_menu)
}
if (!strcmp(desc, "ident"))
- mvwprintw(my_text_win, 0, 0, help1);
+ mvwprintw(my_text_win, 0, 0, "%s", help1);
else if (!strcmp(desc, "attn"))
- mvwprintw(my_text_win, 0, 0, help2);
+ mvwprintw(my_text_win, 0, 0, "%s", help2);
else
- mvwprintw(my_text_win, 0, 0, help3);
+ mvwprintw(my_text_win, 0, 0, "%s", help3);
wrefresh(my_text_win);
@@ -1127,8 +1127,8 @@ startup_window(void)
}
mvprintw(0, 0, "SERVICE INDICATORS VERSION %s", VERSION);
- mvprintw(2, 0, msg1);
- mvprintw(5, 0, msg2);
+ mvprintw(2, 0, "%s", msg1);
+ mvprintw(5, 0, "%s", msg2);
mvprintw(9, 0, "Press the F3 key to exit or press Enter to continue.");
while ((c = getch()) != KEY_F(3)) {

View File

@ -1,17 +1,17 @@
Name: ppc64-diag
Version: 2.7.8
Release: 4%{?dist}
Version: 2.7.9
Release: 1%{?dist}
Summary: PowerLinux Platform Diagnostics
URL: https://github.com/power-ras/%{name}
License: GPLv2
ExclusiveArch: ppc %{power64}
#ExclusiveArch: ppc %{power64}
BuildRequires: make
BuildRequires: gcc-c++
BuildRequires: libservicelog-devel
BuildRequires: flex
BuildRequires: perl-interpreter
BuildRequires: byacc
BuildRequires: libvpd-devel
BuildRequires: libvpd-devel >= 2.2.9
BuildRequires: ncurses-devel
BuildRequires: librtas-devel >= 1.4.0
BuildRequires: systemd-units
@ -33,8 +33,6 @@ Source5: rtas_errd.8
# fix paths and permissions
Patch0: ppc64-diag-fedora.patch
Patch1: ppc64-diag-2.7.8-opal-dump-parse-getopt.patch
Patch2: ppc64-diag-gcc12.patch
%description
This package contains various diagnostic tools for PowerLinux.
@ -169,6 +167,10 @@ if [ "$1" = "0" ]; then # last uninstall
fi
%changelog
* Tue Oct 18 2022 Than Ngo <than@redhat.com> - 2.7.9-1
- update to 2.7.9
- added BR on libvpd >= 2.2.9
* Thu Jul 28 2022 Than Ngo <than@redhat.com> - 2.7.8-4
- Fixed FTBFS, error: format not a string literal

View File

@ -1 +1 @@
SHA512 (ppc64-diag-2.7.8.tar.gz) = 1a8890624609f64eb412cabb690f30a67b7f714260de14acc195268ecbda79d6c5e7d80694dabb3ab148fc74a4df6b8e147750e869ab49f40d04742ef284398e
SHA512 (ppc64-diag-2.7.9.tar.gz) = b6756c17e67e876ad3a945d05dbd2c2523cbf121c4aa658a4edaf33775c8165ff26a252bdf812600e2d47ae69cd68f6e22c0de6f2d3994856adcd3d949322673