Update to latest upstream 2.6.7

Also cleaned up additional patches.

Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
This commit is contained in:
Vasant Hegde 2014-09-25 17:16:06 +05:30
parent 926e920017
commit 4bf4133332
12 changed files with 164 additions and 139 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/ppc64-diag-2.6.4.tar.gz
/ppc64-diag-2.6.5.tar.gz
/ppc64-diag-2.6.6.tar.gz
/ppc64-diag-2.6.7.tar.gz

View File

@ -1,14 +0,0 @@
[Unit]
Description=opal_errd (PowerNV platform error handling) Service
After=syslog.target
[Service]
Type=forking
ExecStart=/usr/libexec/ppc64-diag/opal_errd start
ExecStop=/usr/libexec/ppc64-diag/opal_errd stop
StandardOutput=syslog
StandardError=syslog
[Install]
WantedBy=multi-user.target

View File

@ -1,7 +1,21 @@
diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
--- ppc64-diag-2.4.2/ela/Makefile.msg_loc 2011-06-29 10:50:51.000000000 -0400
+++ ppc64-diag-2.4.2/ela/Makefile 2011-09-09 14:51:01.000000000 -0400
@@ -72,17 +72,17 @@ catalogs.o: catalogs.h
From 47c29d1884912af81e392cbae3b17f6cfb720c1f Mon Sep 17 00:00:00 2001
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
Date: Thu, 25 Sep 2014 16:28:35 +0530
Subject: [PATCH 1/5] Update message location
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
---
ela/Makefile | 8 ++++----
ela/catalogs.h | 2 +-
ela/explain_syslog.cpp | 2 +-
ela/syslog_to_svclog.cpp | 2 +-
4 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/ela/Makefile b/ela/Makefile
index 2205cd2..ad52c5e 100644
--- a/ela/Makefile
+++ b/ela/Makefile
@@ -67,8 +67,8 @@ catalogs.o: catalogs.h
install: all
@$(call install_sbin,$(CMDS),$(DESTDIR))
@ -9,12 +23,10 @@ diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
- @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex)
+ @$(call install_files,$(CATALOG),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog)
+ @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex)
@$(call install_man,$(MANPAGES),$(DESTDIR))
- $(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
+ $(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
$(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
@$(foreach d,$(SUBDIRS), $(MAKE) -C $d install;)
clean:
@rm -rf $(CMDS) *.o lex.*.c *.tab.c *.tab.h
@@ -78,6 +78,6 @@ clean:
uninstall:
@$(call uninstall_sbin,$(CMDS),$(DESTDIR))
@ -22,11 +34,11 @@ diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
- @$(call uninstall_files,$(CATALOG_REGEX),$(DESTDIR)/etc/ppc64-diag/)
+ @$(call uninstall_files,$(CATALOG),$(DESTDIR)/usr/share/ppc64-diag/)
+ @$(call uninstall_files,$(CATALOG_REGEX),$(DESTDIR)/usr/share/ppc64-diag/)
@$(call uninstall_man,$(MANPAGES),$(DESTDIR)/usr/share/man/man8)
diff -up ppc64-diag-2.4.2/ela/catalogs.h.msg_loc ppc64-diag-2.4.2/ela/catalogs.h
--- ppc64-diag-2.4.2/ela/catalogs.h.msg_loc 2011-02-23 17:55:31.000000000 -0500
+++ ppc64-diag-2.4.2/ela/catalogs.h 2011-09-09 14:50:12.000000000 -0400
@$(foreach d,$(SUBDIRS), $(MAKE) -C $d uninstall;)
diff --git a/ela/catalogs.h b/ela/catalogs.h
index 71ad14c..a8f82c2 100644
--- a/ela/catalogs.h
+++ b/ela/catalogs.h
@@ -21,7 +21,7 @@ using namespace std;
#include <stdio.h>
#include <regex.h>
@ -36,10 +48,11 @@ diff -up ppc64-diag-2.4.2/ela/catalogs.h.msg_loc ppc64-diag-2.4.2/ela/catalogs.h
class Parser {
protected:
diff -up ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc ppc64-diag-2.4.2/ela/explain_syslog.cpp
--- ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc 2011-02-22 14:27:02.000000000 -0500
+++ ppc64-diag-2.4.2/ela/explain_syslog.cpp 2011-09-09 14:50:12.000000000 -0400
@@ -94,7 +94,7 @@ print_help(void)
diff --git a/ela/explain_syslog.cpp b/ela/explain_syslog.cpp
index 87bda1c..85eae68 100644
--- a/ela/explain_syslog.cpp
+++ b/ela/explain_syslog.cpp
@@ -97,7 +97,7 @@ print_help(void)
printf(
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
"-C catalog_dir\tUse message catalog in catalog_dir. Defaults to\n"
@ -48,10 +61,11 @@ diff -up ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc ppc64-diag-2.4.2/ela/ex
"-d\t\tPrint debugging output on stderr.\n"
"-e end_time\tStop upon reading message with timestamp after end_time.\n"
"-h\t\tPrint this help text and exit.\n"
diff -up ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp
--- ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc 2011-07-11 05:43:41.000000000 -0400
+++ ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp 2011-09-09 14:50:12.000000000 -0400
@@ -654,7 +654,7 @@ print_help(void)
diff --git a/ela/syslog_to_svclog.cpp b/ela/syslog_to_svclog.cpp
index c62e92a..de5c2c8 100644
--- a/ela/syslog_to_svclog.cpp
+++ b/ela/syslog_to_svclog.cpp
@@ -657,7 +657,7 @@ print_help(void)
printf(
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
"-C catalog_dir\tUse message catalog in catalog_dir. Defaults to\n"
@ -60,3 +74,6 @@ diff -up ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc ppc64-diag-2.4.2/ela/
"-d\t\tPrint debugging output on stderr.\n"
"-e end_time\tStop upon reading message with timestamp after end_time.\n"
"-F\t\tDon't stop at EOF; process newly logged messages as they occur.\n"
--
1.8.3.1

View File

@ -1,9 +1,7 @@
From ee73019f875b15e011f5af2c41386f780b5a65cb Mon Sep 17 00:00:00 2001
From f4700ecb071a3510803e6c68a012d17ea011ada4 Mon Sep 17 00:00:00 2001
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
Date: Sun, 15 Sep 2013 17:13:57 +0530
Subject: [PATCH] Fix PRRN hotplug script location
Install PRRN Hotplug scripts into proper directory.
Date: Thu, 25 Sep 2014 16:33:07 +0530
Subject: [PATCH 5/5] Update PRRN location
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
---
@ -12,7 +10,7 @@ Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/rtas_errd/Makefile b/rtas_errd/Makefile
index d5427d5..a255979 100644
index 021fa65..ab1223c 100644
--- a/rtas_errd/Makefile
+++ b/rtas_errd/Makefile
@@ -38,12 +38,12 @@ extract_platdump: $(EXTRACT_PLATDUMP_OBJS)
@ -31,10 +29,10 @@ index d5427d5..a255979 100644
doc: $(DOXYGEN_CFG)
@echo "Creating doxygen docs..."
diff --git a/rtas_errd/prrn.c b/rtas_errd/prrn.c
index 8bfe7ac..71cebb9 100644
index 7a791cb..222e6e5 100644
--- a/rtas_errd/prrn.c
+++ b/rtas_errd/prrn.c
@@ -39,7 +39,7 @@ static int prrn_log_fd = -1;
@@ -40,7 +40,7 @@ static int prrn_log_fd = -1;
#define OFDT_BASE "/proc/device-tree"
#define OFDTPATH "/proc/ppc64/ofdt"
@ -44,5 +42,5 @@ index 8bfe7ac..71cebb9 100644
static int write_prrn_log(const char *buf, int len)
--
1.7.11.7
1.8.3.1

View File

@ -1,24 +1,42 @@
diff -up ppc64-diag-2.4.3/scripts/Makefile.script_loc ppc64-diag-2.4.3/scripts/Makefile
--- ppc64-diag-2.4.3/scripts/Makefile.script_loc 2012-02-14 06:53:59.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/Makefile 2012-05-04 15:32:55.186608517 +0200
@@ -12,12 +12,12 @@ CFG_FILES = ppc64-diag.config
From 6a9764f7d872c415d0e378254c9d0eae126514a6 Mon Sep 17 00:00:00 2001
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
Date: Thu, 25 Sep 2014 17:01:20 +0530
Subject: [PATCH] Update script location
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
---
scripts/Makefile | 4 ++--
scripts/ppc64_diag_mkrsrc | 4 ++--
scripts/ppc64_diag_notify | 4 ++--
scripts/ppc64_diag_servagent | 4 ++--
scripts/ppc64_diag_setup | 6 +++---
scripts/rtas_errd | 2 +-
6 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/scripts/Makefile b/scripts/Makefile
index 1ab0d2c..9a3acf5 100644
--- a/scripts/Makefile
+++ b/scripts/Makefile
@@ -13,13 +13,13 @@ CFG_FILES = ppc64-diag.config
all: $(SCRIPTS) $(INIT_FILES) $(CFG_FILES)
install: all
- @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/etc/ppc64-diag)
+ @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/usr/libexec/ppc64-diag)
@$(call install_files,$(INIT_FILES),755,$(DESTDIR)/etc/init.d)
@$(call install_files,$(INIT_FILES),755,$(DESTDIR)/$(LIBEXEC_DIR))
@$(call install_files,$(SERVICE_SCRIPT),755,$(DESTDIR)/$(SYSTEMD_DIR))
@$(call install_files,$(CFG_FILES),644,$(DESTDIR)/etc/ppc64-diag)
uninstall:
- @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/etc/ppc64-diag)
+ @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/usr/libexec/ppc64-diag)
@$(call uninstall_files,$(INIT_FILES),$(DESTDIR)/etc/init.d)
@$(call uninstall_files,$(INIT_FILES),$(DESTDIR)/$(LIBEXEC_DIR))
@$(call uninstall_files,$(SERVICE_SCRIPT),755,$(DESTDIR)/$(SYSTEMD_DIR))
@$(call uninstall_files,$(CFG_FILES),$(DESTDIR)/etc/ppc64-diag)
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc
--- ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc.script_loc 2012-01-20 00:53:34.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc 2012-05-04 15:32:55.186608517 +0200
diff --git a/scripts/ppc64_diag_mkrsrc b/scripts/ppc64_diag_mkrsrc
index 93dac2f..6db33d8 100755
--- a/scripts/ppc64_diag_mkrsrc
+++ b/scripts/ppc64_diag_mkrsrc
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
@ -33,10 +51,11 @@ diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc.script_loc ppc64-diag-2.4.3/
+require "/usr/libexec/ppc64-diag/servevent_parse.pl";
# Check to make sure that devices.chrp.base.ServiceRM is installed
$check = `/bin/rpm -q devices.chrp.base.ServiceRM 2>/dev/null`;
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_notify.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_notify
--- ppc64-diag-2.4.3/scripts/ppc64_diag_notify.script_loc 2011-11-08 00:51:25.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_notify 2012-05-04 15:32:55.186608517 +0200
$rc = system("which rpm >/dev/null 2>&1");
diff --git a/scripts/ppc64_diag_notify b/scripts/ppc64_diag_notify
index 0374864..9730d06 100755
--- a/scripts/ppc64_diag_notify
+++ b/scripts/ppc64_diag_notify
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
@ -52,9 +71,10 @@ diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_notify.script_loc ppc64-diag-2.4.3/
sub usage {
print "$0 [OPTIONS]\n";
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_servagent.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_servagent
--- ppc64-diag-2.4.3/scripts/ppc64_diag_servagent.script_loc 2011-11-08 00:51:25.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_servagent 2012-05-04 15:32:55.186608517 +0200
diff --git a/scripts/ppc64_diag_servagent b/scripts/ppc64_diag_servagent
index 917f0c3..b1a4a31 100755
--- a/scripts/ppc64_diag_servagent
+++ b/scripts/ppc64_diag_servagent
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -I /etc/ppc64-diag
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
@ -70,9 +90,10 @@ diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_servagent.script_loc ppc64-diag-2.4
if (!-e "/usr/svcagent/bin/callsa2") {
# eSA is not installed; exit quietly
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_setup.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_setup
--- ppc64-diag-2.4.3/scripts/ppc64_diag_setup.script_loc 2012-02-14 06:53:59.000000000 +0100
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_setup 2012-05-04 15:34:23.960384271 +0200
diff --git a/scripts/ppc64_diag_setup b/scripts/ppc64_diag_setup
index b9b691b..091ef55 100755
--- a/scripts/ppc64_diag_setup
+++ b/scripts/ppc64_diag_setup
@@ -76,15 +76,15 @@ sub unregister {
@notification_tools = (
@ -92,10 +113,11 @@ diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_setup.script_loc ppc64-diag-2.4.3/s
"--match=\'refcode=\"#MIGRATE\" and serviceable=0\' ".
"--type=EVENT --method=pairs_stdin"],
);
diff -up ppc64-diag-2.4.3/scripts/rtas_errd.script_loc ppc64-diag-2.4.3/scripts/rtas_errd
--- ppc64-diag-2.4.3/scripts/rtas_errd.script_loc 2012-05-04 15:32:55.173608987 +0200
+++ ppc64-diag-2.4.3/scripts/rtas_errd 2012-05-04 15:32:55.187608480 +0200
@@ -49,7 +49,7 @@ case "$1" in
diff --git a/scripts/rtas_errd b/scripts/rtas_errd
index c8f9deb..c4cf03a 100755
--- a/scripts/rtas_errd
+++ b/scripts/rtas_errd
@@ -56,7 +56,7 @@ case "$1" in
echo "registering ppc64-diag with system"
rm -f /var/cache/ppc64-diag.registered
mkdir -v /var/cache/ppc64-diag.registered
@ -103,4 +125,7 @@ diff -up ppc64-diag-2.4.3/scripts/rtas_errd.script_loc ppc64-diag-2.4.3/scripts/
+ /usr/libexec/ppc64-diag/ppc64_diag_setup --register
fi
echo -n "Starting rtas_errd (platform error handling) daemon: "
if [[ $INSSERV -eq 1 ]]; then
if [ $INSSERV -eq 1 ]; then
--
1.8.3.1

View File

@ -1,11 +0,0 @@
diff -up ppc64-diag-2.4.2/ela/add_regex.cpp.unistd ppc64-diag-2.4.2/ela/add_regex.cpp
--- ppc64-diag-2.4.2/ela/add_regex.cpp.unistd 2012-02-15 18:30:39.940068887 +0100
+++ ppc64-diag-2.4.2/ela/add_regex.cpp 2012-02-15 18:29:58.710066673 +0100
@@ -1,6 +1,7 @@
using namespace std;
#include <stdlib.h>
+#include <unistd.h>
#include <iostream>
#include "catalogs.h"

View File

@ -1,7 +1,22 @@
diff -urN ppc64-diag-2.4.2/diags/7031_D24_T24.c ppc64-diag-2.4.2_/diags/7031_D24_T24.c
--- ppc64-diag-2.4.2/diags/7031_D24_T24.c 2009-05-21 23:33:06.000000000 +0200
+++ ppc64-diag-2.4.2_/diags/7031_D24_T24.c 2012-02-15 18:36:47.170113915 +0100
@@ -64,7 +64,8 @@
From 27342ee4840dcae3e9180966778b7d4c486fede5 Mon Sep 17 00:00:00 2001
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
Date: Thu, 25 Sep 2014 16:31:56 +0530
Subject: [PATCH 4/5] Add unused attribute
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
---
diags/7031_D24_T24.c | 9 ++++++---
rtas_errd/ela.c | 2 +-
rtas_errd/epow.c | 6 +++---
rtas_errd/files.c | 2 +-
rtas_errd/guard.c | 2 +-
5 files changed, 12 insertions(+), 9 deletions(-)
diff --git a/diags/7031_D24_T24.c b/diags/7031_D24_T24.c
index 924aa66..a466467 100644
--- a/diags/7031_D24_T24.c
+++ b/diags/7031_D24_T24.c
@@ -69,7 +69,8 @@ get_enclosure_scsi_id(struct pearl_diag_page2 *dp)
static int
print_drive_status(uint32_t status)
{
@ -11,7 +26,7 @@ diff -urN ppc64-diag-2.4.2/diags/7031_D24_T24.c ppc64-diag-2.4.2_/diags/7031_D24
if ((status & 0x0F000000) == 0x05000000) {
printf("(empty) ");
@@ -162,7 +163,8 @@
@@ -167,7 +168,8 @@ print_ps_fan_status(uint32_t status)
static int
print_repeater_status(uint32_t status)
{
@ -21,7 +36,7 @@ diff -urN ppc64-diag-2.4.2/diags/7031_D24_T24.c ppc64-diag-2.4.2_/diags/7031_D24
if ((status & 0x0F000000) == 0x01000000)
printf("ok ");
@@ -348,7 +350,8 @@
@@ -351,7 +353,8 @@ int
diag_7031_D24_T24(int fd, struct dev_vpd *vpd)
{
struct pearl_diag_page2 dp;
@ -31,10 +46,11 @@ diff -urN ppc64-diag-2.4.2/diags/7031_D24_T24.c ppc64-diag-2.4.2_/diags/7031_D24
int buf_len = sizeof(dp);
int ps1, ps2, fan1, fan2, fan3, rpt, vpd_card;
diff -urN ppc64-diag-2.4.2/rtas_errd/ela.c ppc64-diag-2.4.2_/rtas_errd/ela.c
--- ppc64-diag-2.4.2/rtas_errd/ela.c 2009-05-21 23:33:07.000000000 +0200
+++ ppc64-diag-2.4.2_/rtas_errd/ela.c 2012-02-15 18:44:36.870078704 +0100
@@ -1787,7 +1787,7 @@
diff --git a/rtas_errd/ela.c b/rtas_errd/ela.c
index afb9517..72e4b06 100644
--- a/rtas_errd/ela.c
+++ b/rtas_errd/ela.c
@@ -1787,7 +1787,7 @@ process_v1_epow(struct event *event, int error_type)
int class;
int ext_epow;
int ext_epow_nofan;
@ -43,10 +59,11 @@ diff -urN ppc64-diag-2.4.2/rtas_errd/ela.c ppc64-diag-2.4.2_/rtas_errd/ela.c
/*
* The following EPOW error logs found in CHRP, Ver. 1
diff -urN ppc64-diag-2.4.2/rtas_errd/epow.c ppc64-diag-2.4.2_/rtas_errd/epow.c
--- ppc64-diag-2.4.2/rtas_errd/epow.c 2010-02-27 02:14:00.000000000 +0100
+++ ppc64-diag-2.4.2_/rtas_errd/epow.c 2012-02-15 18:48:42.460078703 +0100
@@ -48,7 +48,7 @@
diff --git a/rtas_errd/epow.c b/rtas_errd/epow.c
index e6b309c..add1d57 100644
--- a/rtas_errd/epow.c
+++ b/rtas_errd/epow.c
@@ -48,7 +48,7 @@ static int time_remaining = 0;
void
epow_timer_handler(int sig, siginfo_t siginfo, void *context)
{
@ -55,7 +72,7 @@ diff -urN ppc64-diag-2.4.2/rtas_errd/epow.c ppc64-diag-2.4.2_/rtas_errd/epow.c
struct itimerval tv;
if (time_remaining <= 0) {
@@ -149,7 +149,7 @@
@@ -149,7 +149,7 @@ parse_epow(struct event *event)
struct rtas_epow_scn *epow;
struct itimerval tv;
char *event_type;
@ -64,7 +81,7 @@ diff -urN ppc64-diag-2.4.2/rtas_errd/epow.c ppc64-diag-2.4.2_/rtas_errd/epow.c
/*
* Check the sensor state; this will be used to ensure
@@ -371,7 +371,7 @@
@@ -380,7 +380,7 @@ check_epow(struct event *event)
{
pid_t child;
char *childargs[2];
@ -73,10 +90,11 @@ diff -urN ppc64-diag-2.4.2/rtas_errd/epow.c ppc64-diag-2.4.2_/rtas_errd/epow.c
/*
* Dissect the EPOW extended error information;
diff -urN ppc64-diag-2.4.2/rtas_errd/files.c ppc64-diag-2.4.2_/rtas_errd/files.c
--- ppc64-diag-2.4.2/rtas_errd/files.c 2009-06-27 01:20:43.000000000 +0200
+++ ppc64-diag-2.4.2_/rtas_errd/files.c 2012-02-15 18:43:59.950079214 +0100
@@ -161,7 +161,7 @@
diff --git a/rtas_errd/files.c b/rtas_errd/files.c
index e233728..b1f53e1 100644
--- a/rtas_errd/files.c
+++ b/rtas_errd/files.c
@@ -161,7 +161,7 @@ setup_rtas_event_scenario(void)
{
struct stat sbuf;
char *tmp;
@ -85,10 +103,11 @@ diff -urN ppc64-diag-2.4.2/rtas_errd/files.c ppc64-diag-2.4.2_/rtas_errd/files.c
int i;
if (scenario_file == NULL)
diff -urN ppc64-diag-2.4.2/rtas_errd/guard.c ppc64-diag-2.4.2_/rtas_errd/guard.c
--- ppc64-diag-2.4.2/rtas_errd/guard.c 2009-06-27 01:20:43.000000000 +0200
+++ ppc64-diag-2.4.2_/rtas_errd/guard.c 2012-02-15 18:46:45.870082813 +0100
@@ -40,7 +40,7 @@
diff --git a/rtas_errd/guard.c b/rtas_errd/guard.c
index e9cc277..4c5177d 100644
--- a/rtas_errd/guard.c
+++ b/rtas_errd/guard.c
@@ -40,7 +40,7 @@ run_drmgr(enum resource_dealloc_type resource_type, char *drc_name,
unsigned int value, int wait)
{
pid_t child;
@ -97,3 +116,6 @@ diff -urN ppc64-diag-2.4.2/rtas_errd/guard.c ppc64-diag-2.4.2_/rtas_errd/guard.c
char capacity[6], quant_str[5];
char *drmgr_args[] = {DRMGR_PROGRAM_NOPATH, "-r", "-c", NULL,
NULL, NULL, NULL, NULL, NULL};
--
1.8.3.1

View File

@ -1,6 +1,6 @@
Name: ppc64-diag
Version: 2.6.6
Release: 2%{?dist}
Version: 2.6.7
Release: 1%{?dist}
Summary: PowerLinux Platform Diagnostics
URL: http://sourceforge.net/projects/linux-diag/files/ppc64-diag/
Group: System Environment/Base
@ -17,14 +17,12 @@ Requires: servicelog, lsvpd
Requires: powerpc-utils >= 1.2.19
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://downloads.sourceforge.net/project/linux-diag/ppc64-diag/%{version}/%{name}-%{version}.tar.gz
Source1: rtas_errd.service
Source2: opal_errd.service
Patch0: ppc64-diag-2.4.2-messagecatalog-location.patch
Patch1: ppc64-diag-2.4.2-chkconfig.patch
Patch2: ppc64-diag-2.4.3-scriptlocation.patch
Patch0: ppc64-diag-messagecatalog-location.patch
Patch1: ppc64-diag-chkconfig.patch
Patch2: ppc64-diag-scriptlocation.patch
Patch3: ppc64-diag-unusedvar.patch
Patch4: ppc64-diag-2.6.1-lpdscriptloc.patch
Patch5: ppc64-diag-2.6.2-prrnscriptloc.patch
Patch4: ppc64-diag-lpdscriptloc.patch
Patch5: ppc64-diag-prrnscriptloc.patch
%description
This package contains various diagnostic tools for PowerLinux.
@ -56,11 +54,7 @@ make install DESTDIR=$RPM_BUILD_ROOT
chmod 644 COPYRIGHT
rm -f $RPM_BUILD_ROOT/usr/share/doc/packages/ppc64-diag/COPYRIGHT
mkdir -p $RPM_BUILD_ROOT/%{_libexecdir}/%{name}
mv -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/rtas_errd $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/
mv -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/opal_errd $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/
mkdir -p $RPM_BUILD_ROOT/%{_unitdir}
install -m644 %{SOURCE1} $RPM_BUILD_ROOT/%{_unitdir}
install -m644 %{SOURCE2} $RPM_BUILD_ROOT/%{_unitdir}
mkdir $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/ses_pages
mkdir -p $RPM_BUILD_ROOT/%{_var}/log/dump
ln -sfv %{_sbindir}/usysattn $RPM_BUILD_ROOT/%{_sbindir}/usysfault
@ -105,16 +99,20 @@ rm -rf $RPM_BUILD_ROOT
%{_libexecdir}/%{name}/lp_diag_setup --register >/dev/null 2>&1
%{_libexecdir}/%{name}/ppc64_diag_setup --register >/dev/null 2>&1
if [ "$1" = "1" ]; then # first install
systemctl -q enable opal_errd.service >/dev/null || systemctl -q enable rtas_errd.service >/dev/null
systemctl start opal_errd.service >/dev/null || systemctl start rtas_errd.service >/dev/null
systemctl -q enable opal_errd.service >/dev/null
systemctl -q enable rtas_errd.service >/dev/null
systemctl start opal_errd.service >/dev/null
systemctl start rtas_errd.service >/dev/null
elif [ "$1" = "2" ]; then # upgrade
systemctl restart opal_errd.service >/dev/null || systemctl restart rtas_errd.service >/dev/null
systemctl restart opal_errd.service >/dev/null
systemctl restart rtas_errd.service >/dev/null
fi
%preun
# Pre-uninstall script -------------------------------------------------
if [ "$1" = "0" ]; then # last uninstall
systemctl stop opal_errd.service >/dev/null || systemctl stop rtas_errd.service >/dev/null
systemctl stop opal_errd.service >/dev/null
systemctl stop rtas_errd.service >/dev/null
systemctl -q disable opal_errd.service
systemctl -q disable rtas_errd.service
%{_libexecdir}/%{name}/ppc64_diag_setup --unregister >/dev/null
@ -124,11 +122,15 @@ fi
%triggerin -- librtas
# trigger on librtas upgrades ------------------------------------------
if [ "$2" = "2" ]; then
systemctl restart opal_errd.service >/dev/null || systemctl restart rtas_errd.service >/dev/null
systemctl restart opal_errd.service >/dev/null
systemctl restart rtas_errd.service >/dev/null
fi
%changelog
* Thu Sep 25 2014 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 2.6.7
- Update to latest upstream 2.6.7
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

View File

@ -1,15 +0,0 @@
[Unit]
Description=ppc64-diag rtas_errd (platform error handling) Service
After=syslog.target
[Service]
Type=forking
ExecStart=/usr/libexec/ppc64-diag/rtas_errd start
ExecStop=/usr/libexec/ppc64-diag/rtas_errd stop
StandardOutput=syslog
StandardError=syslog
[Install]
WantedBy=multi-user.target

View File

@ -1 +1 @@
22b68d8d0b60c7f3daec093f276d4b85 ppc64-diag-2.6.6.tar.gz
6a05e1221aa7f44550dde6376d3f0187 ppc64-diag-2.6.7.tar.gz