Fix lpd script location issue.
This commit is contained in:
parent
17382cb78b
commit
42b1b21000
49
ppc64-diag-2.6.1-lpdscriptloc.patch
Normal file
49
ppc64-diag-2.6.1-lpdscriptloc.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
diff --git a/lpd/scripts/Makefile b/lpd/scripts/Makefile
|
||||||
|
index d028d09..9cb1ae5 100644
|
||||||
|
--- a/lpd/scripts/Makefile
|
||||||
|
+++ b/lpd/scripts/Makefile
|
||||||
|
@@ -8,9 +8,9 @@ SCRIPTS = lp_diag_setup lp_diag_notify
|
||||||
|
all: $(SCRIPTS)
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/etc/ppc64-diag)
|
||||||
|
+ @$(call install_files,$(SCRIPTS),744,$(DESTDIR)/usr/libexec/ppc64-diag)
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
- @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/etc/ppc64-diag)
|
||||||
|
+ @$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/usr/libexec/ppc64-diag)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
diff --git a/lpd/scripts/lp_diag_notify b/lpd/scripts/lp_diag_notify
|
||||||
|
index 9cb9b04..fb67138 100755
|
||||||
|
--- a/lpd/scripts/lp_diag_notify
|
||||||
|
+++ b/lpd/scripts/lp_diag_notify
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/perl -I /etc/ppc64-diag
|
||||||
|
+#!/usr/bin/perl -I /usr/libexec/ppc64-diag
|
||||||
|
# @file lp_diag_notify
|
||||||
|
#
|
||||||
|
# This script is to be registered with servicelog as a notification tool.
|
||||||
|
diff --git a/lpd/scripts/lp_diag_setup b/lpd/scripts/lp_diag_setup
|
||||||
|
index 7d7cc94..acbe05a 100755
|
||||||
|
--- a/lpd/scripts/lp_diag_setup
|
||||||
|
+++ b/lpd/scripts/lp_diag_setup
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/perl -I /etc/ppc64-diag
|
||||||
|
+#!/usr/bin/perl -I /usr/libexec/ppc64-diag
|
||||||
|
# @file lp_diag_setup
|
||||||
|
# @brief Register/unregister Light Path notification tools
|
||||||
|
# with servicelog
|
||||||
|
@@ -78,10 +78,10 @@ sub unregister {
|
||||||
|
}
|
||||||
|
|
||||||
|
@notification_tools = (
|
||||||
|
- ["/etc/ppc64-diag/lp_diag_notify -e",
|
||||||
|
+ ["/usr/libexec/ppc64-diag/lp_diag_notify -e",
|
||||||
|
"--match='disposition>=1 and severity>=4 and serviceable=1' ".
|
||||||
|
"--type=EVENT --method=num_arg"],
|
||||||
|
- ["/etc/ppc64-diag/lp_diag_notify -r",
|
||||||
|
+ ["/usr/libexec/ppc64-diag/lp_diag_notify -r",
|
||||||
|
"--type=REPAIR --method=num_arg"],
|
||||||
|
);
|
||||||
|
|
@ -21,6 +21,7 @@ Patch0: ppc64-diag-2.4.2-messagecatalog-location.patch
|
|||||||
Patch1: ppc64-diag-2.4.2-chkconfig.patch
|
Patch1: ppc64-diag-2.4.2-chkconfig.patch
|
||||||
Patch2: ppc64-diag-2.4.3-scriptlocation.patch
|
Patch2: ppc64-diag-2.4.3-scriptlocation.patch
|
||||||
Patch3: ppc64-diag-unusedvar.patch
|
Patch3: ppc64-diag-unusedvar.patch
|
||||||
|
Patch4: ppc64-diag-2.6.1-lpdscriptloc.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This package contains various diagnostic tools for PowerLinux.
|
This package contains various diagnostic tools for PowerLinux.
|
||||||
@ -41,6 +42,7 @@ administrators or connected service frameworks.
|
|||||||
%patch1 -p1 -b .chkconfig
|
%patch1 -p1 -b .chkconfig
|
||||||
%patch2 -p1 -b .script_loc
|
%patch2 -p1 -b .script_loc
|
||||||
%patch3 -p1 -b .unusevar
|
%patch3 -p1 -b .unusevar
|
||||||
|
%patch4 -p1 -b .lpdscriptloc
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -116,6 +118,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 21 2013 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 2.6.1-2
|
||||||
|
* Add ncurses-devel as build dependency
|
||||||
|
* Fix script location issue
|
||||||
|
|
||||||
* Mon May 20 2013 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 2.6.1
|
* Mon May 20 2013 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 2.6.1
|
||||||
- Update to latest upstream 2.6.1
|
- Update to latest upstream 2.6.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user