update to 2.4.3
This commit is contained in:
parent
5b0390456e
commit
40f20362c5
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/ppc64-diag-2.4.2.tar.gz
|
/ppc64-diag-2.4.2.tar.gz
|
||||||
|
/ppc64-diag-2.4.3.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up ppc64-diag-2.4.2/scripts/Makefile.scriptloc ppc64-diag-2.4.2/scripts/Makefile
|
diff -up ppc64-diag-2.4.3/scripts/Makefile.script_loc ppc64-diag-2.4.3/scripts/Makefile
|
||||||
--- ppc64-diag-2.4.2/scripts/Makefile.scriptloc 2011-09-05 05:58:06.720541401 -0400
|
--- ppc64-diag-2.4.3/scripts/Makefile.script_loc 2012-02-14 06:53:59.000000000 +0100
|
||||||
+++ ppc64-diag-2.4.2/scripts/Makefile 2009-05-21 17:33:06.000000000 -0400
|
+++ ppc64-diag-2.4.3/scripts/Makefile 2012-05-04 15:32:55.186608517 +0200
|
||||||
@@ -12,12 +12,12 @@ CFG_FILES = ppc64-diag.config
|
@@ -12,12 +12,12 @@ CFG_FILES = ppc64-diag.config
|
||||||
all: $(SCRIPTS) $(INIT_FILES) $(CFG_FILES)
|
all: $(SCRIPTS) $(INIT_FILES) $(CFG_FILES)
|
||||||
|
|
||||||
@ -16,9 +16,9 @@ diff -up ppc64-diag-2.4.2/scripts/Makefile.scriptloc ppc64-diag-2.4.2/scripts/Ma
|
|||||||
@$(call uninstall_files,$(INIT_FILES),$(DESTDIR)/etc/init.d)
|
@$(call uninstall_files,$(INIT_FILES),$(DESTDIR)/etc/init.d)
|
||||||
@$(call uninstall_files,$(CFG_FILES),$(DESTDIR)/etc/ppc64-diag)
|
@$(call uninstall_files,$(CFG_FILES),$(DESTDIR)/etc/ppc64-diag)
|
||||||
|
|
||||||
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc
|
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc
|
||||||
--- ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc.scriptloc 2011-09-05 06:04:22.481785543 -0400
|
--- ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc.script_loc 2012-01-20 00:53:34.000000000 +0100
|
||||||
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc 2011-09-05 06:02:45.519756640 -0400
|
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_mkrsrc 2012-05-04 15:32:55.186608517 +0200
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#! /usr/bin/perl -I /etc/ppc64-diag
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
||||||
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
||||||
@ -34,9 +34,9 @@ diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_mkrsrc.scriptloc ppc64-diag-2.4.2/s
|
|||||||
|
|
||||||
# Check to make sure that devices.chrp.base.ServiceRM is installed
|
# Check to make sure that devices.chrp.base.ServiceRM is installed
|
||||||
$check = `/bin/rpm -q devices.chrp.base.ServiceRM 2>/dev/null`;
|
$check = `/bin/rpm -q devices.chrp.base.ServiceRM 2>/dev/null`;
|
||||||
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_notify.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_notify
|
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_notify.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_notify
|
||||||
--- ppc64-diag-2.4.2/scripts/ppc64_diag_notify.scriptloc 2011-09-05 06:04:37.194638501 -0400
|
--- ppc64-diag-2.4.3/scripts/ppc64_diag_notify.script_loc 2011-11-08 00:51:25.000000000 +0100
|
||||||
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_notify 2011-09-05 06:01:43.164377573 -0400
|
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_notify 2012-05-04 15:32:55.186608517 +0200
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#! /usr/bin/perl -I /etc/ppc64-diag
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
||||||
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
||||||
@ -52,9 +52,9 @@ diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_notify.scriptloc ppc64-diag-2.4.2/s
|
|||||||
|
|
||||||
sub usage {
|
sub usage {
|
||||||
print "$0 [OPTIONS]\n";
|
print "$0 [OPTIONS]\n";
|
||||||
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_servagent.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_servagent
|
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_servagent.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_servagent
|
||||||
--- ppc64-diag-2.4.2/scripts/ppc64_diag_servagent.scriptloc 2011-09-05 06:04:45.922549428 -0400
|
--- ppc64-diag-2.4.3/scripts/ppc64_diag_servagent.script_loc 2011-11-08 00:51:25.000000000 +0100
|
||||||
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_servagent 2011-09-05 06:02:34.317866330 -0400
|
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_servagent 2012-05-04 15:32:55.186608517 +0200
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#! /usr/bin/perl -I /etc/ppc64-diag
|
-#! /usr/bin/perl -I /etc/ppc64-diag
|
||||||
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
+#! /usr/bin/perl -I /usr/libexec/ppc64-diag
|
||||||
@ -70,10 +70,10 @@ diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_servagent.scriptloc ppc64-diag-2.4.
|
|||||||
|
|
||||||
if (!-e "/usr/svcagent/bin/callsa2") {
|
if (!-e "/usr/svcagent/bin/callsa2") {
|
||||||
# eSA is not installed; exit quietly
|
# eSA is not installed; exit quietly
|
||||||
diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_setup.scriptloc ppc64-diag-2.4.2/scripts/ppc64_diag_setup
|
diff -up ppc64-diag-2.4.3/scripts/ppc64_diag_setup.script_loc ppc64-diag-2.4.3/scripts/ppc64_diag_setup
|
||||||
--- ppc64-diag-2.4.2/scripts/ppc64_diag_setup.scriptloc 2011-09-05 06:05:06.033350396 -0400
|
--- ppc64-diag-2.4.3/scripts/ppc64_diag_setup.script_loc 2012-02-14 06:53:59.000000000 +0100
|
||||||
+++ ppc64-diag-2.4.2/scripts/ppc64_diag_setup 2011-09-05 06:00:35.584058181 -0400
|
+++ ppc64-diag-2.4.3/scripts/ppc64_diag_setup 2012-05-04 15:34:23.960384271 +0200
|
||||||
@@ -76,19 +76,19 @@ sub unregister {
|
@@ -76,15 +76,15 @@ sub unregister {
|
||||||
|
|
||||||
@notification_tools = (
|
@notification_tools = (
|
||||||
|
|
||||||
@ -87,19 +87,14 @@ diff -up ppc64-diag-2.4.2/scripts/ppc64_diag_setup.scriptloc ppc64-diag-2.4.2/sc
|
|||||||
"--match='serviceable=1' ".
|
"--match='serviceable=1' ".
|
||||||
"--type=EVENT --method=pairs_stdin"],
|
"--type=EVENT --method=pairs_stdin"],
|
||||||
|
|
||||||
- ["/etc/ppc64-diag/ppc64_diag_servagent",
|
|
||||||
+ ["/usr/libexec/ppc64-diag/ppc64_diag_servagent",
|
|
||||||
"--match='serviceable=1 and (type=2 or type=3)' ".
|
|
||||||
"--type=EVENT --method=pairs_stdin"],
|
|
||||||
|
|
||||||
- ["/etc/ppc64-diag/ppc64_diag_migrate",
|
- ["/etc/ppc64-diag/ppc64_diag_migrate",
|
||||||
+ ["/usr/libexec/ppc64-diag/ppc64_diag_migrate",
|
+ ["/usr/libexec/ppc64-diag/ppc64_diag_migrate",
|
||||||
"--match=\'refcode=\"#MIGRATE\" and serviceable=0\' ".
|
"--match=\'refcode=\"#MIGRATE\" and serviceable=0\' ".
|
||||||
"--type=EVENT --method=pairs_stdin"],
|
"--type=EVENT --method=pairs_stdin"],
|
||||||
);
|
);
|
||||||
diff -up ppc64-diag-2.4.2/scripts/rtas_errd.scriptloc ppc64-diag-2.4.2/scripts/rtas_errd
|
diff -up ppc64-diag-2.4.3/scripts/rtas_errd.script_loc ppc64-diag-2.4.3/scripts/rtas_errd
|
||||||
--- ppc64-diag-2.4.2/scripts/rtas_errd.scriptloc 2011-09-05 05:59:14.982858075 -0400
|
--- ppc64-diag-2.4.3/scripts/rtas_errd.script_loc 2012-05-04 15:32:55.173608987 +0200
|
||||||
+++ ppc64-diag-2.4.2/scripts/rtas_errd 2011-09-05 05:59:34.531662814 -0400
|
+++ ppc64-diag-2.4.3/scripts/rtas_errd 2012-05-04 15:32:55.187608480 +0200
|
||||||
@@ -49,7 +49,7 @@ case "$1" in
|
@@ -49,7 +49,7 @@ case "$1" in
|
||||||
echo "registering ppc64-diag with system"
|
echo "registering ppc64-diag with system"
|
||||||
rm -f /var/cache/ppc64-diag.registered
|
rm -f /var/cache/ppc64-diag.registered
|
@ -1,6 +1,6 @@
|
|||||||
Name: ppc64-diag
|
Name: ppc64-diag
|
||||||
Version: 2.4.2
|
Version: 2.4.3
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Linux for Power Platform Diagnostics
|
Summary: Linux for Power Platform Diagnostics
|
||||||
URL: http://sourceforge.net/projects/linux-diag/files/ppc64-diag/
|
URL: http://sourceforge.net/projects/linux-diag/files/ppc64-diag/
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -14,7 +14,7 @@ Source0: http://downloads.sourceforge.net/project/linux-diag/ppc64-diag/%
|
|||||||
Source1: ppc64-diag.service
|
Source1: ppc64-diag.service
|
||||||
Patch0: ppc64-diag-2.4.2-messagecatalog-location.patch
|
Patch0: ppc64-diag-2.4.2-messagecatalog-location.patch
|
||||||
Patch1: ppc64-diag-2.4.2-chkconfig.patch
|
Patch1: ppc64-diag-2.4.2-chkconfig.patch
|
||||||
Patch2: ppc64-diag-2.4.2-scriptlocation.patch
|
Patch2: ppc64-diag-2.4.3-scriptlocation.patch
|
||||||
Patch3: ppc64-diag-unistd.patch
|
Patch3: ppc64-diag-unistd.patch
|
||||||
Patch4: ppc64-diag-unusedvar.patch
|
Patch4: ppc64-diag-unusedvar.patch
|
||||||
|
|
||||||
@ -61,7 +61,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_migrate
|
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_migrate
|
||||||
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_mkrsrc
|
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_mkrsrc
|
||||||
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_notify
|
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_notify
|
||||||
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_servagent
|
#%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_servagent
|
||||||
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_setup
|
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_setup
|
||||||
%attr(644,root,root) %{_libexecdir}/%{name}/servevent_parse.pl
|
%attr(644,root,root) %{_libexecdir}/%{name}/servevent_parse.pl
|
||||||
%attr(644,root,root) %{_datadir}/%{name}/message_catalog/cxgb3
|
%attr(644,root,root) %{_datadir}/%{name}/message_catalog/cxgb3
|
||||||
@ -96,6 +96,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 04 2012 Karsten Hopp <karsten@redhat.com> 2.4.3-1
|
||||||
|
- update to 2.4.3
|
||||||
|
|
||||||
* Wed Feb 15 2012 Karsten Hopp <karsten@redhat.com> 2.4.2-5
|
* Wed Feb 15 2012 Karsten Hopp <karsten@redhat.com> 2.4.2-5
|
||||||
- don't strip binaries
|
- don't strip binaries
|
||||||
- fix some build issues
|
- fix some build issues
|
||||||
|
Loading…
Reference in New Issue
Block a user