- add DESTDIR to install path
This commit is contained in:
parent
a2da6390c6
commit
32e2a7801f
@ -1,7 +1,7 @@
|
|||||||
diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
|
diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
|
||||||
--- ppc64-diag-2.4.2/ela/Makefile.msg_loc 2011-06-29 10:50:51.000000000 -0400
|
--- ppc64-diag-2.4.2/ela/Makefile.msg_loc 2011-06-29 10:50:51.000000000 -0400
|
||||||
+++ ppc64-diag-2.4.2/ela/Makefile 2011-09-01 08:31:39.524245670 -0400
|
+++ ppc64-diag-2.4.2/ela/Makefile 2011-09-09 14:51:01.000000000 -0400
|
||||||
@@ -72,8 +72,8 @@ catalogs.o: catalogs.h
|
@@ -72,17 +72,17 @@ catalogs.o: catalogs.h
|
||||||
|
|
||||||
install: all
|
install: all
|
||||||
@$(call install_sbin,$(CMDS),$(DESTDIR))
|
@$(call install_sbin,$(CMDS),$(DESTDIR))
|
||||||
@ -10,9 +10,11 @@ diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
|
|||||||
+ @$(call install_files,$(CATALOG),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog)
|
+ @$(call install_files,$(CATALOG),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog)
|
||||||
+ @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex)
|
+ @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex)
|
||||||
@$(call install_man,$(MANPAGES),$(DESTDIR))
|
@$(call install_man,$(MANPAGES),$(DESTDIR))
|
||||||
$(INSTALL) -d -m 755 /var/log/ppc64-diag
|
- $(INSTALL) -d -m 755 /var/log/ppc64-diag
|
||||||
|
+ $(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
|
||||||
|
|
||||||
@@ -82,7 +82,7 @@ clean:
|
clean:
|
||||||
|
@rm -rf $(CMDS) *.o lex.*.c *.tab.c *.tab.h
|
||||||
|
|
||||||
uninstall:
|
uninstall:
|
||||||
@$(call uninstall_sbin,$(CMDS),$(DESTDIR))
|
@$(call uninstall_sbin,$(CMDS),$(DESTDIR))
|
||||||
@ -24,7 +26,7 @@ diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
|
|||||||
|
|
||||||
diff -up ppc64-diag-2.4.2/ela/catalogs.h.msg_loc ppc64-diag-2.4.2/ela/catalogs.h
|
diff -up ppc64-diag-2.4.2/ela/catalogs.h.msg_loc ppc64-diag-2.4.2/ela/catalogs.h
|
||||||
--- ppc64-diag-2.4.2/ela/catalogs.h.msg_loc 2011-02-23 17:55:31.000000000 -0500
|
--- ppc64-diag-2.4.2/ela/catalogs.h.msg_loc 2011-02-23 17:55:31.000000000 -0500
|
||||||
+++ ppc64-diag-2.4.2/ela/catalogs.h 2011-09-01 08:31:39.527245640 -0400
|
+++ ppc64-diag-2.4.2/ela/catalogs.h 2011-09-09 14:50:12.000000000 -0400
|
||||||
@@ -21,7 +21,7 @@ using namespace std;
|
@@ -21,7 +21,7 @@ using namespace std;
|
||||||
#include <stdio.h>
|
#include <stdio.h>
|
||||||
#include <regex.h>
|
#include <regex.h>
|
||||||
@ -35,8 +37,8 @@ diff -up ppc64-diag-2.4.2/ela/catalogs.h.msg_loc ppc64-diag-2.4.2/ela/catalogs.h
|
|||||||
class Parser {
|
class Parser {
|
||||||
protected:
|
protected:
|
||||||
diff -up ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc ppc64-diag-2.4.2/ela/explain_syslog.cpp
|
diff -up ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc ppc64-diag-2.4.2/ela/explain_syslog.cpp
|
||||||
--- ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc 2011-09-01 08:38:05.226391677 -0400
|
--- ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc 2011-02-22 14:27:02.000000000 -0500
|
||||||
+++ ppc64-diag-2.4.2/ela/explain_syslog.cpp 2011-09-01 08:38:27.910165017 -0400
|
+++ ppc64-diag-2.4.2/ela/explain_syslog.cpp 2011-09-09 14:50:12.000000000 -0400
|
||||||
@@ -94,7 +94,7 @@ print_help(void)
|
@@ -94,7 +94,7 @@ print_help(void)
|
||||||
printf(
|
printf(
|
||||||
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
|
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
|
||||||
@ -48,7 +50,7 @@ diff -up ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc ppc64-diag-2.4.2/ela/ex
|
|||||||
"-h\t\tPrint this help text and exit.\n"
|
"-h\t\tPrint this help text and exit.\n"
|
||||||
diff -up ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp
|
diff -up ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp
|
||||||
--- ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc 2011-07-11 05:43:41.000000000 -0400
|
--- ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc 2011-07-11 05:43:41.000000000 -0400
|
||||||
+++ ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp 2011-09-01 08:31:39.531245600 -0400
|
+++ ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp 2011-09-09 14:50:12.000000000 -0400
|
||||||
@@ -654,7 +654,7 @@ print_help(void)
|
@@ -654,7 +654,7 @@ print_help(void)
|
||||||
printf(
|
printf(
|
||||||
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
|
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
|
||||||
|
Loading…
Reference in New Issue
Block a user