import powertop-2.9-8.el8
This commit is contained in:
commit
4068f564b5
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/powertop-v2.9.tar.gz
|
1
.powertop.metadata
Normal file
1
.powertop.metadata
Normal file
@ -0,0 +1 @@
|
||||
0b49a0fe9fd8a1026faf731a959146ed93d83153 SOURCES/powertop-v2.9.tar.gz
|
35
SOURCES/powertop-2.7-always-create-params.patch
Normal file
35
SOURCES/powertop-2.7-always-create-params.patch
Normal file
@ -0,0 +1,35 @@
|
||||
diff --git a/src/parameters/persistent.cpp b/src/parameters/persistent.cpp
|
||||
index 9a5688a..6a232cd 100644
|
||||
--- a/src/parameters/persistent.cpp
|
||||
+++ b/src/parameters/persistent.cpp
|
||||
@@ -145,9 +145,6 @@ void save_parameters(const char *filename)
|
||||
|
||||
// printf("result size is %i, #parameters is %i \n", (int)past_results.size(), (int)all_parameters.parameters.size());
|
||||
|
||||
- if (!global_power_valid())
|
||||
- return;
|
||||
-
|
||||
pathname = get_param_directory(filename);
|
||||
|
||||
file.open(pathname, ios::out);
|
||||
@@ -156,12 +153,15 @@ void save_parameters(const char *filename)
|
||||
return;
|
||||
}
|
||||
|
||||
- map<string, int>::iterator it;
|
||||
+ if (global_power_valid())
|
||||
+ {
|
||||
+ map<string, int>::iterator it;
|
||||
|
||||
- for (it = param_index.begin(); it != param_index.end(); it++) {
|
||||
- int index;
|
||||
- index = it->second;
|
||||
- file << it->first << "\t" << setprecision(9) << all_parameters.parameters[index] << "\n";
|
||||
+ for (it = param_index.begin(); it != param_index.end(); it++) {
|
||||
+ int index;
|
||||
+ index = it->second;
|
||||
+ file << it->first << "\t" << setprecision(9) << all_parameters.parameters[index] << "\n";
|
||||
+ }
|
||||
}
|
||||
file.close();
|
||||
}
|
41
SOURCES/powertop-2.9-cstates-rewrite-fix.patch
Normal file
41
SOURCES/powertop-2.9-cstates-rewrite-fix.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From f3f350f138912dc89abb37676f7e65fc6057ec53 Mon Sep 17 00:00:00 2001
|
||||
From: Gautam Paranjape <gautam.paranjape@intel.com>
|
||||
Date: Fri, 21 Jul 2017 07:02:13 -0700
|
||||
Subject: [PATCH] Some c-states exposed by the intel_idle driver are assigned
|
||||
the same line_level, which means that the most recent one assigned can
|
||||
overwrite another c-state. For example, the C1-SKL c-state is overwritten by
|
||||
the C1E-SKL c-state because both have a "1" in the name and are assigned the
|
||||
same line level. To fix this, check if a "sub c-state" (ex. C1E-SKL) is being
|
||||
inserted. If so, check the vector of c-states if a c-state with similar name
|
||||
(ex. C1-SKL) exists, and increment the line level.
|
||||
|
||||
Signed-off-by: Gautam Paranjape <gautam.paranjape@intel.com>
|
||||
---
|
||||
src/cpu/abstract_cpu.cpp | 11 +++++++++++
|
||||
1 file changed, 11 insertions(+)
|
||||
|
||||
diff --git a/src/cpu/abstract_cpu.cpp b/src/cpu/abstract_cpu.cpp
|
||||
index bc32336..c59721c 100644
|
||||
--- a/src/cpu/abstract_cpu.cpp
|
||||
+++ b/src/cpu/abstract_cpu.cpp
|
||||
@@ -218,6 +218,17 @@ void abstract_cpu::insert_cstate(const char *linux_name, const char *human_name,
|
||||
}
|
||||
if (*c >= '0' && *c <='9') {
|
||||
state->line_level = strtoull(c, NULL, 10);
|
||||
+ if(*(c+1) != '-'){
|
||||
+ int greater_line_level = strtoull(c, NULL, 10);
|
||||
+ for(unsigned int pos = 0; pos < cstates.size(); pos++){
|
||||
+ if(*c == cstates[pos]->human_name[1]){
|
||||
+ if(*(c+1) != cstates[pos]->human_name[2]){
|
||||
+ greater_line_level = max(greater_line_level, cstates[pos]->line_level);
|
||||
+ state->line_level = greater_line_level + 1;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
break;
|
||||
}
|
||||
c++;
|
||||
--
|
||||
2.14.3
|
||||
|
51
SOURCES/powertop-2.9-intel-cnluy-support.patch
Normal file
51
SOURCES/powertop-2.9-intel-cnluy-support.patch
Normal file
@ -0,0 +1,51 @@
|
||||
From 0d3a1cda2a95484fa41cc4c35294a4153b3a5e97 Mon Sep 17 00:00:00 2001
|
||||
From: Nivedita Swaminathan <nivedita.swaminathan@intel.com>
|
||||
Date: Wed, 31 Jan 2018 14:53:28 -0800
|
||||
Subject: [PATCH] Enable support for Intel CNL-U/Y
|
||||
|
||||
This commit adds support for Intel CNL-U/Y platforms
|
||||
|
||||
Signed-off-by: Nivedita Swaminathan <nivedita.swaminathan@intel.com>
|
||||
---
|
||||
src/cpu/intel_cpus.cpp | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/cpu/intel_cpus.cpp b/src/cpu/intel_cpus.cpp
|
||||
index 4980516..4c7b315 100644
|
||||
--- a/src/cpu/intel_cpus.cpp
|
||||
+++ b/src/cpu/intel_cpus.cpp
|
||||
@@ -68,6 +68,7 @@ static int intel_cpu_models[] = {
|
||||
0x5E, /* SKY */
|
||||
0x56, /* BDX-DE */
|
||||
0x5c, /* BXT-P */
|
||||
+ 0x66, /* CNL-U/Y */
|
||||
0x7A, /* GLK */
|
||||
0x8E, /* KBL */
|
||||
0x9E, /* KBL */
|
||||
@@ -166,6 +167,7 @@ nhm_core::nhm_core(int model)
|
||||
case 0x5E: /* SKY */
|
||||
case 0x3D: /* BDW */
|
||||
case 0x5c: /* BXT-P */
|
||||
+ case 0x66: /* CNL-U/Y */
|
||||
case 0x7A: /* GLK */
|
||||
case 0x8E: /* KBL */
|
||||
case 0x9E: /* KBL */
|
||||
@@ -347,6 +349,7 @@ nhm_package::nhm_package(int model)
|
||||
case 0x5E: /* SKY */
|
||||
case 0x3D: /* BDW */
|
||||
case 0x5c: /* BXT-P */
|
||||
+ case 0x66: /* CNL-U/Y */
|
||||
case 0x7A: /* GLK */
|
||||
case 0x8E: /* KBL */
|
||||
case 0x9E: /* KBL */
|
||||
@@ -380,6 +383,7 @@ nhm_package::nhm_package(int model)
|
||||
case 0x4E: /* SKY */
|
||||
case 0x5E: /* SKY */
|
||||
case 0x5c: /* BXT-P */
|
||||
+ case 0x66: /* CNL-U/Y */
|
||||
case 0x7A: /* GLK */
|
||||
case 0x8E: /* KBL */
|
||||
case 0x9E: /* KBL */
|
||||
--
|
||||
2.14.3
|
||||
|
66
SOURCES/powertop-2.9-intel-cpu-check-aperf.patch
Normal file
66
SOURCES/powertop-2.9-intel-cpu-check-aperf.patch
Normal file
@ -0,0 +1,66 @@
|
||||
diff --git a/src/cpu/cpu.cpp b/src/cpu/cpu.cpp
|
||||
index f3711f5..019d922 100644
|
||||
--- a/src/cpu/cpu.cpp
|
||||
+++ b/src/cpu/cpu.cpp
|
||||
@@ -68,7 +68,7 @@ static class abstract_cpu * new_package(int package, int cpu, char * vendor, int
|
||||
char packagename[128];
|
||||
if (strcmp(vendor, "GenuineIntel") == 0)
|
||||
if (family == 6)
|
||||
- if (is_supported_intel_cpu(model))
|
||||
+ if (is_supported_intel_cpu(model, cpu))
|
||||
ret = new class nhm_package(model);
|
||||
|
||||
if (!ret)
|
||||
@@ -105,7 +105,7 @@ static class abstract_cpu * new_core(int core, int cpu, char * vendor, int famil
|
||||
|
||||
if (strcmp(vendor, "GenuineIntel") == 0)
|
||||
if (family == 6)
|
||||
- if (is_supported_intel_cpu(model))
|
||||
+ if (is_supported_intel_cpu(model, cpu))
|
||||
ret = new class nhm_core(model);
|
||||
|
||||
if (!ret)
|
||||
@@ -134,7 +134,7 @@ static class abstract_cpu * new_cpu(int number, char * vendor, int family, int m
|
||||
|
||||
if (strcmp(vendor, "GenuineIntel") == 0)
|
||||
if (family == 6)
|
||||
- if (is_supported_intel_cpu(model))
|
||||
+ if (is_supported_intel_cpu(model, number))
|
||||
ret = new class nhm_cpu;
|
||||
|
||||
if (!ret)
|
||||
diff --git a/src/cpu/intel_cpus.cpp b/src/cpu/intel_cpus.cpp
|
||||
index 4c7b315..0030dba 100644
|
||||
--- a/src/cpu/intel_cpus.cpp
|
||||
+++ b/src/cpu/intel_cpus.cpp
|
||||
@@ -77,13 +77,15 @@ static int intel_cpu_models[] = {
|
||||
|
||||
static int intel_pstate_driver_loaded = -1;
|
||||
|
||||
-int is_supported_intel_cpu(int model)
|
||||
+int is_supported_intel_cpu(int model, int cpu)
|
||||
{
|
||||
int i;
|
||||
+ uint64_t msr;
|
||||
|
||||
for (i = 0; intel_cpu_models[i] != 0; i++)
|
||||
if (model == intel_cpu_models[i])
|
||||
- return 1;
|
||||
+ if (cpu < 0 || read_msr(cpu, MSR_APERF, &msr) >= 0)
|
||||
+ return 1;
|
||||
|
||||
return 0;
|
||||
}
|
||||
diff --git a/src/cpu/intel_cpus.h b/src/cpu/intel_cpus.h
|
||||
index d20db9a..79afb98 100644
|
||||
--- a/src/cpu/intel_cpus.h
|
||||
+++ b/src/cpu/intel_cpus.h
|
||||
@@ -172,7 +172,7 @@ public:
|
||||
|
||||
};
|
||||
|
||||
-int is_supported_intel_cpu(int model);
|
||||
+int is_supported_intel_cpu(int model, int cpu);
|
||||
int byt_has_ahci();
|
||||
|
||||
int is_intel_pstate_driver_loaded();
|
51
SOURCES/powertop-2.9-intel-glk-support.patch
Normal file
51
SOURCES/powertop-2.9-intel-glk-support.patch
Normal file
@ -0,0 +1,51 @@
|
||||
From 523b15bd892f036bb6b777ad6c88f334f0980347 Mon Sep 17 00:00:00 2001
|
||||
From: Nivedita Swaminathan <nivedita.swaminathan@intel.com>
|
||||
Date: Wed, 31 Jan 2018 14:41:18 -0800
|
||||
Subject: [PATCH] Enable support for Intel GLK
|
||||
|
||||
This commit enables support for Intel GLK platforms
|
||||
|
||||
Signed-off-by: Nivedita Swaminathan <nivedita.saminathan@intel.com>
|
||||
---
|
||||
src/cpu/intel_cpus.cpp | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/cpu/intel_cpus.cpp b/src/cpu/intel_cpus.cpp
|
||||
index 3901342..4980516 100644
|
||||
--- a/src/cpu/intel_cpus.cpp
|
||||
+++ b/src/cpu/intel_cpus.cpp
|
||||
@@ -68,6 +68,7 @@ static int intel_cpu_models[] = {
|
||||
0x5E, /* SKY */
|
||||
0x56, /* BDX-DE */
|
||||
0x5c, /* BXT-P */
|
||||
+ 0x7A, /* GLK */
|
||||
0x8E, /* KBL */
|
||||
0x9E, /* KBL */
|
||||
0 /* last entry must be zero */
|
||||
@@ -165,6 +166,7 @@ nhm_core::nhm_core(int model)
|
||||
case 0x5E: /* SKY */
|
||||
case 0x3D: /* BDW */
|
||||
case 0x5c: /* BXT-P */
|
||||
+ case 0x7A: /* GLK */
|
||||
case 0x8E: /* KBL */
|
||||
case 0x9E: /* KBL */
|
||||
has_c7_res = 1;
|
||||
@@ -345,6 +347,7 @@ nhm_package::nhm_package(int model)
|
||||
case 0x5E: /* SKY */
|
||||
case 0x3D: /* BDW */
|
||||
case 0x5c: /* BXT-P */
|
||||
+ case 0x7A: /* GLK */
|
||||
case 0x8E: /* KBL */
|
||||
case 0x9E: /* KBL */
|
||||
has_c2c6_res=1;
|
||||
@@ -377,6 +380,7 @@ nhm_package::nhm_package(int model)
|
||||
case 0x4E: /* SKY */
|
||||
case 0x5E: /* SKY */
|
||||
case 0x5c: /* BXT-P */
|
||||
+ case 0x7A: /* GLK */
|
||||
case 0x8E: /* KBL */
|
||||
case 0x9E: /* KBL */
|
||||
has_c8c9c10_res = 1;
|
||||
--
|
||||
2.14.3
|
||||
|
9
SOURCES/powertop.service
Normal file
9
SOURCES/powertop.service
Normal file
@ -0,0 +1,9 @@
|
||||
[Unit]
|
||||
Description=PowerTOP autotuner
|
||||
|
||||
[Service]
|
||||
Type=oneshot
|
||||
ExecStart=/usr/sbin/powertop --auto-tune
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
394
SPECS/powertop.spec
Normal file
394
SPECS/powertop.spec
Normal file
@ -0,0 +1,394 @@
|
||||
Name: powertop
|
||||
Version: 2.9
|
||||
Release: 8%{?dist}
|
||||
Summary: Power consumption monitor
|
||||
|
||||
Group: Applications/System
|
||||
License: GPLv2
|
||||
URL: http://01.org/powertop/
|
||||
Source0: http://01.org/sites/default/files/downloads/powertop/%{name}-v%{version}.tar.gz
|
||||
Source1: powertop.service
|
||||
|
||||
# Sent upstream
|
||||
Patch0: powertop-2.7-always-create-params.patch
|
||||
Patch1: powertop-2.9-cstates-rewrite-fix.patch
|
||||
Patch2: powertop-2.9-intel-glk-support.patch
|
||||
Patch3: powertop-2.9-intel-cnluy-support.patch
|
||||
Patch4: powertop-2.9-intel-cpu-check-aperf.patch
|
||||
BuildRequires: gettext-devel, ncurses-devel, pciutils-devel, zlib-devel, libnl3-devel
|
||||
BuildRequires: systemd
|
||||
BuildRequires: gcc, gcc-c++
|
||||
Requires(post): systemd, coreutils
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
Provides: bundled(kernel-event-lib)
|
||||
|
||||
%description
|
||||
PowerTOP is a tool that finds the software component(s) that make your
|
||||
computer use more power than necessary while it is idle.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-v%{version}
|
||||
%patch0 -p1 -b .always-create-params
|
||||
# https://github.com/fenrus75/powertop/commit/f3f350f138912dc89abb37676f7e65fc6057ec53
|
||||
%patch1 -p1 -b .cstates-rewrite-fix
|
||||
# https://github.com/fenrus75/powertop/commit/523b15bd892f036bb6b777ad6c88f334f0980347
|
||||
%patch2 -p1 -b .intel-glk-support
|
||||
# https://github.com/fenrus75/powertop/commit/0d3a1cda2a95484fa41cc4c35294a4153b3a5e97
|
||||
%patch3 -p1 -b .intel-cnluy-support
|
||||
# sent upstream
|
||||
%patch4 -p1 -b .intel-cpu-check-aperf
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{?_smp_mflags} CFLAGS="%{optflags}"
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make install DESTDIR=%{buildroot}
|
||||
install -Dd %{buildroot}%{_localstatedir}/cache/powertop
|
||||
touch %{buildroot}%{_localstatedir}/cache/powertop/{saved_parameters.powertop,saved_results.powertop}
|
||||
%find_lang %{name}
|
||||
|
||||
# Systemd
|
||||
install -Dpm 644 %{SOURCE1} %{buildroot}%{_unitdir}/powertop.service
|
||||
|
||||
%preun
|
||||
%systemd_preun powertop.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart powertop.service
|
||||
|
||||
%post
|
||||
%systemd_post powertop.service
|
||||
# Hack for powertop not to show warnings on first start
|
||||
touch %{_localstatedir}/cache/powertop/{saved_parameters.powertop,saved_results.powertop} &> /dev/null || :
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README TODO
|
||||
%dir %{_localstatedir}/cache/powertop
|
||||
%ghost %{_localstatedir}/cache/powertop/saved_parameters.powertop
|
||||
%ghost %{_localstatedir}/cache/powertop/saved_results.powertop
|
||||
%{_sbindir}/powertop
|
||||
%{_mandir}/man8/powertop.8*
|
||||
%{_unitdir}/powertop.service
|
||||
|
||||
%changelog
|
||||
* Fri May 4 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.9-8
|
||||
- Use intel_cpu only if APERF MSR is supported, it fixes powertop on KVM
|
||||
(by intel-cpu-check-aperf patch)
|
||||
|
||||
* Fri May 4 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.9-7
|
||||
- Added support for Intel GLK platforms (by intel-glk-support patch)
|
||||
- Added support for Intel CNL-U/Y platforms (by intel-cnluy-support patch)
|
||||
- Fixed problem with some C-states overwriting others
|
||||
(by cstates-rewrite-fix patch)
|
||||
|
||||
* Fri Apr 20 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.9-6
|
||||
- Made post scriptlet not to fail
|
||||
Resolves: rhbz#1569722
|
||||
|
||||
* Mon Feb 19 2018 Ondřej Lysoněk <olysonek@redhat.com> - 2.9-5
|
||||
- Add gcc, gcc-c++ to BuildRequires
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue May 23 2017 Jaroslav Škarvada <jskarvad@redhat.com> - 2.9-1
|
||||
- New version
|
||||
Resolves: rhbz#1454519
|
||||
- Dropped pthreads-cflags-fix and potential-segfaults patches (both upstreamed)
|
||||
- Updated source URL
|
||||
|
||||
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.8-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Aug 30 2016 Ondřej Lysoněk <olysonek@redhat.com> - 2.8-3
|
||||
- Fixed some potential sources of segfaults
|
||||
Resolves: rhbz#1352708
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Nov 10 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2.8-1
|
||||
- New version
|
||||
Resolves: rhbz#1279872
|
||||
- Dropped tunable-overflow-fix, auto-tune-crash-fix, navigate-hint
|
||||
patches (all upstreamed)
|
||||
- Dropped bytrail-no-c7 patch (following upstream)
|
||||
- Fixed linkage with pthreads (by pthreads-cflags-fix patch)
|
||||
- Added bundled(kernel-event-lib)
|
||||
Resolves: rhbz#1041323
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed May 6 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7-5
|
||||
- Fixed crash on Baytrail CPUs (by bytrail-no-c7 patch)
|
||||
Resolves: rhbz#1208600
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.7-4
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Wed Feb 11 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7-3
|
||||
- Added hint how to navigate through panes, (by navigate-hint patch)
|
||||
Resolves: rhbz#1191112
|
||||
|
||||
* Fri Jan 30 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7-2
|
||||
- Fixed crash when running with --auto-tune (by auto-tune-crash-fix patch)
|
||||
Resolves: rhbz#1187452
|
||||
|
||||
* Tue Nov 25 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7-1
|
||||
- New version
|
||||
Resolves: rhbz#1167726
|
||||
- De-fuzzified patches
|
||||
- Dropped man-fix patch (upstreamed)
|
||||
- Added powertop autotuner oneshot service
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon May 26 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.6.1-1
|
||||
- New version
|
||||
Resolves: rhbz#1100724
|
||||
- Dropped ondemand-check patch (upstream dropped the functionality)
|
||||
|
||||
* Tue Mar 25 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.5-2
|
||||
- Fixed buffer overflow in cpufreq tunables on systems with many CPUs
|
||||
(by tunable-overflow-fix patch)
|
||||
|
||||
* Mon Nov 25 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.5-1
|
||||
- New version
|
||||
Resolves: rhbz#1034113
|
||||
- Dropped unlimit-fds, fd-limit-err, reg-net-params patches (all upstreamed)
|
||||
|
||||
* Tue Oct 29 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4-6
|
||||
- Fixed some possible unregistered parameters errors
|
||||
Resolves: rhbz#947425
|
||||
|
||||
* Thu Oct 10 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4-5
|
||||
- New version of unlimit-fds patch
|
||||
- Fixed error message if FDs limit is reached (by fd-limit-err patch)
|
||||
|
||||
* Fri Sep 20 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4-4
|
||||
- Unlimit FDs (by unlimit-fds patch) and dropped the fd-limit-err patch
|
||||
|
||||
* Thu Sep 19 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4-3
|
||||
- Printed friendly error message if the system is running out
|
||||
of FDs (by fd-limit-err patch)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Jul 23 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4-1
|
||||
- New version
|
||||
Resolves: rhbz#987404
|
||||
|
||||
* Fri Jun 28 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.3-4
|
||||
- Added check if ondemand governor is applicable (by ondemand-check patch)
|
||||
Resolves: rhbz#697273
|
||||
|
||||
* Tue Jun 25 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.3-3
|
||||
- Added workload option to the man page
|
||||
|
||||
* Wed Apr 10 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.3-2
|
||||
- Added post requirements for coreutils
|
||||
|
||||
* Wed Mar 20 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.3-1
|
||||
- New version
|
||||
Resolves: rhbz#923729
|
||||
- Dropped fix-crash-on-readonly-fs, reduce-syscalls,
|
||||
gpu-wiggle-fix patches (upstreamed)
|
||||
- Dropped version-fix patch (not needed)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jan 20 2013 Dan Horák <dan@danny.cz> - 2.2-6
|
||||
- rebuilt again for fixed soname in libnl3
|
||||
|
||||
* Sun Jan 20 2013 Kalev Lember <kalevlember@gmail.com> - 2.2-5
|
||||
- Rebuilt for libnl3
|
||||
|
||||
* Mon Jan 14 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2-4
|
||||
- Reduced number of useless syscalls (reduce-syscalls patch) and
|
||||
fixed gpu wiggle (gpu-wiggle-fix patch)
|
||||
Resolves: rhbz#886185
|
||||
|
||||
* Sun Dec 2 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2-3
|
||||
- Updated version to show 2.2 (by version-fix patch)
|
||||
|
||||
* Wed Nov 28 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2-2
|
||||
- Fixed crash when writing report on readonly filesystem
|
||||
(fix-crash-on-readonly-fs patch)
|
||||
|
||||
* Fri Nov 23 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2-1
|
||||
- New version
|
||||
Resolves: rhbz#877373
|
||||
- Dropped html-escape patch (not needed)
|
||||
|
||||
* Thu Aug 16 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.1-2
|
||||
- Removed left over object files
|
||||
|
||||
* Thu Aug 16 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.1-1
|
||||
- New version
|
||||
- Removed patches (all upstreamed): show-watts-only-if-discharging,
|
||||
valid-html-output, factor-out-powertop-init, catch-fstream-errors
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed Jul 4 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.0-3
|
||||
- Catch fstream exceptions
|
||||
Resolves: rhbz#832497
|
||||
|
||||
* Mon May 21 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.0-2
|
||||
- Fixed segfault during calibration
|
||||
Resolves: rhbz#823502
|
||||
- Used macro optflags instead of variable RPM_OPT_FLAGS
|
||||
|
||||
* Wed May 16 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 2.0-1
|
||||
- New version
|
||||
Resolves: rhbz#821144
|
||||
- Dropped patches: unknown-readings-fix (upstreamed), compile-fix (upstreamed),
|
||||
power-supply-add-power-now-support (upstreamed),
|
||||
html-print-commands (upstreamed), add-power-supply-class-support (obsoleted),
|
||||
power-supply-units-fix (obsoleted)
|
||||
- Updated patches: show-watts-only-if-discharging patch (sent upstream),
|
||||
html-escape patch
|
||||
- Added patch: valid-html-output (sent upstream)
|
||||
|
||||
* Tue Apr 17 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 1.98-9
|
||||
- Show power consumption only if discharging
|
||||
Resolves: rhbz#811949
|
||||
|
||||
* Tue Apr 03 2012 Jan Kaluza <jkaluza@redhat.com> - 1.98-8
|
||||
- Escape scripts in HTML output
|
||||
|
||||
* Mon Mar 26 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 1.98-7
|
||||
- Print commands which reproduce the tunings into html log (html-print-commands patch)
|
||||
|
||||
* Wed Mar 7 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 1.98-6
|
||||
- Fixed power_supply units
|
||||
Resolves: rhbz#800814
|
||||
|
||||
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.98-5
|
||||
- Rebuilt for c++ ABI breakage
|
||||
|
||||
* Fri Feb 24 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 1.98-4
|
||||
- Backported support for power_supply class
|
||||
(add-power-supply-class-support patch)
|
||||
- Added support for POWER_NOW readings
|
||||
(power-supply-add-power-now-support patch)
|
||||
Resolves: rhbz#796068
|
||||
|
||||
* Tue Jan 10 2012 Jaroslav Škarvada <jskarvad@redhat.com> - 1.98-3
|
||||
- Fixed 'unknown' readings from ACPI meters
|
||||
Resolves: rhbz#770289
|
||||
- Fixed compilation on f17
|
||||
|
||||
* Fri Dec 2 2011 Jaroslav Škarvada <jskarvad@redhat.com> - 1.98-2
|
||||
- Always create params file
|
||||
Resolves: rhbz#698020
|
||||
- Added cache files
|
||||
|
||||
* Wed May 25 2011 Jaroslav Škarvada <jskarvad@redhat.com> - 1.98-1
|
||||
- New version
|
||||
|
||||
* Wed Mar 23 2011 Dan Horák <dan[at]danny.cz> - 1.97-2
|
||||
- csstoh should return 0
|
||||
|
||||
* Tue Feb 15 2011 Jaroslav Škarvada <jskarvad@redhat.com> - 1.97-1
|
||||
- New version
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Nov 24 2010 Jaroslav Škarvada <jskarvad@redhat.com> - 1.13-2
|
||||
- Fixed sigwinch handling (#644800)
|
||||
- Readded strncpy patch as strncpy is safer than strcpy
|
||||
- Print all P-states in dump mode
|
||||
- Added explicit requires for pcituils (#653560)
|
||||
- Output error in interactive mode if there is no tty (#657212)
|
||||
- Do not suggest ondemand when p4-clockmod scaling driver is used (#497167)
|
||||
- Fixed rpmlint warning about mixed tabs and spaces
|
||||
|
||||
* Wed Aug 25 2010 Adam Jackson <ajax@redhat.com> 1.13-1
|
||||
- powertop 1.13
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Tue Jan 06 2009 Adam Jackson <ajax@redhat.com> 1.11-1
|
||||
- powertop 1.11
|
||||
|
||||
* Thu Nov 20 2008 Adam Jackson <ajax@redhat.com>
|
||||
- Spec only change, fix URL.
|
||||
|
||||
* Thu Nov 6 2008 Josh Boyer <jwboyer@gmail.com> - 1.10-1
|
||||
- Update to latest release
|
||||
- Drop upstreamed patch
|
||||
|
||||
* Wed May 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.9-4
|
||||
- fix license tag
|
||||
|
||||
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.9-3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Tue Jan 22 2008 Adam Jackson <ajax@redhat.com> 1.9-2
|
||||
- Use full path when invoking hciconfig. (Ville Skyttä, #426721)
|
||||
|
||||
* Mon Dec 10 2007 Josh Boyer <jwboyer@gmail.com> 1.9-1
|
||||
- Update to latest release
|
||||
|
||||
* Mon Aug 20 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.8-1
|
||||
- Update to latest release
|
||||
|
||||
* Mon Jul 23 2007 Bill Nottingham <notting@redhat.com> 1.7-4
|
||||
- add patch to allow dumping output to stdout
|
||||
|
||||
* Mon Jul 09 2007 Adam Jackson <ajax@redhat.com> 1.7-3
|
||||
- powertop-1.7-strncpy.patch: Use strncpy() to avoid stack smash. Patch from
|
||||
Till Maas. (#246796)
|
||||
|
||||
* Thu Jul 05 2007 Adam Jackson <ajax@redhat.com> 1.7-2
|
||||
- Don't suggest disabling g-p-m. Any additional power consumption is more
|
||||
than offset by the ability to suspend.
|
||||
|
||||
* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 1.7-1
|
||||
- powertop 1.7.
|
||||
|
||||
* Mon Jun 11 2007 Adam Jackson <ajax@redhat.com> 1.6-1
|
||||
- powertop 1.6.
|
||||
|
||||
* Tue May 29 2007 Adam Jackson <ajax@redhat.com> 1.5-1
|
||||
- powertop 1.5.
|
||||
|
||||
* Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.3-1
|
||||
- powertop 1.3.
|
||||
|
||||
* Tue May 15 2007 Adam Jackson <ajax@redhat.com> 1.2-1
|
||||
- powertop 1.2. Fixes power reports on machines that report power in Amperes
|
||||
instead of Watts.
|
||||
|
||||
* Sun May 13 2007 Adam Jackson <ajax@redhat.com> 1.1-1
|
||||
- powertop 1.1.
|
||||
|
||||
* Fri May 11 2007 Adam Jackson <ajax@redhat.com> 1.0-1
|
||||
- Initial revision.
|
Loading…
Reference in New Issue
Block a user