- Rebased to 1.3.4
This commit is contained in:
parent
d2f2d80b48
commit
4eff2e66dc
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ powerpc-utils-1.2.2.tar.gz
|
||||
/v1.3.0.tar.gz
|
||||
/v1.3.1.tar.gz
|
||||
/v1.3.3.tar.gz
|
||||
/powerpc-utils-1.3.4.tar.gz
|
||||
|
@ -1,142 +0,0 @@
|
||||
2009-10-29 Stepan Kasal <skasal@redhat.com>
|
||||
|
||||
Make build with autoconf 2.59.
|
||||
|
||||
diff -urN powerpc-utils-1.2.2.orig/configure.ac powerpc-utils-1.2.2/configure.ac
|
||||
--- powerpc-utils-1.2.2.orig/configure.ac 2009-10-22 21:00:13.000000000 +0200
|
||||
+++ powerpc-utils-1.2.2/configure.ac 2009-10-29 15:41:58.000000000 +0100
|
||||
@@ -1,8 +1,9 @@
|
||||
# -*- Autoconf -*-
|
||||
# Process this file with autoconf to produce a configure script.
|
||||
|
||||
-AC_PREREQ([2.63])
|
||||
-AC_INIT([powerpc-utils], [1.2.0], [nfont@austin.ibm.com])
|
||||
+AC_PREREQ([2.59])
|
||||
+m4_include([ac_type_uint.m4])
|
||||
+AC_INIT([powerpc-utils], [1.2.2], [nfont@austin.ibm.com])
|
||||
AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_SRCDIR([src/rtas_ibm_get_vpd.c])
|
||||
|
||||
diff -urN powerpc-utils-1.2.2.orig/ac_type_uint.m4 powerpc-utils-1.2.2/ac_type_uint.m4
|
||||
--- powerpc-utils-1.2.2.orig/ac_type_uint.m4 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ powerpc-utils-1.2.2/ac_type_uint.m4 2009-10-29 16:04:41.000000000 +0100
|
||||
@@ -0,0 +1,119 @@
|
||||
+AC_DEFUN([AC_TYPE_INT8_T], [_AC_TYPE_INT(8)])
|
||||
+AC_DEFUN([AC_TYPE_INT16_T], [_AC_TYPE_INT(16)])
|
||||
+AC_DEFUN([AC_TYPE_INT32_T], [_AC_TYPE_INT(32)])
|
||||
+AC_DEFUN([AC_TYPE_INT64_T], [_AC_TYPE_INT(64)])
|
||||
+AC_DEFUN([AC_TYPE_UINT8_T], [_AC_TYPE_UNSIGNED_INT(8)])
|
||||
+AC_DEFUN([AC_TYPE_UINT16_T], [_AC_TYPE_UNSIGNED_INT(16)])
|
||||
+AC_DEFUN([AC_TYPE_UINT32_T], [_AC_TYPE_UNSIGNED_INT(32)])
|
||||
+AC_DEFUN([AC_TYPE_UINT64_T], [_AC_TYPE_UNSIGNED_INT(64)])
|
||||
+
|
||||
+# _AC_TYPE_INT(NBITS)
|
||||
+# -------------------
|
||||
+AC_DEFUN([_AC_TYPE_INT],
|
||||
+[
|
||||
+ AC_CACHE_CHECK([for int$1_t], [ac_cv_c_int$1_t],
|
||||
+ [ac_cv_c_int$1_t=no
|
||||
+ for ac_type in 'int$1_t' 'int' 'long int' \
|
||||
+ 'long long int' 'short int' 'signed char'; do
|
||||
+ AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_BOOL_COMPILE_TRY(
|
||||
+ [AC_INCLUDES_DEFAULT],
|
||||
+ [[0 < ($ac_type) (((($ac_type) 1 << ($1 - 2)) - 1) * 2 + 1)]])],
|
||||
+ [AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_BOOL_COMPILE_TRY(
|
||||
+ [AC_INCLUDES_DEFAULT],
|
||||
+ [[($ac_type) (((($ac_type) 1 << ($1 - 2)) - 1) * 2 + 1)
|
||||
+ < ($ac_type) (((($ac_type) 1 << ($1 - 2)) - 1) * 2 + 2)]])],
|
||||
+ [],
|
||||
+ [AS_CASE([$ac_type], [int$1_t],
|
||||
+ [ac_cv_c_int$1_t=yes],
|
||||
+ [ac_cv_c_int$1_t=$ac_type])])])
|
||||
+ test "$ac_cv_c_int$1_t" != no && break
|
||||
+ done])
|
||||
+ case $ac_cv_c_int$1_t in #(
|
||||
+ no|yes) ;; #(
|
||||
+ *)
|
||||
+ AC_DEFINE_UNQUOTED([int$1_t], [$ac_cv_c_int$1_t],
|
||||
+ [Define to the type of a signed integer type of width exactly $1 bits
|
||||
+ if such a type exists and the standard includes do not define it.]);;
|
||||
+ esac
|
||||
+])# _AC_TYPE_INT
|
||||
+
|
||||
+# _AC_TYPE_UNSIGNED_INT(NBITS)
|
||||
+# ----------------------------
|
||||
+AC_DEFUN([_AC_TYPE_UNSIGNED_INT],
|
||||
+[
|
||||
+ AC_CACHE_CHECK([for uint$1_t], [ac_cv_c_uint$1_t],
|
||||
+ [ac_cv_c_uint$1_t=no
|
||||
+ for ac_type in 'uint$1_t' 'unsigned int' 'unsigned long int' \
|
||||
+ 'unsigned long long int' 'unsigned short int' 'unsigned char'; do
|
||||
+ AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_BOOL_COMPILE_TRY(
|
||||
+ [AC_INCLUDES_DEFAULT],
|
||||
+ [[($ac_type) -1 >> ($1 - 1) == 1]])],
|
||||
+ [AS_CASE([$ac_type], [uint$1_t],
|
||||
+ [ac_cv_c_uint$1_t=yes],
|
||||
+ [ac_cv_c_uint$1_t=$ac_type])])
|
||||
+ test "$ac_cv_c_uint$1_t" != no && break
|
||||
+ done])
|
||||
+ case $ac_cv_c_uint$1_t in #(
|
||||
+ no|yes) ;; #(
|
||||
+ *)
|
||||
+ m4_bmatch([$1], [^\(8\|32\|64\)$],
|
||||
+ [AC_DEFINE([_UINT$1_T], 1,
|
||||
+ [Define for Solaris 2.5.1 so the uint$1_t typedef from
|
||||
+ <sys/synch.h>, <pthread.h>, or <semaphore.h> is not used.
|
||||
+ If the typedef were allowed, the #define below would cause a
|
||||
+ syntax error.])])
|
||||
+ AC_DEFINE_UNQUOTED([uint$1_t], [$ac_cv_c_uint$1_t],
|
||||
+ [Define to the type of an unsigned integer type of width exactly $1 bits
|
||||
+ if such a type exists and the standard includes do not define it.]);;
|
||||
+ esac
|
||||
+])# _AC_TYPE_UNSIGNED_INT
|
||||
+
|
||||
+
|
||||
+# AS_CASE(WORD, [PATTERN1], [IF-MATCHED1]...[DEFAULT])
|
||||
+# ----------------------------------------------------
|
||||
+# Expand into
|
||||
+# | case WORD in
|
||||
+# | PATTERN1) IF-MATCHED1 ;;
|
||||
+# | ...
|
||||
+# | *) DEFAULT ;;
|
||||
+# | esac
|
||||
+m4_define([_AS_CASE],
|
||||
+[ $1[)] m4_default([$2], [:]) ;;
|
||||
+])
|
||||
+m4_define([_AS_CASE_DEFAULT],
|
||||
+[ *[)] $1 ;;
|
||||
+])
|
||||
+m4_defun([AS_CASE],
|
||||
+[m4_ifval([$2$3],
|
||||
+[case $1 in
|
||||
+m4_transform_pair([_$0], [_$0_DEFAULT], m4_shift($@))dnl
|
||||
+esac
|
||||
+])dnl
|
||||
+])# AS_CASE
|
||||
+
|
||||
+
|
||||
+# m4_transform_pair(EXPRESSION, [END-EXPR = EXPRESSION], ARG...)
|
||||
+# --------------------------------------------------------------
|
||||
+# Perform a pairwise grouping of consecutive ARGs, by expanding
|
||||
+# EXPRESSION([ARG1], [ARG2]). If there are an odd number of ARGs, the
|
||||
+# final argument is expanded with END-EXPR([ARGn]).
|
||||
+#
|
||||
+# For example:
|
||||
+# m4_define([show], [($*)m4_newline])dnl
|
||||
+# m4_transform_pair([show], [], [a], [b], [c], [d], [e])dnl
|
||||
+# => (a,b)
|
||||
+# => (c,d)
|
||||
+# => (e)
|
||||
+#
|
||||
+# Please keep foreach.m4 in sync with any adjustments made here.
|
||||
+m4_define([m4_transform_pair],
|
||||
+[m4_if([$#], [0], [m4_fatal([$0: too few arguments: $#])],
|
||||
+ [$#], [1], [m4_fatal([$0: too few arguments: $#: $1])],
|
||||
+ [$#], [2], [],
|
||||
+ [$#], [3], [m4_default([$2], [$1])([$3])[]],
|
||||
+ [$#], [4], [$1([$3], [$4])[]],
|
||||
+ [$1([$3], [$4])[]$0([$1], [$2], m4_shift(m4_shift3($@)))])])
|
||||
+
|
@ -1,12 +1,12 @@
|
||||
Name: powerpc-utils
|
||||
Version: 1.3.3
|
||||
Release: 4%{?dist}
|
||||
Version: 1.3.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Utilities for PowerPC platforms
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPLv2
|
||||
URL: https://github.com/nfont/%{name}/
|
||||
Source0: https://github.com/nfont/%{name}/archive/v%{version}.tar.gz
|
||||
URL: https://github.com/ibm-power-utilities/powerpc-utils
|
||||
Source0: https://github.com/ibm-power-utilities/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
Source1: nvsetenv
|
||||
|
||||
ExclusiveArch: ppc %{power64}
|
||||
@ -24,8 +24,6 @@ Requires: %{name}-core = %{version}-%{release}
|
||||
Obsoletes: powerpc-utils-papr <= 1.1.7-6
|
||||
Provides: powerpc-utils-papr = 1.1.7-6
|
||||
|
||||
# This hack is needed only for platforms with autoconf < 2.63
|
||||
Patch0: powerpc-utils-autoconf.patch
|
||||
Patch1: powerpc-utils-1.2.15-man.patch
|
||||
Patch2: powerpc-utils-1.2.27-makefile.patch
|
||||
|
||||
@ -59,10 +57,6 @@ Utilities needed when installing Fedora on PowerPC systems.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
# This hack is needed only for platforms with autoconf < 2.63
|
||||
%if 0%{?fedora} < 9 && 0%{?rhel} < 6
|
||||
%patch0 -p1 -b .aconf
|
||||
%endif
|
||||
%patch1 -p1 -b .man
|
||||
%patch2 -p1 -b .makefile
|
||||
|
||||
@ -76,7 +70,7 @@ make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT FILES= RCSCRIPTS=
|
||||
install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/nvsetenv
|
||||
install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/nvsetenv
|
||||
|
||||
#define pkgdocdir {_datadir}/doc/{name}-{version}
|
||||
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
@ -165,8 +159,11 @@ ln -s nvram.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/nvsetenv.8.gz
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 10 2017 Dan Horák <dan[at]danny.cz> - 1.3.4-1
|
||||
- Rebased to 1.3.4
|
||||
|
||||
* Tue Oct 10 2017 Stephen Gallagher <sgallagh@redhat.com> - 1.3.3-4
|
||||
- Split critical components into powerpc-utils-core
|
||||
- Split critical components into powerpc-utils-core (#1463749)
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (v1.3.3.tar.gz) = cdd7c355b5fd7aa11f717282bad8a03e553249ca104018519faf72a36753e1ac2f6347af3d65acaadbffd0906fd5835d8b6a49dbd545d0a2519b26cbaf9d96ae
|
||||
SHA512 (powerpc-utils-1.3.4.tar.gz) = a53a5d0cf8fc3eb5dc165b8f563b5c057e727c1473eaf4b8dfe868cd948be1fa966109daa848b9e838a54a602b743e9b25e2d5d86141cca991432f3aab015b17
|
||||
|
Loading…
Reference in New Issue
Block a user