Fix makefile
Upstream v1.2.22 re-organized Makefile.am. Hence applying additional patch (man page patch) failed. This patch fixes Makefile issue. Also splits man page patches into two separate patch. (one for actual man page and second one for Makefile). That way it will be easy to maintain. Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
This commit is contained in:
parent
7e1babb2a7
commit
390ad046d8
@ -297,33 +297,6 @@ diff -up powerpc-utils-1.2.15/man/ls-vscsi.8.man powerpc-utils-1.2.15/man/ls-vsc
|
||||
+was written by Brian King <brking@linux.vnet.ibm.com>.
|
||||
+.PP
|
||||
+This manual page was written by Roman Rakus <rrakus@redhat.com>.
|
||||
diff -up powerpc-utils-1.2.15/man/Makefile.am.man powerpc-utils-1.2.15/man/Makefile.am
|
||||
--- powerpc-utils-1.2.15/man/Makefile.am.man 2012-12-12 16:29:25.000000000 +0100
|
||||
+++ powerpc-utils-1.2.15/man/Makefile.am 2013-01-16 15:44:18.903758484 +0100
|
||||
@@ -2,5 +2,7 @@ dist_man_MANS = activate_firmware.8 rtas
|
||||
uesensor.8 amsstat.1 serv_config.8 \
|
||||
update_flash.8 nvram.8 set_poweron_time.8 \
|
||||
bootlist.8 ofpathname.8 snap.8 hvcsadmin.8 \
|
||||
- rtas_dump.8 sys_ident.8 lparcfg.5 lparstat.8 lsslot.8
|
||||
+ rtas_dump.8 sys_ident.8 lparcfg.5 lparstat.8 lsslot.8 \
|
||||
+ lsdevinfo.8 rtas_event_decode.8 ls-vdev.8 lsprop.8 \
|
||||
+ drmgr.8 ls-veth.8 ppc64_cpu.8 nvsetenv.8 ls-vscsi.8
|
||||
|
||||
diff -up powerpc-utils-1.2.15/man/Makefile.in.man powerpc-utils-1.2.15/man/Makefile.in
|
||||
--- powerpc-utils-1.2.15/man/Makefile.in.man 2012-12-19 16:17:28.000000000 +0100
|
||||
+++ powerpc-utils-1.2.15/man/Makefile.in 2013-01-16 15:44:02.799331647 +0100
|
||||
@@ -137,7 +137,10 @@ dist_man_MANS = activate_firmware.8 rtas
|
||||
uesensor.8 amsstat.1 serv_config.8 \
|
||||
update_flash.8 nvram.8 set_poweron_time.8 \
|
||||
bootlist.8 ofpathname.8 snap.8 hvcsadmin.8 \
|
||||
- rtas_dump.8 sys_ident.8 lparcfg.5 lparstat.8 lsslot.8
|
||||
+ rtas_dump.8 sys_ident.8 lparcfg.5 lparstat.8 lsslot.8 \
|
||||
+ lsdevinfo.8 rtas_event_decode.8 ls-vdev.8 lsprop.8 \
|
||||
+ drmgr.8 ls-veth.8 ppc64_cpu.8 nvsetenv.8 ls-vscsi.8
|
||||
+
|
||||
|
||||
all: all-am
|
||||
|
||||
diff -up powerpc-utils-1.2.15/man/nvsetenv.8.man powerpc-utils-1.2.15/man/nvsetenv.8
|
||||
--- powerpc-utils-1.2.15/man/nvsetenv.8.man 2013-01-16 15:31:13.887591102 +0100
|
||||
+++ powerpc-utils-1.2.15/man/nvsetenv.8 2013-01-16 15:31:13.887591102 +0100
|
||||
|
44
powerpc-utils-1.2.22-makefile.patch
Normal file
44
powerpc-utils-1.2.22-makefile.patch
Normal file
@ -0,0 +1,44 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 01b258e..351f5e7 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -40,7 +40,16 @@ man_MANS = \
|
||||
man/sys_ident.8 \
|
||||
man/lparcfg.5 \
|
||||
man/lparstat.8 \
|
||||
- man/lsslot.8
|
||||
+ man/lsslot.8 \
|
||||
+ man/lsdevinfo.8 \
|
||||
+ man/rtas_event_decode.8 \
|
||||
+ man/ls-vdev.8 \
|
||||
+ man/lsprop.8 \
|
||||
+ man/drmgr.8 \
|
||||
+ man/ls-veth.8 \
|
||||
+ man/ppc64_cpu.8 \
|
||||
+ man/nvsetenv.8 \
|
||||
+ man/ls-vscsi.8
|
||||
|
||||
EXTRA_DIST += $(bin_SCRIPTS) $(sbin_SCRIPTS) $(man_MANS)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index b3f5360..8679e01 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -345,7 +345,16 @@ man_MANS = \
|
||||
man/sys_ident.8 \
|
||||
man/lparcfg.5 \
|
||||
man/lparstat.8 \
|
||||
- man/lsslot.8
|
||||
+ man/lsslot.8 \
|
||||
+ man/lsdevinfo.8 \
|
||||
+ man/rtas_event_decode.8 \
|
||||
+ man/ls-vdev.8 \
|
||||
+ man/lsprop.8 \
|
||||
+ man/drmgr.8 \
|
||||
+ man/ls-veth.8 \
|
||||
+ man/ppc64_cpu.8 \
|
||||
+ man/nvsetenv.8 \
|
||||
+ man/ls-vscsi.8
|
||||
|
||||
pseries_platform_SOURCES = src/common/pseries_platform.c src/common/pseries_platform.h
|
||||
librtas_error_SOURCES = src/common/librtas_error.c src/common/librtas_error.h
|
@ -1,6 +1,6 @@
|
||||
Name: powerpc-utils
|
||||
Version: 1.2.22
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Utilities for PowerPC platforms
|
||||
|
||||
Group: System Environment/Base
|
||||
@ -18,6 +18,7 @@ ExclusiveArch: ppc ppc64 ppc64le
|
||||
# This hack is needed only for platforms with autoconf < 2.63
|
||||
Patch0: powerpc-utils-autoconf.patch
|
||||
Patch1: powerpc-utils-1.2.15-man.patch
|
||||
Patch2: powerpc-utils-1.2.22-makefile.patch
|
||||
|
||||
# This is done before release of F12
|
||||
Obsoletes: powerpc-utils-papr < 1.1.6-3
|
||||
@ -36,6 +37,7 @@ Utilities for PowerPC platforms.
|
||||
%patch0 -p1 -b .aconf
|
||||
%endif
|
||||
%patch1 -p1 -b .man
|
||||
%patch2 -p1 -b .makefile
|
||||
|
||||
%build
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||
@ -120,6 +122,9 @@ ln -s nvram.8.gz $RPM_BUILD_ROOT/%{_mandir}/man8/nvsetenv.8.gz
|
||||
%doc README COPYRIGHT Changelog
|
||||
|
||||
%changelog
|
||||
* Mon Sep 22 2014 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 1.2.22-2
|
||||
- Fix makefile issue
|
||||
|
||||
* Mon Sep 22 2014 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 1.2.22
|
||||
- Update to latest upstream 1.2.22
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user