- new upstream version
- amsvis removed, this package has no longer anything with python - change the manual pages in the file list so that it does not depend on particular compression used - add patch for configure.ac on platforms with autoconf < 2.63 - use standard %configure/make in %build
This commit is contained in:
parent
7bd8501309
commit
2e7522f113
@ -1 +1 @@
|
||||
powerpc-utils-1.2.0.tar.gz
|
||||
powerpc-utils-1.2.2.tar.gz
|
||||
|
142
powerpc-utils-autoconf.patch
Normal file
142
powerpc-utils-autoconf.patch
Normal file
@ -0,0 +1,142 @@
|
||||
2009-10-29 Stepan Kasal <skasal@redhat.com>
|
||||
|
||||
Make build with autoconf 2.59.
|
||||
|
||||
diff -urN powerpc-utils-1.2.2.orig/configure.ac powerpc-utils-1.2.2/configure.ac
|
||||
--- powerpc-utils-1.2.2.orig/configure.ac 2009-10-22 21:00:13.000000000 +0200
|
||||
+++ powerpc-utils-1.2.2/configure.ac 2009-10-29 15:41:58.000000000 +0100
|
||||
@@ -1,8 +1,9 @@
|
||||
# -*- Autoconf -*-
|
||||
# Process this file with autoconf to produce a configure script.
|
||||
|
||||
-AC_PREREQ([2.63])
|
||||
-AC_INIT([powerpc-utils], [1.2.0], [nfont@austin.ibm.com])
|
||||
+AC_PREREQ([2.59])
|
||||
+m4_include([ac_type_uint.m4])
|
||||
+AC_INIT([powerpc-utils], [1.2.2], [nfont@austin.ibm.com])
|
||||
AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_SRCDIR([src/rtas_ibm_get_vpd.c])
|
||||
|
||||
diff -urN powerpc-utils-1.2.2.orig/ac_type_uint.m4 powerpc-utils-1.2.2/ac_type_uint.m4
|
||||
--- powerpc-utils-1.2.2.orig/ac_type_uint.m4 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ powerpc-utils-1.2.2/ac_type_uint.m4 2009-10-29 16:04:41.000000000 +0100
|
||||
@@ -0,0 +1,119 @@
|
||||
+AC_DEFUN([AC_TYPE_INT8_T], [_AC_TYPE_INT(8)])
|
||||
+AC_DEFUN([AC_TYPE_INT16_T], [_AC_TYPE_INT(16)])
|
||||
+AC_DEFUN([AC_TYPE_INT32_T], [_AC_TYPE_INT(32)])
|
||||
+AC_DEFUN([AC_TYPE_INT64_T], [_AC_TYPE_INT(64)])
|
||||
+AC_DEFUN([AC_TYPE_UINT8_T], [_AC_TYPE_UNSIGNED_INT(8)])
|
||||
+AC_DEFUN([AC_TYPE_UINT16_T], [_AC_TYPE_UNSIGNED_INT(16)])
|
||||
+AC_DEFUN([AC_TYPE_UINT32_T], [_AC_TYPE_UNSIGNED_INT(32)])
|
||||
+AC_DEFUN([AC_TYPE_UINT64_T], [_AC_TYPE_UNSIGNED_INT(64)])
|
||||
+
|
||||
+# _AC_TYPE_INT(NBITS)
|
||||
+# -------------------
|
||||
+AC_DEFUN([_AC_TYPE_INT],
|
||||
+[
|
||||
+ AC_CACHE_CHECK([for int$1_t], [ac_cv_c_int$1_t],
|
||||
+ [ac_cv_c_int$1_t=no
|
||||
+ for ac_type in 'int$1_t' 'int' 'long int' \
|
||||
+ 'long long int' 'short int' 'signed char'; do
|
||||
+ AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_BOOL_COMPILE_TRY(
|
||||
+ [AC_INCLUDES_DEFAULT],
|
||||
+ [[0 < ($ac_type) (((($ac_type) 1 << ($1 - 2)) - 1) * 2 + 1)]])],
|
||||
+ [AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_BOOL_COMPILE_TRY(
|
||||
+ [AC_INCLUDES_DEFAULT],
|
||||
+ [[($ac_type) (((($ac_type) 1 << ($1 - 2)) - 1) * 2 + 1)
|
||||
+ < ($ac_type) (((($ac_type) 1 << ($1 - 2)) - 1) * 2 + 2)]])],
|
||||
+ [],
|
||||
+ [AS_CASE([$ac_type], [int$1_t],
|
||||
+ [ac_cv_c_int$1_t=yes],
|
||||
+ [ac_cv_c_int$1_t=$ac_type])])])
|
||||
+ test "$ac_cv_c_int$1_t" != no && break
|
||||
+ done])
|
||||
+ case $ac_cv_c_int$1_t in #(
|
||||
+ no|yes) ;; #(
|
||||
+ *)
|
||||
+ AC_DEFINE_UNQUOTED([int$1_t], [$ac_cv_c_int$1_t],
|
||||
+ [Define to the type of a signed integer type of width exactly $1 bits
|
||||
+ if such a type exists and the standard includes do not define it.]);;
|
||||
+ esac
|
||||
+])# _AC_TYPE_INT
|
||||
+
|
||||
+# _AC_TYPE_UNSIGNED_INT(NBITS)
|
||||
+# ----------------------------
|
||||
+AC_DEFUN([_AC_TYPE_UNSIGNED_INT],
|
||||
+[
|
||||
+ AC_CACHE_CHECK([for uint$1_t], [ac_cv_c_uint$1_t],
|
||||
+ [ac_cv_c_uint$1_t=no
|
||||
+ for ac_type in 'uint$1_t' 'unsigned int' 'unsigned long int' \
|
||||
+ 'unsigned long long int' 'unsigned short int' 'unsigned char'; do
|
||||
+ AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_BOOL_COMPILE_TRY(
|
||||
+ [AC_INCLUDES_DEFAULT],
|
||||
+ [[($ac_type) -1 >> ($1 - 1) == 1]])],
|
||||
+ [AS_CASE([$ac_type], [uint$1_t],
|
||||
+ [ac_cv_c_uint$1_t=yes],
|
||||
+ [ac_cv_c_uint$1_t=$ac_type])])
|
||||
+ test "$ac_cv_c_uint$1_t" != no && break
|
||||
+ done])
|
||||
+ case $ac_cv_c_uint$1_t in #(
|
||||
+ no|yes) ;; #(
|
||||
+ *)
|
||||
+ m4_bmatch([$1], [^\(8\|32\|64\)$],
|
||||
+ [AC_DEFINE([_UINT$1_T], 1,
|
||||
+ [Define for Solaris 2.5.1 so the uint$1_t typedef from
|
||||
+ <sys/synch.h>, <pthread.h>, or <semaphore.h> is not used.
|
||||
+ If the typedef were allowed, the #define below would cause a
|
||||
+ syntax error.])])
|
||||
+ AC_DEFINE_UNQUOTED([uint$1_t], [$ac_cv_c_uint$1_t],
|
||||
+ [Define to the type of an unsigned integer type of width exactly $1 bits
|
||||
+ if such a type exists and the standard includes do not define it.]);;
|
||||
+ esac
|
||||
+])# _AC_TYPE_UNSIGNED_INT
|
||||
+
|
||||
+
|
||||
+# AS_CASE(WORD, [PATTERN1], [IF-MATCHED1]...[DEFAULT])
|
||||
+# ----------------------------------------------------
|
||||
+# Expand into
|
||||
+# | case WORD in
|
||||
+# | PATTERN1) IF-MATCHED1 ;;
|
||||
+# | ...
|
||||
+# | *) DEFAULT ;;
|
||||
+# | esac
|
||||
+m4_define([_AS_CASE],
|
||||
+[ $1[)] m4_default([$2], [:]) ;;
|
||||
+])
|
||||
+m4_define([_AS_CASE_DEFAULT],
|
||||
+[ *[)] $1 ;;
|
||||
+])
|
||||
+m4_defun([AS_CASE],
|
||||
+[m4_ifval([$2$3],
|
||||
+[case $1 in
|
||||
+m4_transform_pair([_$0], [_$0_DEFAULT], m4_shift($@))dnl
|
||||
+esac
|
||||
+])dnl
|
||||
+])# AS_CASE
|
||||
+
|
||||
+
|
||||
+# m4_transform_pair(EXPRESSION, [END-EXPR = EXPRESSION], ARG...)
|
||||
+# --------------------------------------------------------------
|
||||
+# Perform a pairwise grouping of consecutive ARGs, by expanding
|
||||
+# EXPRESSION([ARG1], [ARG2]). If there are an odd number of ARGs, the
|
||||
+# final argument is expanded with END-EXPR([ARGn]).
|
||||
+#
|
||||
+# For example:
|
||||
+# m4_define([show], [($*)m4_newline])dnl
|
||||
+# m4_transform_pair([show], [], [a], [b], [c], [d], [e])dnl
|
||||
+# => (a,b)
|
||||
+# => (c,d)
|
||||
+# => (e)
|
||||
+#
|
||||
+# Please keep foreach.m4 in sync with any adjustments made here.
|
||||
+m4_define([m4_transform_pair],
|
||||
+[m4_if([$#], [0], [m4_fatal([$0: too few arguments: $#])],
|
||||
+ [$#], [1], [m4_fatal([$0: too few arguments: $#: $1])],
|
||||
+ [$#], [2], [],
|
||||
+ [$#], [3], [m4_default([$2], [$1])([$3])[]],
|
||||
+ [$#], [4], [$1([$3], [$4])[]],
|
||||
+ [$1([$3], [$4])[]$0([$1], [$2], m4_shift(m4_shift3($@)))])])
|
||||
+
|
@ -1,23 +1,24 @@
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(0)")}
|
||||
%{!?python_version: %global python_version %(%{__python} -c "from distutils.sysconfig import get_python_version; print get_python_version()")}
|
||||
Name: powerpc-utils
|
||||
Version: 1.2.0
|
||||
Version: 1.2.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Utilities for PowerPC platforms
|
||||
|
||||
Group: System Environment/Base
|
||||
License: CPL
|
||||
URL: http://powerpc-utils.ozlabs.org/
|
||||
Source0: http://powerpc-utils.ozlabs.org/releases/powerpc-utils-%{version}.tar.gz
|
||||
URL: http://sourceforge.net/projects/%{name}/
|
||||
#Source0: http://downloads.sourceforge.net/projects/%{name}/%{name}-%{version}.tar.gz
|
||||
Source0: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source1: nvsetenv
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: doxygen automake python python-devel librtas-devel libservicelog-devel >= 1.0.1-2
|
||||
BuildRequires: doxygen automake librtas-devel libservicelog-devel >= 1.0.1-2
|
||||
|
||||
# should be fixed - libservicelog is not right name
|
||||
Requires: libservicelog
|
||||
ExclusiveArch: ppc ppc64
|
||||
|
||||
Patch1: powerpc-utils-1.2.0-chkconfig.patch
|
||||
# This hack is needed only for platforms with autoconf < 2.63
|
||||
Patch2: powerpc-utils-autoconf.patch
|
||||
|
||||
# This is done before release of F12
|
||||
Obsoletes: powerpc-utils-papr < 1.1.6-3
|
||||
@ -27,13 +28,18 @@ Provides: powerpc-utils-papr = 1.1.6-3
|
||||
Utilities for PowerPC platforms.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%setup -q
|
||||
%patch1 -p1 -b .chkconfig
|
||||
|
||||
# This hack is needed only for platforms with autoconf < 2.63
|
||||
%if 0%{?fedora} < 9 && 0%{?rhel} < 6
|
||||
%patch2 -p1 -b .aconf
|
||||
%endif
|
||||
|
||||
%build
|
||||
./bootstrap.sh
|
||||
./configure --prefix=/usr
|
||||
make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
@ -64,11 +70,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_sbindir}/bootlist
|
||||
%{_sbindir}/ofpathname
|
||||
%{_sbindir}/ppc64_cpu
|
||||
%{_sbindir}/lsdevinfo
|
||||
%{_sbindir}/lsprop
|
||||
%{_mandir}/man8/nvram.8.gz
|
||||
%{_mandir}/man8/snap.8.gz
|
||||
%{_mandir}/man8/bootlist.8.gz
|
||||
%{_mandir}/man8/ofpathname.8.gz
|
||||
%{_mandir}/man8/nvram.8*
|
||||
%{_mandir}/man8/snap.8*
|
||||
%{_mandir}/man8/bootlist.8*
|
||||
%{_mandir}/man8/ofpathname.8*
|
||||
|
||||
%{_sysconfdir}/rc.d/init.d/ibmvscsisd
|
||||
|
||||
@ -87,33 +94,25 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_sbindir}/sys_ident
|
||||
%{_sbindir}/drmgr
|
||||
%{_sbindir}/lsslot
|
||||
%{_bindir}/amsvis
|
||||
%{_bindir}/amsstat
|
||||
%{_mandir}/man8/update_flash.8.gz
|
||||
%{_mandir}/man8/activate_firmware.8.gz
|
||||
%{_mandir}/man8/usysident.8.gz
|
||||
%{_mandir}/man8/usysattn.8.gz
|
||||
%{_mandir}/man8/set_poweron_time.8.gz
|
||||
%{_mandir}/man8/rtas_ibm_get_vpd.8.gz
|
||||
%{_mandir}/man8/serv_config.8.gz
|
||||
%{_mandir}/man8/uesensor.8.gz
|
||||
%{_mandir}/man8/hvcsadmin.8.gz
|
||||
%{_mandir}/man8/vscsisadmin.8.gz
|
||||
%{_mandir}/man8/ibmvscsis.sh.8.gz
|
||||
%{_mandir}/man8/ibmvscsis.conf.8.gz
|
||||
%{_mandir}/man8/rtas_dump.8.gz
|
||||
%{_mandir}/man8/sys_ident.8.gz
|
||||
%{_mandir}/man1/amsvis.1.gz
|
||||
%{_mandir}/man1/amsstat.1.gz
|
||||
%{_mandir}/man8/update_flash.8*
|
||||
%{_mandir}/man8/activate_firmware.8*
|
||||
%{_mandir}/man8/usysident.8*
|
||||
%{_mandir}/man8/usysattn.8*
|
||||
%{_mandir}/man8/set_poweron_time.8*
|
||||
%{_mandir}/man8/rtas_ibm_get_vpd.8*
|
||||
%{_mandir}/man8/serv_config.8*
|
||||
%{_mandir}/man8/uesensor.8*
|
||||
%{_mandir}/man8/hvcsadmin.8*
|
||||
%{_mandir}/man8/vscsisadmin.8*
|
||||
%{_mandir}/man8/ibmvscsis.sh.8*
|
||||
%{_mandir}/man8/ibmvscsis.conf.8*
|
||||
%{_mandir}/man8/rtas_dump.8*
|
||||
%{_mandir}/man8/sys_ident.8*
|
||||
%{_mandir}/man1/amsvis.1*
|
||||
%{_mandir}/man1/amsstat.1*
|
||||
%doc README COPYRIGHT Changelog
|
||||
|
||||
# pythonies
|
||||
%{python_sitelib}/powerpcAMS-%{version}-py%{python_version}.egg-info
|
||||
%{python_sitelib}/powerpcAMS/__init__.py*
|
||||
%{python_sitelib}/powerpcAMS/amsdata.py*
|
||||
%{python_sitelib}/powerpcAMS/amsnet.py*
|
||||
%{python_sitelib}/powerpcAMS/amswidget.py*
|
||||
|
||||
%post
|
||||
/sbin/chkconfig --add ibmvscsisd
|
||||
|
||||
@ -124,6 +123,14 @@ if [ $1 = 0 ] ; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Thu Oct 29 2009 Stepan Kasal <skasal@redhat.com> - 1.2.2-1
|
||||
- new upstream version
|
||||
- amsvis removed, this package has no longer anything with python
|
||||
- change the manual pages in the file list so that it does not depend on
|
||||
particular compression used
|
||||
- add patch for configure.ac on platforms with autoconf < 2.63
|
||||
- use standard %%configure/make in %%build
|
||||
|
||||
* Mon Aug 17 2009 Roman Rakus <rrakus@redhat.com> - 1.2.0-1
|
||||
- Bump tu version 1.2.0 - powerpc-utils and powerpc-utils-papr get merged
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user