diff --git a/postgresql-fix-xml2.patch b/postgresql-fix-xml2.patch
new file mode 100644
index 0000000..6b97017
--- /dev/null
+++ b/postgresql-fix-xml2.patch
@@ -0,0 +1,77 @@
+diff --git a/src/test/regress/expected/xml.out b/src/test/regress/expected/xml.out
+index 9b7b393..72f0be3 100644
+--- a/src/test/regress/expected/xml.out
++++ b/src/test/regress/expected/xml.out
+@@ -9,8 +9,6 @@ ERROR: invalid XML content
+ LINE 1: INSERT INTO xmltest VALUES (3, '', NULL, '');
+ xmlconcat
+ --------------
+@@ -212,16 +208,12 @@ DETAIL: line 1: xmlParseEntityRef: no name
+ &
+ ^
+ line 1: chunk is not well balanced
+-&
+- ^
+ SELECT xmlparse(content '&idontexist;');
+ ERROR: invalid XML content
+ DETAIL: line 1: Entity 'idontexist' not defined
+ &idontexist;
+ ^
+ line 1: chunk is not well balanced
+-&idontexist;
+- ^
+ SELECT xmlparse(content '');
+ xmlparse
+ ---------------------------
+@@ -240,11 +232,7 @@ DETAIL: line 1: Entity 'idontexist' not defined
+ &idontexist;
+ ^
+ line 1: Opening and ending tag mismatch: twoerrors line 1 and unbalanced
+-&idontexist;
+- ^
+ line 1: chunk is not well balanced
+-&idontexist;
+- ^
+ SELECT xmlparse(content '');
+ xmlparse
+ ---------------------
+@@ -268,16 +256,12 @@ DETAIL: line 1: xmlParseEntityRef: no name
+ &
+ ^
+ line 1: Opening and ending tag mismatch: invalidentity line 1 and abc
+-&
+- ^
+ SELECT xmlparse(document '&idontexist;');
+ ERROR: invalid XML document
+ DETAIL: line 1: Entity 'idontexist' not defined
+ &idontexist;
+ ^
+ line 1: Opening and ending tag mismatch: undefinedentity line 1 and abc
+-&idontexist;
+- ^
+ SELECT xmlparse(document '');
+ xmlparse
+ ---------------------------
+@@ -296,8 +280,6 @@ DETAIL: line 1: Entity 'idontexist' not defined
+ &idontexist;
+ ^
+ line 1: Opening and ending tag mismatch: twoerrors line 1 and unbalanced
+-&idontexist;
+- ^
+ SELECT xmlparse(document '');
+ xmlparse
+ ---------------------
diff --git a/postgresql.spec b/postgresql.spec
index e22df4e..bf9116b 100644
--- a/postgresql.spec
+++ b/postgresql.spec
@@ -67,7 +67,7 @@ Summary: PostgreSQL client programs
Name: postgresql
%global majorversion 9.4
Version: 9.4.5
-Release: 4%{?dist}
+Release: 5%{?dist}
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
# recognizes it as an independent license, so we do as well.
@@ -118,6 +118,7 @@ Patch5: postgresql-var-run-socket.patch
Patch6: postgresql-man.patch
Patch7: postgresql-perl-5.22-test-fail.patch
Patch8: postgresql-python3.5-tests.patch
+Patch9: postgresql-fix-xml2.patch
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex gawk help2man
BuildRequires: perl(ExtUtils::Embed), perl-devel
@@ -359,6 +360,7 @@ benchmarks.
%patch6 -p1
%patch7 -p1
%patch8 -p1
+%patch9 -p1
# We used to run autoconf here, but there's no longer any real need to,
# since Postgres ships with a reasonably modern configure script.
@@ -1188,6 +1190,9 @@ fi
%endif
%changelog
+* Thu Dec 16 2015 Pavel Kajaba - 9.4.5-5
+- fixed problem with xml2 test (rhbz#1286692)
+
* Thu Dec 3 2015 Pavel Kajaba - 9.4.5-4
- fixed short-circuit build