Update to version 08.04.0200
This commit is contained in:
parent
d98d1b588f
commit
e135c0653b
@ -1 +1 @@
|
|||||||
psqlodbc-08.04.0100.tar.gz
|
psqlodbc-08.04.0200.tar.gz
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
Miscellaneous changes to align psqlodbc with unixODBC 64-bit fixes.
|
|
||||||
|
|
||||||
|
|
||||||
diff -Naur psqlodbc-08.04.0100.orig/odbcapi30.c psqlodbc-08.04.0100/odbcapi30.c
|
|
||||||
--- psqlodbc-08.04.0100.orig/odbcapi30.c 2008-10-06 17:46:09.000000000 -0400
|
|
||||||
+++ psqlodbc-08.04.0100/odbcapi30.c 2009-08-17 23:40:02.000000000 -0400
|
|
||||||
@@ -118,13 +118,7 @@
|
|
||||||
SQLPOINTER CharacterAttribute,
|
|
||||||
SQLSMALLINT BufferLength,
|
|
||||||
SQLSMALLINT *StringLength,
|
|
||||||
-#if defined(_WIN64)
|
|
||||||
SQLLEN *NumericAttribute
|
|
||||||
-#elif defined(WITH_UNIXODBC) || defined(WIN32)
|
|
||||||
- SQLPOINTER NumericAttribute
|
|
||||||
-#else
|
|
||||||
- SQLLEN *NumericAttribute
|
|
||||||
-#endif
|
|
||||||
)
|
|
||||||
{
|
|
||||||
CSTR func = "SQLColAttribute";
|
|
||||||
diff -Naur psqlodbc-08.04.0100.orig/odbcapi30w.c psqlodbc-08.04.0100/odbcapi30w.c
|
|
||||||
--- psqlodbc-08.04.0100.orig/odbcapi30w.c 2009-03-22 10:17:10.000000000 -0400
|
|
||||||
+++ psqlodbc-08.04.0100/odbcapi30w.c 2009-08-17 23:40:02.000000000 -0400
|
|
||||||
@@ -262,11 +262,7 @@
|
|
||||||
SQLPOINTER pCharAttr,
|
|
||||||
SQLSMALLINT cbCharAttrMax,
|
|
||||||
SQLSMALLINT *pcbCharAttr,
|
|
||||||
-#if defined(WITH_UNIXODBC) || (defined(WIN32) && ! defined(_WIN64))
|
|
||||||
- SQLPOINTER pNumAttr
|
|
||||||
-#else
|
|
||||||
SQLLEN *pNumAttr
|
|
||||||
-#endif
|
|
||||||
)
|
|
||||||
{
|
|
||||||
CSTR func = "SQLColAttributeW";
|
|
@ -1,7 +1,7 @@
|
|||||||
Name: postgresql-odbc
|
Name: postgresql-odbc
|
||||||
Summary: PostgreSQL ODBC driver
|
Summary: PostgreSQL ODBC driver
|
||||||
Version: 08.04.0100
|
Version: 08.04.0200
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
URL: http://psqlodbc.projects.postgresql.org/
|
URL: http://psqlodbc.projects.postgresql.org/
|
||||||
@ -14,12 +14,10 @@ Source0: http://www.postgresql.org/ftp/odbc/versions/src/psqlodbc-%{version}.tar
|
|||||||
# available while building this RPM.) To generate: in psqlodbc source tree,
|
# available while building this RPM.) To generate: in psqlodbc source tree,
|
||||||
# aclocal -I . -I $PGSRC/config
|
# aclocal -I . -I $PGSRC/config
|
||||||
# then strip aclocal.m4 down to just the PGAC macros.
|
# then strip aclocal.m4 down to just the PGAC macros.
|
||||||
# BUT: as of 08.04.0100, configure.ac hasn't been updated to use PG8.4
|
# BUT: as of 08.04.0200, configure.ac hasn't been updated to use PG8.4
|
||||||
# macros, so keep using the previous version of acinclude.m4.
|
# macros, so keep using the previous version of acinclude.m4.
|
||||||
Source1: acinclude.m4
|
Source1: acinclude.m4
|
||||||
|
|
||||||
Patch1: 64bit-fixes.patch
|
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
BuildRequires: unixODBC-devel
|
BuildRequires: unixODBC-devel
|
||||||
BuildRequires: libtool automake autoconf postgresql-devel
|
BuildRequires: libtool automake autoconf postgresql-devel
|
||||||
@ -37,8 +35,6 @@ PostgreSQL system via ODBC (Open Database Connectivity).
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n psqlodbc-%{version}
|
%setup -q -n psqlodbc-%{version}
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# Some missing macros. Courtesy Owen Taylor <otaylor@redhat.com>.
|
# Some missing macros. Courtesy Owen Taylor <otaylor@redhat.com>.
|
||||||
cp -p %{SOURCE1} .
|
cp -p %{SOURCE1} .
|
||||||
|
|
||||||
@ -53,8 +49,7 @@ autoheader
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
%configure --with-unixodbc --with-odbcinst=%{_sysconfdir} \
|
%configure --with-unixodbc --disable-dependency-tracking
|
||||||
--disable-dependency-tracking
|
|
||||||
|
|
||||||
make
|
make
|
||||||
|
|
||||||
@ -83,6 +78,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc license.txt readme.txt docs/*
|
%doc license.txt readme.txt docs/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 30 2009 Tom Lane <tgl@redhat.com> 08.04.0200-1
|
||||||
|
- Update to version 08.04.0200
|
||||||
|
|
||||||
* Fri Aug 28 2009 Tom Lane <tgl@redhat.com> 08.04.0100-2
|
* Fri Aug 28 2009 Tom Lane <tgl@redhat.com> 08.04.0100-2
|
||||||
- Rebuild with new openssl
|
- Rebuild with new openssl
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user