Update to version 08.04.0100
This commit is contained in:
parent
dfd6a10441
commit
a65e01b1db
@ -1 +1 @@
|
|||||||
psqlodbc-08.03.0200.tar.gz
|
psqlodbc-08.04.0100.tar.gz
|
||||||
|
@ -1,9 +1,9 @@
|
|||||||
Miscellaneous changes to align psqlodbc with unixODBC 64-bit fixes.
|
Miscellaneous changes to align psqlodbc with unixODBC 64-bit fixes.
|
||||||
|
|
||||||
|
|
||||||
diff -Naur psqlodbc-08.03.0200.orig/odbcapi30.c psqlodbc-08.03.0200/odbcapi30.c
|
diff -Naur psqlodbc-08.04.0100.orig/odbcapi30.c psqlodbc-08.04.0100/odbcapi30.c
|
||||||
--- psqlodbc-08.03.0200.orig/odbcapi30.c 2006-11-14 10:29:25.000000000 -0500
|
--- psqlodbc-08.04.0100.orig/odbcapi30.c 2008-10-06 17:46:09.000000000 -0400
|
||||||
+++ psqlodbc-08.03.0200/odbcapi30.c 2009-02-16 13:05:58.000000000 -0500
|
+++ psqlodbc-08.04.0100/odbcapi30.c 2009-08-17 23:40:02.000000000 -0400
|
||||||
@@ -118,13 +118,7 @@
|
@@ -118,13 +118,7 @@
|
||||||
SQLPOINTER CharacterAttribute,
|
SQLPOINTER CharacterAttribute,
|
||||||
SQLSMALLINT BufferLength,
|
SQLSMALLINT BufferLength,
|
||||||
@ -18,10 +18,10 @@ diff -Naur psqlodbc-08.03.0200.orig/odbcapi30.c psqlodbc-08.03.0200/odbcapi30.c
|
|||||||
)
|
)
|
||||||
{
|
{
|
||||||
CSTR func = "SQLColAttribute";
|
CSTR func = "SQLColAttribute";
|
||||||
diff -Naur psqlodbc-08.03.0200.orig/odbcapi30w.c psqlodbc-08.03.0200/odbcapi30w.c
|
diff -Naur psqlodbc-08.04.0100.orig/odbcapi30w.c psqlodbc-08.04.0100/odbcapi30w.c
|
||||||
--- psqlodbc-08.03.0200.orig/odbcapi30w.c 2007-04-03 10:49:02.000000000 -0400
|
--- psqlodbc-08.04.0100.orig/odbcapi30w.c 2009-03-22 10:17:10.000000000 -0400
|
||||||
+++ psqlodbc-08.03.0200/odbcapi30w.c 2009-02-16 13:08:05.000000000 -0500
|
+++ psqlodbc-08.04.0100/odbcapi30w.c 2009-08-17 23:40:02.000000000 -0400
|
||||||
@@ -255,11 +255,7 @@
|
@@ -262,11 +262,7 @@
|
||||||
SQLPOINTER pCharAttr,
|
SQLPOINTER pCharAttr,
|
||||||
SQLSMALLINT cbCharAttrMax,
|
SQLSMALLINT cbCharAttrMax,
|
||||||
SQLSMALLINT *pcbCharAttr,
|
SQLSMALLINT *pcbCharAttr,
|
||||||
@ -33,27 +33,3 @@ diff -Naur psqlodbc-08.03.0200.orig/odbcapi30w.c psqlodbc-08.03.0200/odbcapi30w.
|
|||||||
)
|
)
|
||||||
{
|
{
|
||||||
CSTR func = "SQLColAttributeW";
|
CSTR func = "SQLColAttributeW";
|
||||||
diff -Naur psqlodbc-08.03.0200.orig/psqlodbc.h psqlodbc-08.03.0200/psqlodbc.h
|
|
||||||
--- psqlodbc-08.03.0200.orig/psqlodbc.h 2008-05-03 01:57:42.000000000 -0400
|
|
||||||
+++ psqlodbc-08.03.0200/psqlodbc.h 2009-02-16 13:02:22.000000000 -0500
|
|
||||||
@@ -235,9 +235,6 @@
|
|
||||||
#else
|
|
||||||
#define DRIVER_FILE_NAME "PSQLODBC25.DLL"
|
|
||||||
#endif /* ODBCVER 0x0300 */
|
|
||||||
-BOOL isMsAccess();
|
|
||||||
-BOOL isMsQuery();
|
|
||||||
-BOOL isSqlServr();
|
|
||||||
#else
|
|
||||||
#ifdef UNICODE_SUPPORT
|
|
||||||
#define DRIVER_FILE_NAME "psqlodbcw.so"
|
|
||||||
@@ -246,6 +243,10 @@
|
|
||||||
#endif
|
|
||||||
#endif /* WIN32 */
|
|
||||||
|
|
||||||
+BOOL isMsAccess();
|
|
||||||
+BOOL isMsQuery();
|
|
||||||
+BOOL isSqlServr();
|
|
||||||
+
|
|
||||||
#define NULL_CATALOG_NAME ""
|
|
||||||
|
|
||||||
/* ESCAPEs */
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Name: postgresql-odbc
|
Name: postgresql-odbc
|
||||||
Summary: PostgreSQL ODBC driver
|
Summary: PostgreSQL ODBC driver
|
||||||
Version: 08.03.0200
|
Version: 08.04.0100
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
URL: http://psqlodbc.projects.postgresql.org/
|
URL: http://psqlodbc.projects.postgresql.org/
|
||||||
@ -14,6 +14,8 @@ Source0: http://www.postgresql.org/ftp/odbc/versions/src/psqlodbc-%{version}.tar
|
|||||||
# available while building this RPM.) To generate: in psqlodbc source tree,
|
# available while building this RPM.) To generate: in psqlodbc source tree,
|
||||||
# aclocal -I . -I $PGSRC/config
|
# aclocal -I . -I $PGSRC/config
|
||||||
# then strip aclocal.m4 down to just the PGAC macros.
|
# then strip aclocal.m4 down to just the PGAC macros.
|
||||||
|
# BUT: as of 08.04.0100, configure.ac hasn't been updated to use PG8.4
|
||||||
|
# macros, so keep using the previous version of acinclude.m4.
|
||||||
Source1: acinclude.m4
|
Source1: acinclude.m4
|
||||||
|
|
||||||
Patch1: 64bit-fixes.patch
|
Patch1: 64bit-fixes.patch
|
||||||
@ -81,6 +83,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc license.txt readme.txt docs/*
|
%doc license.txt readme.txt docs/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 18 2009 Tom Lane <tgl@redhat.com> 08.04.0100-1
|
||||||
|
- Update to version 08.04.0100
|
||||||
|
|
||||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 08.03.0200-4
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 08.03.0200-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user