New version
Resolves: rhbz#2212596 Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com>
This commit is contained in:
parent
8d9e3a48bb
commit
973d98f3f8
@ -1,37 +0,0 @@
|
|||||||
commit a53fb4c34c8dc09e81ed0577df51a11bc5b7ae3e
|
|
||||||
Author: Tomas Korbar <tkorbar@redhat.com>
|
|
||||||
Date: Thu May 25 14:59:46 2023 +0200
|
|
||||||
|
|
||||||
Fix freed memory access in posttls-finger
|
|
||||||
|
|
||||||
diff --git a/src/posttls-finger/posttls-finger.c b/src/posttls-finger/posttls-finger.c
|
|
||||||
index 2f3a58e..d446583 100644
|
|
||||||
--- a/src/posttls-finger/posttls-finger.c
|
|
||||||
+++ b/src/posttls-finger/posttls-finger.c
|
|
||||||
@@ -1590,12 +1590,12 @@ static char *parse_destination(char *destination, char *def_service,
|
|
||||||
static void connect_remote(STATE *state, char *dest)
|
|
||||||
{
|
|
||||||
DNS_RR *addr;
|
|
||||||
- char *buf;
|
|
||||||
- char *domain;
|
|
||||||
- char *service;
|
|
||||||
|
|
||||||
/* When reconnecting use IP address of previous session */
|
|
||||||
if (state->addr == 0) {
|
|
||||||
+ char *buf;
|
|
||||||
+ char *domain;
|
|
||||||
+ char *service;
|
|
||||||
buf = parse_destination(dest, state->smtp ? "smtp" : "24",
|
|
||||||
&domain, &service, &state->port);
|
|
||||||
if (!state->nexthop)
|
|
||||||
@@ -1622,8 +1622,8 @@ static void connect_remote(STATE *state, char *dest)
|
|
||||||
|
|
||||||
if (level == TLS_LEV_INVALID
|
|
||||||
|| (state->stream = connect_addr(state, addr)) == 0) {
|
|
||||||
- msg_info("Failed to establish session to %s:%s via %s:%u: %s",
|
|
||||||
- dest, service, HNAME(addr), addr->port,
|
|
||||||
+ msg_info("Failed to establish session to %s via %s:%u: %s",
|
|
||||||
+ dest, HNAME(addr), addr->port,
|
|
||||||
vstring_str(state->why->reason));
|
|
||||||
continue;
|
|
||||||
}
|
|
10
postfix.spec
10
postfix.spec
@ -48,8 +48,8 @@
|
|||||||
|
|
||||||
Name: postfix
|
Name: postfix
|
||||||
Summary: Postfix Mail Transport Agent
|
Summary: Postfix Mail Transport Agent
|
||||||
Version: 3.8.0
|
Version: 3.8.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
URL: http://www.postfix.org
|
URL: http://www.postfix.org
|
||||||
License: (IBM and GPLv2+) or (EPL-2.0 and GPLv2+)
|
License: (IBM and GPLv2+) or (EPL-2.0 and GPLv2+)
|
||||||
@ -100,8 +100,6 @@ Patch10: pflogsumm-1.1.5-ipv6-warnings-fix.patch
|
|||||||
Patch11: postfix-3.4.4-chroot-example-fix.patch
|
Patch11: postfix-3.4.4-chroot-example-fix.patch
|
||||||
# rhbz#1931403, sent upstream
|
# rhbz#1931403, sent upstream
|
||||||
Patch13: pflogsumm-1.1.5-syslog-name-underscore-fix.patch
|
Patch13: pflogsumm-1.1.5-syslog-name-underscore-fix.patch
|
||||||
# fix freed memory access reported and fixed by upstream after 3.8.0
|
|
||||||
Patch14: postfix-3.8.0-posttls-finger.patch
|
|
||||||
|
|
||||||
# Optional patches - set the appropriate environment variables to include
|
# Optional patches - set the appropriate environment variables to include
|
||||||
# them when building the package/spec file
|
# them when building the package/spec file
|
||||||
@ -806,6 +804,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 6 2023 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.8.1-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#2212596
|
||||||
|
|
||||||
* Thu May 25 2023 Tomas Korbar <tkorbar@redhat.com> - 2:3.8.0-3
|
* Thu May 25 2023 Tomas Korbar <tkorbar@redhat.com> - 2:3.8.0-3
|
||||||
- Fix freed memory access
|
- Fix freed memory access
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (pflogsumm-1.1.5.tar.gz) = 994d660692dfea38a1dd9866d15f15035657e85131c1f5a2cd82baa5bd4ad987a00939cb5233f316d2090014c52ae68ef20db0c893f8634969484e0e74678f4d
|
SHA512 (pflogsumm-1.1.5.tar.gz) = 994d660692dfea38a1dd9866d15f15035657e85131c1f5a2cd82baa5bd4ad987a00939cb5233f316d2090014c52ae68ef20db0c893f8634969484e0e74678f4d
|
||||||
SHA512 (postfix-3.8.0.tar.gz) = a66956b0cc5eb6ad5ee926348b584ba5640586784aec794a84c40472faecb6313d46537c9f5696edfd8fda070591925a0cfaedc014e15bb3496195e5fb9ee4bd
|
SHA512 (postfix-3.8.1.tar.gz) = 9eb91f2baab327de22dd55fc5ff398de74856e30be461282f41b1801301873881a8f40ce061c16e0505d51d96aaf0eff8d0ac660e5f6c70c6125133f64a4ee80
|
||||||
|
Loading…
Reference in New Issue
Block a user